Jump to content

Upcoming Ally Crew Count Patch Read more... ×

Recommended Posts

So where is it???

You can only download version 1.1.7b from the mirror site. Going on my 4th day of trying to get my server working and I'd like to try this manager, since the manual way isn't working ( see my other thread ).

Your link is dead and there isn't a download link from your main site, only for Commander whatever. hehe.

Please update your server manager download link.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello @SparcMX the project was abandoned?

it is no longer possible to update the ASC to the latest version 😥

Edited by Rising

Share this post


Link to post
Share on other sites

Hello i installed the Server manager but it seem i ran into issues

Missing Servergrid.json

i did server installer and installed the server 2 times Cluster 1 Cluster 2 but he doesnt add them to cluster view or server control
 

1ineZ20.png

QBbWiY3.png

hvlGOk9.png

J0atoxU.png

Share this post


Link to post
Share on other sites
Posted (edited)

How to get Remote Shard Working cant get it to work (Solved)

Bug Report: Game.ini Gets Wiped Clean at Server Start

Edited by AkenoHimejima
Updated

Share this post


Link to post
Share on other sites

ASC v0.1.5.5b Released

This should hopefully address the issues posted here, apologies for not replying sooner.
When I'm in the dungeon coding, I read all the forums but rarely reply, I'm easily distracted.

Let me know how you go with this version, you'll need to grab the installer again (too many changes for a patch)
Grab it here

Share this post


Link to post
Share on other sites

Sorry if this has been answered.

I need to change my server name but I am not sure how any help will be appreciated.

Also how do you lock the server?

Awesome work and was really needed I was wanting to set up a server just for friends but was overwhelmed by the process.

Share this post


Link to post
Share on other sites

ASC - Patch 0.1.5.8b Released

  • Added more Game.ini and GUS.ini configurable options 
  • Fixed the “WorldFriendlyName” getting cleared when running the wizard.
  • Fixed the port spacing in the wizard (protecting the second query port)
  • Fixed missing elements in the ServerGrid.json output
  • Case ignored on true/false statements in Game.ini and GUS.ini
  • Unlocked more config controls on the Shard GUI

Restart ASC and the Auto Updater will kick in

Share this post


Link to post
Share on other sites

Is there a way to wipe map and players data using this program. If not do you know where those are stored so I can wipe my server. Also I don’t know if it’s been fully implemented yet but the grid editor won’t let you drag islands in just so you know. Other than that it’s really cool and very helpful. 

Share this post


Link to post
Share on other sites

cant drag and drop isles
when i edit the json with the extern servergrid editor and import the files into the server folder ASC starts with a error

 

Share this post


Link to post
Share on other sites
On 7/11/2019 at 9:43 AM, Laserdragon23 said:

Is there a way to wipe map and players data using this program. If not do you know where those are stored so I can wipe my server. Also I don’t know if it’s been fully implemented yet but the grid editor won’t let you drag islands in just so you know. Other than that it’s really cool and very helpful. 

To wipe the map you need to remove the savefiles from shootergame/saved/A1, A2, A3 etc (just delete the whole folder).  And delete the Redis database (.db) file from /Atlastools

21 hours ago, flex73 said:

cant drag and drop isles
when i edit the json with the extern servergrid editor and import the files into the server folder ASC starts with a error

I have fixed this issue in the upcoming patch

Share this post


Link to post
Share on other sites

Now that Atlas in on sale, I've started looking into it.  I'm starting a dedicated server for some friends who've shown an interest.  I have to say, this is one of the best server management programs I've seen.  Excellent work!  Keep it up.

A couple of questions:

  • How do I autostart a server after a shutdown/reboot?
  • How do I "re-add" a server instance that's disappeared off my cluster?  I had a 4 server cluster and the 4th one dropped off.
  • If I want to log into my own server on my own LAN, do I need to add it to my Steam servers like I do with ARK?

Share this post


Link to post
Share on other sites
On 7/27/2019 at 12:59 PM, Tovrin said:

Now that Atlas in on sale, I've started looking into it.  I'm starting a dedicated server for some friends who've shown an interest.  I have to say, this is one of the best server management programs I've seen.  Excellent work!  Keep it up.

A couple of questions:

  • How do I autostart a server after a shutdown/reboot?
  • How do I "re-add" a server instance that's disappeared off my cluster?  I had a 4 server cluster and the 4th one dropped off.
  • If I want to log into my own server on my own LAN, do I need to add it to my Steam servers like I do with ARK?

Glad you like it, still plenty of work to do :classic_ninja:

Autostart is not implemented yet because I'm still not happy with the auto-update system which currently has its own version of Autostart.  Hopefully this version addresses some issues I've been having and I can finally refactor the Autostart into its own class.

If you've lost an instance but the Shardx-x.json files are still there, delete ServerShards.xml and restart ASC.  I'll eventually write some code to flush this file automatically.

If your running on LAN, use localhost (127.0.0.1) or private address.  If you bind Atlas to your external IP and dont have a loopback configured you won't be able to query the server.

Share this post


Link to post
Share on other sites

ASC - Patch 0.1.6.5b Released

  • Refactored Auto-update functions and fixed a threading issue
  • Added TileMap Server components (Territory Map)
  • Fixed 'Cannot drag new island' on the Server Grid Editor
  • Fixed missing properties in ServerGrid.json output
  • Added 'Island Points' field to the SGE Island Instance dialog
  • Added support for DLC maps
  • Added more server config options
  • Optimized the performance counters and graph

Don't forget, when I release a patch, I also update the ASC-Setup.exe which is the Full Release.
If you encounter any issues after a patch I suggest trying a Full Install.

Share this post


Link to post
Share on other sites

SPARCMX thank you i have waited for a program like this A++ will be a patron as soon as i get my 3x3 up and running

 

Share this post


Link to post
Share on other sites

Also having this issue. I had my server password protected and when I started using this Server manager it seems its not password protecting the server anymore. The WorldAtlas Password does exists in servergrid.json. Maybe its because we are running the Blackwood Map?

Share this post


Link to post
Share on other sites
On 7/28/2019 at 6:22 AM, SparcMX said:

ASC - Patch 0.1.6.5b Released

  • Refactored Auto-update functions and fixed a threading issue
  • Added TileMap Server components (Territory Map)
  • Fixed 'Cannot drag new island' on the Server Grid Editor
  • Fixed missing properties in ServerGrid.json output
  • Added 'Island Points' field to the SGE Island Instance dialog
  • Added support for DLC maps
  • Added more server config options
  • Optimized the performance counters and graph

Don't forget, when I release a patch, I also update the ASC-Setup.exe which is the Full Release.
If you encounter any issues after a patch I suggest trying a Full Install.

so this will now work with blackwood?

Share this post


Link to post
Share on other sites

I was able to resolve this error by starting up the redis server when I ran into it @Banjaxe.  It is saying that it cannot connect to the redis server on the second line.  Its the third button down on the left side of the ui, it says "Redis Database" I just clicked it, and launched it with the defaults and it worked.

22 hours ago, Banjaxe said:

Getting this odd crash when I try to start my server 
67762617_2363330933987520_65739041003358

 

Share this post


Link to post
Share on other sites
On 8/7/2019 at 6:15 PM, CapArrow said:

anyone an idea how to run a blackwood server with this tool?

^

Share this post


Link to post
Share on other sites

Well... Sort of? lol
Basically, I set things up pretty much how it's shown on the developer's wiki page, except I used slightly different ports and changed the admin password (I also put in my server's "external IP" rather than the local or lan side ones, because i couldn't get it to work right otherwise. I'm *not* sure if that's how it's supposed to be, because the author uses different terminology than i do for some things, so i couldn't be certain i was completely understanding his instructions/notations).
However... Things get a little awkward here, because of what seems like a missing, or incompleteable step. I'll come back to this...
Anyway, after the basic setup, I selected "Cluster Shards" button near the center of the UI (user interface).
That brings up a bunch of server options. I changed a few of them, and used the "Add Configuration Option" to add several more (I figured it would be better to add the options here, than to put them into the ini or bat files like i had done on a previous manual 1x1 server i'd set up).
On the right side while on the same tab, I changed the server name (this never actually applied the way I expected it to) and where it said "Map Name", I clicked where it said "Ocean", and changed the selection to "Blackwood".
Then over on the upper left of the ui, I selected "Redis Database".
That brings up a small window where you can start or stop the redis thingy.
I started the redis db, then closed out that small window. The cmd-style redis window started up and said it was ready. and then....
Well, I did this a couple of times, and initially I was starting the server by hitting "Start Cluster", and then later on I was hitting "Start" over on the right side of the "Cluster Shards" tab just above the server name. Over the period of a couple of days, I started it using a couple of different variations, and to be honest I'm not really sure which is supposed to be the right method - BUT, I always started the redis *first*, and it, and the program were both set to run as admin.
we had various random bouts of luck actually getting connected to the server, but once anyone had gotten on at least once, it would show up in their favorites.
We also had to manually add the server external IP and port number to the "favorites" list on steam (visible by opening steam, then selecting view, then servers), and had to click "find games at this address". <<--although I'm not sure that would still be necessary now, do to other various changes i've made since the first couple of days.
Anyway, that "worked"... but I'm pretty sure it wasn't really done correctly. Or at least not *completely* correctly.
Which  brings me back to what I was saying about it seeming like there was a missing, or incomplete-able step.
Basically, as I was going through the sort of setup guide on the wiki, it got to the bottom of the page, and said something exporting things to the root folder using the grid editor.
But the problem is, I could figure out now way to do that.
I mean, i could *open* the grid editor just fine, but what was showing up in it, was the "Ocean" map, *not blackwood*.
That led me to think I probably needed to find and open a different .json file, to like, "edit" it, then export. But when clicking "edit", the only json file there, was not openable by the grid editor.
I looked through some other folders, but never found one that looked like it was the right thing.
So, basically, I was never able to actually complete the "export" step.
That is probably *also* why I could never add a server password, because in the previous 1x1 i'd done, the grid editor *was* how the password was added; it was basically put in as part of  the map/project while i was setting it up, *before exporting*.
So I'm assuming the reason the name I'd put isn't showing up, and that there's no password, is because i was never able to figure out how to do the map grid editor export part.
That may also be at least part of why it was so hard to get onto my server initially.
Oh, as a side note, when the server would show up in the in-game server list (it rarely showed up there, but when it did...) it was called something like atlas_68745.
That name was also showing up in the redis cmd window. aaaand, to find it, i may have had to go to the non-atlas section, but I really can't remember right now.
Anyway, it *did* work. 5 or six of us, some on lan, some from the internet, were all playing on it at once.
But some things were glitchy, and I don't know if it was working 100% the way it was supposed to, because i've never played the solo version of blackwood.
That's all I can really say about it for now off the top of my head. the steam/atlas update killed the server we were playing on, and I was *not* able to resurrect it.
I created a new one, but decided to wait on doing anything more with it until after the ASC update, and/or finding out how to do the export step correctly.
Hope something in there helps, if not, it sounds like more info will be coming along in the future :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×