Jump to content

PSA to Xbox players regarding low FPS Read more... ×
Unable to gain experience points in Freeports? Read more... ×
Firedragon

dedicated server [Anleitung] LAN & DEDICATED Server 2x2 Deutsch

Recommended Posts

Sind die Coords der Disco Zones nicht theoretisch egal, da sie ja nicht auf eine landfläche sondern auf einen Trigger reagieren?
Hab es aber auch mit dem Sheet gemacht und verschiedene Varianten ausgetestet.

Notfalls mach ich das nochmal neu mit dem sheet... wäre aber strange^^

Share this post


Link to post
Share on other sites

Ganz egal sind sie nicht was die WorldX / Y Adresse angeht, allerdings ist bei dir der Wurm drin.

Unbenannt.png

allowSea = X = Du kannst die Discovery mit dem Schiff freischalten
allowSea = O = Du musst auf die Insel gehen um die Discovery frei zu schalten
isManual = X = Der ManualName triggert die Discovery wenn sie im Einzugsbereich der Worldadresse ist in der richtigen Zone (Parent)


 

Share this post


Link to post
Share on other sites

Ich hab mich ursprünglich an die Anleitung von drac gehalten.
Dort war allow sea auf true gesetzt - Da es damit ursprünglich klappte hab ich es nicht weiter hinterfragt 😄
Generell in den richtigen Grids sind die Zonen jedoch - Eine Größe der einzelnen Zonen war bei drac nicht mit angegeben und ging auf 3x3 auch.

Ich seh auch gerade das es wohl meine Test.json war.
Auf dem Server ist es aktuell so eingetragen.

	{
          "name": "The Blue Stone of Power",
          "sizeX": 0.0,
          "sizeY": 0.0,
          "sizeZ": 0.0,
          "id": 1132,
          "xp": 150.0,
          "bIsManuallyPlaced": true,
          "ManualVolumeName": "PowerStone2",
          "explorerNoteIndex": 22,
          "allowSea": false,
          "worldX": 994401.9,
          "worldY": 399811.0,
          "rotation": 0.0
        }


Ich hab dir nochmal die aktuell auf dem Server laufende Json übermittelt.
Vor lauter rumgebastel komm ich langsam durcheinander ^^ sorry


PS: Die vorgelagerten DiscoZones zu den PowerSTones funktionieren auch problemlos.
Wurden durch IsManual nur in die Mitte des Grids geschoben.

Edited by Wikinger

Share this post


Link to post
Share on other sites

Hallo @FIREDRAGON beim Testen habe ich jetzt doch noch ein Problem das auch schon lange drin ist und habe es vielleicht erst jetzt gemerkt.

Ich bin bei 2X2 Grid in die rechte MAP "10" (Server1-0) gefahren und habe dort den Server verlassen. Beim Einstieg bekomme ich jetzt die Meldung#:

Network Failure Message Unable to query server info for invite. Ich komme also nicht auf den Server. Jetzt weiß ich nicht wo ich da Suchen muß. Weist du für diesen Fall etwas? :classic_sad:

OK der Fall wird schon in einem anderen Thread behandelt aber seid Januar und bis jetzt keine Lösung. 😭

Edited by MysteryDiver

Share this post


Link to post
Share on other sites

Ich habe heute nochmal alle Koords überprüft und korrigiert.
Ich habe die Rotationen der PVE Island mit Rotation übernommen.
Ich habe bei allen PowerStones "IsManual" auf true und "AllowSea" auf false gesetzt.
Ich habe nochmals geprüft ob alle DiscoZonen/PowerStones auf den richtigen Grids liegen.

Normale Discovery Zones funktionieren.
Discovery Zone wie "The Giant last Breath" auf den PvE Island funktionieren.
Beim Abholen des PowerStones wird dieser freigeschaltet und der MapMarker wird ebenfalls aktiviert(farbiges Icon).
Die Tänze werden freigeschaltet und die PowerStones dem Kompass hinzugefügt.

Es klappt also weiterhin alles bis auf die Discovery am PowerStone selber und die damit verbundene ExplorerNote.

Ich hab echt absolut keinen Ahnung woran es noch liegen kann/soll :classic_sad:

 


PS: 1zu1 nach https://docs.google.com/spreadsheets/d/1a-9t4KwN8_kKEg4n6tZcqLsv8p4ce2Kjaoh1Tu2LKMs/edit#gid=1992771100

 

Share this post


Link to post
Share on other sites
3 hours ago, zhuzhiyun said:

How to prohibit construction in Freeport? No setting order was found. Please help me.

You can disable claim flags and rise decay time, but prohibiting it is impossible.

You might want to use fire to cook or other things that newbies need until setting sail.

7 minutes ago, Wikinger said:

Ich hab echt absolut keinen Ahnung woran es noch liegen kann/soll :classic_sad:

Das hier hat schon einigen geholfen > PowerStone Insel entfernen + Discovery etc. > Insel neu setzen und Coordinaten anpassen sowie wipen.

Share this post


Link to post
Share on other sites

Ich hatte es mir zwar schon gedacht - habs aber dennoch gemacht.
Map nochmal komplett neu aufgebaut und siehe da - wieder exakt das selbe Fehlerbild.
Savefiles und DB wird vor jedem Test gewiped.. selbst den Atlas Server hab ich schon neu installiert.

Alles geht außer die DiscoZone und ExplorerNote beim abholen des PowerStones.
Langsam vergeht mir echt die Lust auf eine eigene Atlas Map....

Falls noch jemand Langeweile hat oder eventuell eine Idee hier der Link zur JSON
 

Edited by Wikinger

Share this post


Link to post
Share on other sites
2 hours ago, Wikinger said:

Ich hatte es mir zwar schon gedacht - habs aber dennoch gemacht.
Map nochmal komplett neu aufgebaut und siehe da - wieder exakt das selbe Fehlerbild.
Savefiles und DB wird vor jedem Test gewiped.. selbst den Atlas Server hab ich schon neu installiert.

Alles geht außer die DiscoZone und ExplorerNote beim abholen des PowerStones.
Langsam vergeht mir echt die Lust auf eine eigene Atlas Map....

Falls noch jemand Langeweile hat oder eventuell eine Idee hier der Link zur JSON
 

Funktioniert alles du hast bloß keine "," nach paar "True" und "False" in den Discovery Zonen gesetzt.. wenn du die ServerGrid.json mit dem ServerGrid Editor laedst zeigt er dir die Zeilen bei denen etwas nicht stimmt.. was ich aber noch nicht verstehe wieso du zwei Discovery Zonen hast wenn ich mich dem PowerStone naehere 1m davor wird "Arty Night" ausgeloest und wenn du den Key abgibst "The Orange Stone Of Power"

Screenshots

 

 

 

 

ServerGrid.zip

Edited by phlex

Share this post


Link to post
Share on other sites

I have disabled claim flags, but the durability of the players'ships and buildings will not decrease. How to make players'ships and buildings decay quickly。:classic_sad:

In addition, my free port is set up in the PVE mode.

Edited by zhuzhiyun

Share this post


Link to post
Share on other sites
3 hours ago, phlex said:

Funktioniert alles du hast bloß keine "," nach paar "True" und "False" in den Discovery Zonen gesetzt.. wenn du die ServerGrid.json mit dem ServerGrid Editor laedst zeigt er dir die Zeilen bei denen etwas nicht stimmt.. was ich aber noch nicht verstehe wieso du zwei Discovery Zonen hast wenn ich mich dem PowerStone naehere 1m davor wird "Arty Night" ausgeloest und wenn du den Key abgibst "The Orange Stone Of Power"

Screenshots

 

 

 

 

ServerGrid.zip

 

Arty Night ist eigentlich die Insel - Da solltest du die Discovery Zone beim betreten der Insel aufdecken.
The Orange Power Stone ging bei dir auf anhieb? ich teste derzeit immer mit PowerStone2 "The Blue Power Stone".

Ich teste nochmal mit dem orangenen...


PS: Ich habe jetzt die Json von dir genommen und nur die ID und das Passwort wieder angepasst - händisch.
Bei mir funktioniert die Discovery weder am blauen noch am orangenen PowerStone.

Wird das freischalten der explorernote irgendwie auf meinem pc vielleicht gespeichert und ich muss da was löschen? 😄

Edited by Wikinger

Share this post


Link to post
Share on other sites

RedisDatenbank  & alle ordner unter "saved" loeschen ich hatte genau deshalb mal Probleme mit Discovery Zonen..

probier mal auf g-portal unter "Atlas" mal eine meiner gesharten Maps ob auf denen bei dir Discovery Zonen funktionieren

Edited by phlex

Share this post


Link to post
Share on other sites

Hallo Phlex,

ich hab soeben mal deine 3x3 Map ausprobiert.
Selbes Fehlerbild - PowerStone bekomme ich , jedoch wird die DiscoveryZone sowie die ExplorerNote nicht geöffnet.
Getestet an PowerStone8 - Mit und ohne Mods.

Ich installiere jetzt mal bei mir Atlas komplett neu.

  • Like 1

Share this post


Link to post
Share on other sites

Hallo, ich habe einfach mal ein kleines Tool erstellt was die Location der Powerstone Inseln, GhostShip & BossLevel erkennt und die Quest generiert.

 

-> http://atlastools.reakenari.de/kraken_quest

--> Einfach den inhalt der ServerGrid.Json bei Json einfügen und Berechnen klicken

 

MfG Kyrium

  • Thanks 1

Share this post


Link to post
Share on other sites

Funktioniert für die Questline super!
Hatte es mal ausprobiert, in der Hoffnung es löst mein Problem 😄
leider nein - aber ansonsten eine super Erleichterung.

Share this post


Link to post
Share on other sites

@Wikinger versuche es jetzt mal hab en kleinen Patch aufgespielt der einige Funktionen hinzugeführt hat.

Share this post


Link to post
Share on other sites

Jap klappt wieder und zeigt auch Fehler an - wenn man sie absichtlich einbaut.
Bei mir war aber alles in Ordnung 😄

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Wir haben vor unseren Server zu wipen und nach Hardware Upgrade des RAM's von einem 2x2 auf 3x2 zu wechseln.

Für das Unterfangen wurden bereits alle Massnahmen ergriffen um die Programmierung fertig zu stellen.

Im Rahmen dessen habe ich mir @Kyrium 's Tool angesehen und einen Fehler festgestellt. Die Positionsangaben müssen
X.XXXXXX einhalten, ansonsten kann es zu Glitches im Server führen. z.B. Das Meer hängt in der Bewegungsanimation.

Warum eigentlich ein Wipe?

Die Frage ist einfach zu beantworten, ungleich zum Start von dem Tutorial sind jetzt ausreichend Inseln und Resourcen
bekannt um vollständig zu kochen sowie Mythical Blueprints verwenden zu können welche 6x je Resource benötigen.

Darüber hinaus ist es Server freundlicher ein gesundes Ballancing zu machen für die Zonen mit die RAM und Rechen-
auslastung gleichmässig verteilt ist. Sprich wir haben 26 Inseln (25 hätten gereicht + 1 weil ich sie wollte) die die Zonen
befüllen und genug Platz ist für den Kampf auf See oder spätere Änderungen durch mehr Spielfunktionalität / Updates.

Temperaturzonen bis auf Polar sowie alle Resourcen sind vorhanden:

MapImg.jpg

Alle Zonen im ungespielten Zustand verbrauchen 20GB RAM.

Unser " Central Maw " benötigt 780MB, jede andere Zone verbraucht zusätzlich je Insel zwischen 500 bis 600MB RAM.

Die CPU Auslastung eines i9 9900K's liegt bei verwendung aller 8 Cores je Zone bei 3-4%.

Der Neustart benötigt bis 45 Sekunden für den gesammten Atlas Server.

Edited by Firedragon

Share this post


Link to post
Share on other sites
Posted (edited)

Wo siehst Du das? Beim Quest Generator?

Quote

Im Rahmen dessen habe ich mir @Kyrium 's Tool angesehen und einen Fehler festgestellt. Die Positionsangaben müssen
X.XXXXXX einhalten, ansonsten kann es zu Glitches im Server führen. z.B. Das Meer hängt in der Bewegungsanimation.

Beim Quest sehe ich sowas (X=0.5,Y=0.166667), müssten diese somit immer 6 stellig sein?

 

Edited by Buccaneers

Share this post


Link to post
Share on other sites
6 minutes ago, Buccaneers said:

Beim Quest sehe ich sowas (X=0.5,Y=0.166667), müssten diese somit immer 6 stellig sein?

Testweise hatte ich sogar alle .ini's entfernt welche die Konfigurationen der Zonen enthält die ich gemacht
habe und mit minimalistischer ShooterGameServer.exe startline den Server gestartet was nicht geholfen hat.

(Ich habe ein riesiges Ballancing eingebracht mit das spielen angenehmer wird und die PVE etc. nicht op sind.)

Ich hatte z.B. X=0.5 und Y=0.75, erst nach ändern auf 0.500000 und 0.750000 ist der Glitch verschwunden.

 

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, Firedragon said:

Testweise hatte ich sogar alle .ini's entfernt welche die Konfigurationen der Zonen enthält die ich gemacht
habe und mit minimalistischer ShooterGameServer.exe startline den Server gestartet was nicht geholfen hat.

(Ich habe ein riesiges Ballancing eingebracht mit das spielen angenehmer wird und die PVE etc. nicht op sind.)

Ich hatte z.B. X=0.5 und Y=0.75, erst nach ändern auf 0.500000 und 0.750000 ist der Glitch verschwunden.

 

.. aber schon nur beim QuestEntries, richtig? (Finde ich interessant, wie ein Questline dieses beinflusst)

Edited by Buccaneers

Share this post


Link to post
Share on other sites

Jep, es reicht schon eine übersehene Leerzeile um einem das Atlas Server Leben schwer zu machen.

Leider hat dann auch noch der ServerGridEditor einen blöden Bug den ich schon vor längeren reportet habe und noch nicht gefixt wurde.

(Er nimmt bei der Inseleinstellung für den Schwierigkeitsgrad immer den " . " raus, so das aus z.B. 1.0 dann 10 wird und man Mobs bis
LVL 300 oder höher hat die KEIN Alpha sind. Hatte dann so Scherzeinstellungen wie 30 und LVL 1000 Mobs etc.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×