Jump to content

Recommended Posts

Hi guys

I opened up my project file. Control-Left click on the grid I wanted the spawn to be. Bottom-right corner, pasted the code at the earlier part of the thread. Export it. Then edit the json file. Noticed that the codes are before the server [], as compared to the official json which in the server template.

Start the server but endup as bootloop. Edit the json again to remove the spawn codes. Restart, and ihe server restarted.

Which part did i do wrong ? Wrong place for the spawn code to be at ?

 

UPDATE : Got it to work. Seems the coords was the issue.

Edited by enrell

Share this post


Link to post
Share on other sites
2 hours ago, enrell said:

Hi guys

I opened up my project file. Control-Left click on the grid I wanted the spawn to be. Bottom-right corner, pasted the code at the earlier part of the thread. Export it. Then edit the json file. Noticed that the codes are before the server [], as compared to the official json which in the server template.

Start the server but endup as bootloop. Edit the json again to remove the spawn codes. Restart, and ihe server restarted.

Which part did i do wrong ? Wrong place for the spawn code to be at ?

"seamlessDataPort": 27000,
      "isHomeServer": false,
      "AdditionalCmdLineParams": "",
      "OverrideShooterGameModeDefaultGameIni": {},
      "floorZDist": 0,
      "utcOffset": 0,
      "transitionMinZ": 0,
      "GlobalBiomeSeamlessServerGridPreOffsetValues": "(BiomeZoneName=\"Temperate At Land\",PreOffsetMaxDistanceFromShore=100000.000000,PreOffsetTemperatureMultiplier=1.000000,PreOffsetTemperatureMultiplierMaxDistanceFromShore=1.000000,PreOffsetTemperatureAdditionMaxDistanceFromShore=-9.000000,PreOffsetTemperatureAddition=0.000000,PreOffsetTemperatureExponent=1.000000,PreOffsetTemperatureExponentMaxDistanceFromShore=1.000000,BiomeZoneNameAltDistanceName=\"Temperate Open Water\",BiomeZoneNameAltDistanceAmount=0.000000)",
      "GlobalBiomeSeamlessServerGridPreOffsetValuesOceanWater": "(BiomeZoneName=\"Temperate Ocean Water\",PreOffsetMaxDistanceFromShore=17500.000000,PreOffsetTemperatureMultiplier=1.000000,PreOffsetTemperatureMultiplierMaxDistanceFromShore=1.000000,PreOffsetTemperatureAdditionMaxDistanceFromShore=-31.000000,PreOffsetTemperatureAddition=-5.000000,PreOffsetTemperatureExponent=1.000000,PreOffsetTemperatureExponentMaxDistanceFromShore=1.000000,BiomeZoneNameAltDistanceName=\"Temperate Deep Ocean\",BiomeZoneNameAltDistanceAmount=0.500000)",
      "OceanDinoDepthEntriesOverride": "",
      "OceanEpicSpawnEntriesOverrideValues": "(NPCSpawnEntries=((NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/MeanWhale/MeanWhale_Character_BP.MeanWhale_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000))),NPCSpawnLimits=,MaxDesiredNumEnemiesMultiplier=12.000000)",
      "oceanFloatsamCratesOverride": "",
      "treasureMapLootTablesOverride": "",
      "oceanEpicSpawnEntriesOverrideTemplateName": "",
      "NPCShipSpawnEntriesOverrideTemplateName": "",

That's exactly what's in my json and all my creature spawns work respective for each grid.

Share this post


Link to post
Share on other sites

Somehow the whale did not spawn in another grid that ive added in. so sad. spent days looking for it. lol

Share this post


Link to post
Share on other sites
On 1/31/2019 at 12:25 AM, enrell said:

Somehow the whale did not spawn in another grid that ive added in. so sad. spent days looking for it. lol

I am having this issue as well it seems things in template sometimes dont get added correctly...

Share this post


Link to post
Share on other sites
1 minute ago, 1david25 said:

I am having this issue as well it seems things in template sometimes dont get added correctly...

I didnt add this in the template field. 

Its kinda funny tho, it works on 1 grid but not the other. I could have about 7 mean whale sightings in that grid but none in the other

Share this post


Link to post
Share on other sites
1 minute ago, enrell said:

I didnt add this in the template field. 

Its kinda funny tho, it works on 1 grid but not the other. I could have about 7 mean whale sightings in that grid but none in the other

Hmm Ive always been using the template system. Ive kinda given up on getting whales and stuff to spawn but I want to get it working again badly. I been pulling my hair out over it no matter what I do they wont spawn for me. Ive also tried modifying the sotd difficulty and I get jack all for results..

Share this post


Link to post
Share on other sites
9 minutes ago, 1david25 said:

Hmm Ive always been using the template system. Ive kinda given up on getting whales and stuff to spawn but I want to get it working again badly. I been pulling my hair out over it no matter what I do they wont spawn for me. Ive also tried modifying the sotd difficulty and I get jack all for results..

Im quite happy with my SOTD difficult. 1.8 gets me around 30-45 levels.

Share this post


Link to post
Share on other sites

Ok question does just adding the relevant code to override epic ocean box on a server to spawn whales mermaids ect, or are there other things i must do? Right now with Gportal i cant check using getallstate since they dont give access to gamelogs right now

Edited by Balsafer

Share this post


Link to post
Share on other sites
On ‎1‎/‎12‎/‎2019 at 3:59 AM, Yemesis said:

Trying to find the same , i think it's possible through the servergrideditor AKA Island editor  , if you CTRL +left click on any "unlocked" island there's a "Spawner override"  option where you could add some creatures spawner , as it was possible with ark but i don't know the correct form to write those lines under this Atlas island editor yet

@ASA you currenlty wrote a Kraken line not a Mermaid one and if you place it in i presume an ini file it will probably add General spawner , not tied to an island 

Edit 2 : nevermind it add those to Quest zone !
Source :https://www.drac346.net/

whales are under the server template types temperate, equatorial, polar, ect.... for the Ocean override spawners

Quote

(NPCSpawnEntries=((NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/GentleWhale/GentleWhale_SeaMonster_Character_BP.GentleWhale_SeaMonster_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000)),(NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/GentleWhale/GentleWhale_Character_BP.GentleWhale_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000))),NPCSpawnLimits=,MaxDesiredNumEnemiesMultiplier=4.000000)

 

Share this post


Link to post
Share on other sites

Please Help.

I have a 2x2 with all resources and quest (including end boss) setup. I have everything working except the whales or any epicspawnoverride creatures. Seems no matter what I do they will not spawn in. I have taken them out of the end boss level as I dont think anything spawns in that grid once you designate it endbosslevel.

So, questions.

1. I am using templates and putting the NPCSpawnEntries pasted into the box on the bottom right of the server grid through map editor. Does the override actually override the template? For instance, I am trying to spawn them in on my grid that is using the tropical template. Will it spawn all the epics I choose here or is it limited based on the template? 

2. My Atlas is very crowded (as you can imagine with full quest all resource and the empty endbosslevel). The grid I am trying to get working now has 9 islands. Is there any issue with the whales spawning near islands? Could there not be enough empty ocean for them to spawn?

3. I have read conflicting things on the coordinates. Someone had said they got it working using x0 y0 and Z defined indicating that the 0,0 is a random spawn within that grid. Others have indicated that I need to define the x,y coordinates for them to spawn. So, are X,Y needed? If so, do I pick a random ocean spot in that grid and use the x,y from the top right of the map editor screen? Do they need to be recalculated like the quest stones from Drac's guide? ( https://www.drac346.net/ )

4. I am on a hosted server using Nitrado. I saw someone else say they couldnt get them working on Nitrado. Is it possible a host issue? A side question to this, is it possible to use getallstate from within the game or without access to the server console? I have not been able to find a way to access any console or see the right log file with Nitrado any ideas?

I have tried a number of variations, but this is the code I am currently using pasted into the OceanEpicSpawnEntriesOverrideValues field. This is all I am pasting in there:
(NPCSpawnEntries=((NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/MeanWhale/MeanWhale_Character_BP.MeanWhale_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000))),(NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/GentleWhale/GentleWhale_Character_BP.GentleWhale_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000)),(NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/MeanWhale/MeanWhale_SeaMonster_Character_BP.MeanWhale_SeaMonster_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000)),(NPCsToSpawn=(BlueprintGeneratedClass'/Game/Atlas/Creatures/GentleWhale/GentleWhale_SeaMonster_Character_BP.GentleWhale_SeaMonster_Character_BP_C'),NPCsSpawnOffsets=((X=0.000000,Y=0.000000,Z=-700.000000)),NPCsToSpawnPercentageChance=(1.000000)),NPCSpawnLimits=,MaxDesiredNumEnemiesMultiplier=10.000000)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×