Jump to content

Sign in to follow this  
Akarillon

Cannot join my own server

Recommended Posts

Hi,

I've been trying to set up my own server for a few days now, but no matter what I try I cannot connect to my server.
The only message I get when trying to connect is "Network Failure Message", "Unable to query server info for invite".

I've used SteamCMD to download the server.
Used the Island Editor's basic maps, a 1x1 map, and tried making my own 1x1 from scratch. All were edited to fit the right ip, ports etc.
Edited the start batch script with my ip/ports/reduced MaxPlayers count.
I always use 127.0.0.1 for testing my own servers, but I've also tried my global ip, and my static local ip.

The server looks like it starts without any issues, it pops up in my Steam Server favourites, but does not appear in the in-game list or even the LAN tab of the Steam Servers list.
The only errors that appear on the server is the Steam host errors that everyone gets.

I've seen the same error being a problem on ARK servers, but they mostly blamed it on server vs client version mismatching. I know it's not a version fault, cause I've double checked it many times and I've now tried on both version 8.72 and the new 9.0 that recently came out.

I can connect to any other server, including unofficial servers, just not my own.

Anyone got any ideas?

Share this post


Link to post
Share on other sites

1: Close out of regis and ensure it is no longer running under task manager (sometimes it doesn't like to close!).

Run clearall_127.0.0.1.bat. 

Run redis-server_start.bat. Do not use the exe, use the bat to launch redis.

2. Delete/Backup your savegames

3. You've probably already done this but, There are 3 ports which need to looked at in servergrid editor. Queryport, gamePort, Seamless port. Use control and click on the grid to edit these. Use your public facing IPv4 address as seen on https://www.whatismyip.com/ for the ip address.

4. You've probably already done this but, Ensure the 2 ports and your public ipv4 ip is correct in your atlas server launch batch file.

5. Ensure that the 5 DatabaseConnections located under ServerGrid.ServerOnly.json are correct and are using your local ip for those 5 items in DatabaseConnections . These are also edited in the servergrid editor when you click edit (project -> edit).

It should look something like this:

    {
      "Name": "Default",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    },

6. Under the edit screen in servergrid editor, remove any baseserverarg content. It doesn't work in this current release and it may even be causing an issue in the json prevent your server from showing up in the game.

7. Ensure you've set a new and unique atlas ID for your server and you aren't using a template of someone elses atlas ID. 

8. Ensure you've exported both the ServerGrid.json and ServerGrid.ServerOnly.json and these are located in the atlas\ShooterGame folder. 

Share this post


Link to post
Share on other sites
4 minutes ago, Dunning said:

1: Close out of regis and ensure it is no longer running under task manager (sometimes it doesn't like to close!).

Run clearall_127.0.0.1.bat. 

Run redis-server_start.bat. Do not use the exe, use the bat to launch redis.

2. Delete/Backup your savegames

3. You've probably already done this but, There are 3 ports which need to looked at in servergrid editor. Queryport, gamePort, Seamless port. Use control and click on the grid to edit these. Use your public facing IPv4 address as seen on https://www.whatismyip.com/ for the ip address.

4. You've probably already done this but, Ensure the 2 ports and your public ipv4 ip is correct in your atlas server launch batch file.

5. Ensure that the 5 DatabaseConnections located under ServerGrid.ServerOnly.json are correct and are using your local ip for those 5 items in DatabaseConnections . These are also edited in the servergrid editor when you click edit (project -> edit).

It should look something like this:

    {
      "Name": "Default",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    },

6. Under the edit screen in servergrid editor, remove any baseserverarg content. It doesn't work in this current release and it may even be causing an issue in the json prevent your server from showing up in the game.

7. Ensure you've set a new and unique atlas ID for your server and you aren't using a template of someone elses atlas ID. 

8. Ensure you've exported both the ServerGrid.json and ServerGrid.ServerOnly.json and these are located in the atlas\ShooterGame folder. 

1. I am always using clearall_127.0.0.1.bat and redis-server_start.bat when I start redis.

2. Never been able to log on to my server, so no need.

3. Yes, I've remembered to change ip, and the 3 ports. I've been using QueryPort 57561, GamePort 5761 and SeamlessDataPort 27000.

4. Double, triple, octuple checked the batch file.

5. Never changed these settings, but I'll double check the .json file. All 5 connections have 127.0.0.1 as URL, 6379 as Port and foobared as Password.

6. BaseServerArgs is blank.

7. Might have neglected this on my last 1x1, so will re-test it.
Did not fix the problem.

8. I do a "local export all", and then copy the ServerGrid.json, ServerGrid.ServerOnly.json and the ServerGrid folder.

 

I've also tried connecting to the server via launch arguments on Steam. The error message does not pop up, but the game is stuck in a loading screen (tried leaving it for hours, but never finishes loading).
Also tried reinstalling the whole thing.

Share this post


Link to post
Share on other sites

A few things I can think of that might be causing a problem.

Make sure that the ports you are using (query, game and seamless) have been forwarded on your router.

Sometimes if the island hasn't been set to a home server, it won't show on the in game server list (although you should still be able to connect to it)

Edited by thegoob

Share this post


Link to post
Share on other sites
Just now, thegoob said:

A of things I can think of that might be causing a problem.

Make sure that the ports you are using (query, game and seamless) have been forwarded on your router.

Sometimes if the island hasn't been set to a home server, it won't show on the in game server list (although you should still be able to connect to it)

I have forwarded all ports in question, but that shouldn't be a problem when I'm using localhost to connect. The connection would never leave my computer, so the router would be arbitrary.

Share this post


Link to post
Share on other sites

In the servers section of the ServerGrid.json file, there is a value for ip, port, gameport and seamless data port. Do these four values match with what you are using?

Share this post


Link to post
Share on other sites
5 minutes ago, thegoob said:

In the servers section of the ServerGrid.json file, there is a value for ip, port, gameport and seamless data port. Do these four values match with what you are using?

"servers": [
    {
      "gridX": 0,
      "gridY": 0,
      "MachineIdTag": "",
      "ip": "x.x.x.x",
      "name": "HomeServer Freeport",
      "port": 57561,
      "gamePort": 5761,
      "seamlessDataPort": 27000,
      "isHomeServer": true,
      "AdditionalCmdLineParams": "",
      "OverrideShooterGameModeDefaultGameIni": {
        "NoClaimFlagDecayPeriodMultiplier": "4",
        "PlayerDefaultNoDiscoveriesMaxLevelUps": "8",
        "bClampHomeServerXP": "0",
        "ClampHomeServerXPLevel": "100"

Yes, these are the same values as what I'm using everywhere else.

Edited by Akarillon
Forgot the actual reply...

Share this post


Link to post
Share on other sites
Just now, Akarillon said:

I run the server on my own computer.

Ye, Atlas does not support local connection as of now. Only work around is to use NAT reflection / loopback, but majority of todays routers does not support this and have this hardcoded disabled as enabling this is a major security risk.

So in short, if your router dont support NAT reflections / loopback, you gonna need to host the server on a remote server outside your network.

Share this post


Link to post
Share on other sites
24 minutes ago, HelixU4 said:

Ye, Atlas does not support local connection as of now. Only work around is to use NAT reflection / loopback, but majority of todays routers does not support this and have this hardcoded disabled as enabling this is a major security risk.

So in short, if your router dont support NAT reflections / loopback, you gonna need to host the server on a remote server outside your network.

I can confirm this.  I've done everything that others have done that worked for them, but my router doesn't allow the loopback.  Best bet is to make it publicly accessible, password protect and run a VPN to connect to it.  I can send you some info on a VPN that is free if you are interested in that route.  I have a 9-grid server running at my house that I was never able to access while everyone outside my network could, so that was the route I went until they added some official support.

Share this post


Link to post
Share on other sites
53 minutes ago, HelixU4 said:

Ye, Atlas does not support local connection as of now. Only work around is to use NAT reflection / loopback, but majority of todays routers does not support this and have this hardcoded disabled as enabling this is a major security risk.

So in short, if your router dont support NAT reflections / loopback, you gonna need to host the server on a remote server outside your network.

Well that sucks. At least now I know why. Thanks for the help. 🙂

Share this post


Link to post
Share on other sites
41 minutes ago, micah68ph said:

I tried that as well to no avail

Sorry to hear that.

Have you update your server since last night? they had... a mishap.. with client at v9.x and servers at 8.x i wasnt able to connect even though i could find it, until i updated it.

Share this post


Link to post
Share on other sites
2 minutes ago, igneli said:

Sorry to hear that.

Have you update your server since last night? they had... a mishap.. with client at v9.x and servers at 8.x i wasnt able to connect even though i could find it, until i updated it.

I did update it but haven't tried connecting locally since then.  I have some changes to make to the game settings and will be updating later today and planned to test again then.  Damn real job has been keeping me busy today so I haven't been able to play with the changes much today 😃

Share this post


Link to post
Share on other sites
23 hours ago, igneli said:

There is a much easier workaround, i found it yesterday.

i was having the same issues. Try this:

https://steamcommunity.com/app/834910/discussions/0/1742230617607167193/

Note: Windows method, not sure about other systems 😞

(I'm now playing on same machine with a router that lacks NAT Loopback) 

This worked like a charm. Thank you for the workaround. 🙂

Share this post


Link to post
Share on other sites

I've had this error because my server files were out of date. I was able to check my current server version in the titlebar after opening the .bat file I use to start my server.

Edited by Eldeon

Share this post


Link to post
Share on other sites

The ARK server used to and the Conan server work fine.

I tried this
https://steamcommunity.com/app/834910/discussions/0/1742230617607167193/

as well. No good.

So to be clear please, I have a laptop running windows 10, acting like a server that is on my home network, and all ports forwarded, everything is running, but I cannot use it because it needs to be outside my network?  Am I understanding this correctly?

btw, I'm using a Netgear Nighthawk X6 AC3200 router.

I can see my server on my desktop but when I try and connect after putting in my password, I get server full or host connection timeout.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×