Jump to content

Draugr

Server Not Showing in Server List - gethostbyname failed ()

Recommended Posts

Posted (edited)

Hi.

I've been wrestling with this issue for a few days now. An Internet search brought up posts and discussions where people claim to have this issue, but I haven't seen a reliable resolution. I'm hoping someone here might be able to help me.

When I launch Atlas and go to the server list, I can see my server. My friend who lives on Florida cannot see my server in the list. 

Does anyone know how to resolve this issue? I did host an Atlas server a year ago or so and we were able to play fine. I've also run Ark, DnL, Conan Exiles, and other games as dedicated servers in the past and also had no issues.

Any help is appreciated.

Setting breakpad minidump AppID = 834910
[2020.04.19-18.10.12:562][  0]LogMemory: Platform Memory Stats for WindowsServer
[2020.04.19-18.10.12:562][  0]LogMemory: Process Physical Memory: 59.57 MB used, 59.57 MB peak
[2020.04.19-18.10.12:563][  0]LogMemory: Process Virtual Memory: 58.93 MB used, 59.06 MB peak
[2020.04.19-18.10.12:563][  0]LogMemory: Physical Memory: 4717.47 MB used, 32677.80 MB total
[2020.04.19-18.10.12:563][  0]LogMemory: Virtual Memory: 289.04 MB used, 134217728.00 MB total
[2020.04.19-18.10.12:846][  0]ATLAS Version: 405.9 (Rev. 119034)
[2020.04.19-18.10.12:847][  0]PID: 4972
[2020.04.19-18.10.30:031][  0]Primal Game Data Took 16.72 seconds

/* I intentionally placed these empty lines to make the gethostname lines of the server launch easier to see.

[2020.04.19-18.10.33:401][  0]SteamSocketsOpenSource: gethostname failed ()
[2020.04.19-18.10.33:401][  0]gethostbyname failed ()

/* I intentionally placed the above and below empty lines to make the gethostname lines of the server launch easier to see.

[2020.04.19-18.10.42:572][  0]Server Initializing with BattlEye Anti-Cheat Protection. If you do not wish to use BattlEye, please launch with -NoBattlEye
[2020.04.19-18.10.42:573][  0]BattlEye successfully started.
[2020.04.19-18.10.42:574][  0]Network range scales set to: 48 start, 77 end, 0.440000 endscale
[2020.04.19-18.10.43:114][  0]Server: "Temperate Region" has successfully started!
[2020.04.19-18.10.47:247][  0]2020.04.19_18.10.47: Force respawning Wild Dinos!
[2020.04.19-18.10.47:494][  0]Commandline: Ocean?AltSaveDirectoryName=A1?ServerX=0?ServerY=0?SeamlessIP=24.146.138.111?QueryPort=57560?Port=5760?RCONEnabled=True?RCO
NPort=47560?ServerAdminPassword=Removed?MaxPlayers=64?ReservedPlayerSlots=2 -ServerGameLog -ForceRespawnDinos -server
[2020.04.19-18.10.47:494][  0]Full Startup: 43.65 seconds (BP compile: 0.00 seconds)
[2020.04.19-18.10.47:494][  0]Number of cores 4
[2020.04.19-18.10.52:124][  2]Finished start-up log processing

 

 

Edited by Draugr

Share this post


Link to post
Share on other sites

[2020.04.19-18.10.33:401][ 0]SteamSocketsOpenSource: gethostname failed ()
[2020.04.19-18.10.33:401][ 0]gethostbyname failed ()

That's normal.  It happens with Ark servers as well.

Share this post


Link to post
Share on other sites
Just now, DeepSeaDuo said:

[2020.04.19-18.10.33:401][ 0]SteamSocketsOpenSource: gethostname failed ()
[2020.04.19-18.10.33:401][ 0]gethostbyname failed ()

That's normal.  It happens with Ark servers as well.

Ok. thanks

I gotta put my server back up and somehow try to see it online. My friend cant find it in the listing, but I see it. My server is in the same house, but on a separate network, so I should see the same thing my friend does or rather he should see what I see, but he claims he can't. 😞

I'll keep working on this to see if it is my friend with the issue or if my server is really not showing on the list.

Share this post


Link to post
Share on other sites

I believe the unofficial server lists have some threshold based on the ping times.  We don't all see the same servers in the list.

Share this post


Link to post
Share on other sites

Is there a way to direct connect to a server by directly entering an IP? I think Ark had such a feature, but it may have been Conan Exiles or some other game. I recall an option to enter a server IP and connect directly instead of having to connect through the list.

Share this post


Link to post
Share on other sites
Posted (edited)
15 minutes ago, Draugr said:

Is there a way to direct connect to a server by directly entering an IP? I think Ark had such a feature, but it may have been Conan Exiles or some other game. I recall an option to enter a server IP and connect directly instead of having to connect through the list.

I've just tried it with my Atlas server, it does work...
Use the Windows Key + R   and enter   steam://connect/xxx.xxx.xxx.xxx:QueryPort

Use your external IP address, and the QueryPort number of your "Home" server.

Edited by DeepSeaDuo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×