Jump to content

TakCan

Wild Pirates on Dedicated server

Recommended Posts

Out of curiosity has anyone been able to get the WPE to work on a dedicated server ? if so what settings are needed ? i have done a lot of testing and research but found nothing definitive yet. 

Thank You 

Share this post


Link to post
Share on other sites
Posted (edited)

As of right now there is a setting that shows up under GameUserSettings that is defaulted to False. If changed to True, it is overwritten and automatically changed to false upon server stsrt. I don't believe it is supported for unofficial servers yet. I've even tried using DefaultGaneUserSettings in Read Only yet it adds a line in each individual grid's GameUserSettings adjusting the value to false and ignoring my read only value. 

Edited by Roteck

Share this post


Link to post
Share on other sites

The patch notes say " "Wild Pirate Camps" option for singleplayer and non-dedicated sessions (enabled by default): take over each island across the ATLAS by attacking and claiming procedural enemy pirate camps, guarded by cannons, pirates wielding all sorts of weapons, and even powerful pirate ships! ". It would be nice to have some sort of confirmation from the devs
A. Does it actually work? and if no
B. When do you plan on fixing or telling everyone it doesn't work instead of admins being constantly badgered or servers being accused of not being set up correctly?

I get questioned about this on a daily basis. It would be nice if we didn't have to explain something that's not our fault.

Don't get me wrong, i think (and many others) that this is a great feature and would like the new challenge!

Share this post


Link to post
Share on other sites
41 minutes ago, Munkeh said:

The patch notes say " "Wild Pirate Camps" option for singleplayer and non-dedicated sessions (enabled by default): take over each island across the ATLAS by attacking and claiming procedural enemy pirate camps, guarded by cannons, pirates wielding all sorts of weapons, and even powerful pirate ships! ". It would be nice to have some sort of confirmation from the devs
A. Does it actually work? and if no
B. When do you plan on fixing or telling everyone it doesn't work instead of admins being constantly badgered or servers being accused of not being set up correctly?

I get questioned about this on a daily basis. It would be nice if we didn't have to explain something that's not our fault.

Don't get me wrong, i think (and many others) that this is a great feature and would like the new challenge!

Yeah absolutely. I hope they're leaving out dedicated servers was not a ploy to move players onto their official network. I just don't see why it wouldn't be available for unofficial of it was available to official and single player. Of course I'm no game developer but I would love to have something to do in this game. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello,

I'm also trying to make them work with no success

Here so far, what I've tried, found, it may help someone...
I tried to launch a non-dedicated server and activate wild pirates camp. I checked the game.ini and saw this addition at the end :
bUseWildPirateCamps=True

I tried this on the server... nothing
I saw nothing in the GameUSerSettings.ini related to WPE

I updated my map with the new editor, exporter the JSON. In it I can see coordinates for each island for wild pirates camps :
 

          "wildPirateCampSpawnPoints": [
            "-26646.427734 57032.546875 15726.286133",
            "-33327.203125 42065.792969 16517.349609",
            "-2896.923340 12302.686523 14360.617188",
            "63194.441406 1899.462524 27179.417969",
            "37241.488281 10570.250977 31606.826172"
          ],

I tried adding some of the new islands... still nothing

I activated the claiming system (was not activated on our server), I also activated settlement mode... but still no pirate camp....

I also tried to TP to these coordinates and I ended on another island... 

Edited by BadSpencer

Share this post


Link to post
Share on other sites
1 hour ago, BadSpencer said:

Hello,

I'm also trying to make them work with no success

Here so far, what I've tried, found, it may help someone...
I tried to launch a non-dedicated server and activate wild pirates camp. I checked the game.ini and saw this addition at the end :
bUseWildPirateCamps=True

I tried this on the server... nothing
I saw nothing in the GameUSerSettings.ini related to WPE

I updated my map with the new editor, exporter the JSON. In it I can see coordinates for each island for wild pirates camps :
 


          "wildPirateCampSpawnPoints": [
            "-26646.427734 57032.546875 15726.286133",
            "-33327.203125 42065.792969 16517.349609",
            "-2896.923340 12302.686523 14360.617188",
            "63194.441406 1899.462524 27179.417969",
            "37241.488281 10570.250977 31606.826172"
          ],

I tried adding some of the new islands... still nothing

I activated the claiming system (was not activated on our server), I also activated settlement mode... but still no pirate camp....

I also tried to TP to these coordinates and I ended on another island... 

It's just not supported yet for dedicated servers.

Share this post


Link to post
Share on other sites

You can activate WPC but you have to start a new server. Unfortunately they seem to be bugged. After playing for a few days they seemed to spawn again and again at the same place, even there is already one... So there were 4 budings, 4 canon towers, aso. at the same place. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×