Jump to content

Recommended Posts

Hi everyone,

when i start my Dedi Server crash this server.

LowLevelFatalError [File:H:\YARKUpdateTest\Projects\ShooterGame\Source\ShooterGame\Private\DatabaseShared_Redis.cpp] [Line: 144] 
Redis Failed To Connect! Check that it's running and connectable from here or edit ServerGrid.ServerOnly.json if this is incorrect. URL=127.0.0.1 EX="connect() failure"


VERSION: 207.9 
KERNELBASE.dll!UnknownFunction (0x00007ffb411d8e6c) + 0 bytes [UnknownFile:0]
ShooterGameServer.exe!FOutputDeviceWindowsError::Serialize() (0x00007ff6e84e65f3) + 0 bytes [h:\yarkupdatetest\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
ShooterGameServer.exe!FError::LowLevelFatal() (0x00007ff6e84bdfe6) + 0 bytes [h:\yarkupdatetest\engine\source\runtime\core\private\misc\outputdevice.cpp:354]
ShooterGameServer.exe!`FDatabaseRedisShared::GetOrCreateClientConnectionHelper'::`1'::catch$0() (0x00007ff6e99634ad) + 103 bytes [h:\yarkupdatetest\projects\shootergame\source\shootergame\private\databaseshared_redis.cpp:144]
MSVCR120.dll!UnknownFunction (0x00007ffb33406920) + 0 bytes [UnknownFile:0]
MSVCR120.dll!UnknownFunction (0x00007ffb333fe36d) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffb43fb2b03) + 0 bytes [UnknownFile:0]
ShooterGameServer.exe!FDatabaseRedisShared::GetOrCreateClientConnectionHelper() (0x00007ff6e7540acc) + 59 bytes [h:\yarkupdatetest\projects\shootergame\source\shootergame\private\databaseshared_redis.cpp:137]
ShooterGameServer.exe!FDatabaseRedisShared::GetOrCreateClientConnection() (0x00007ff6e75404ea) + 20 bytes [h:\yarkupdatetest\projects\shootergame\source\shootergame\private\databaseshared_redis.cpp:165]
ShooterGameServer.exe!UDatabase_ClusterInfo_Redis::Init() (0x00007ff6e75520fb) + 171 bytes [h:\yarkupdatetest\projects\shootergame\source\shootergame\private\database_clusterinfo_redis.cpp:95]
ShooterGameServer.exe!UShooterGameInstance::StartGameInstance() (0x00007ff6e7a112a4) + 20 bytes [h:\yarkupdatetest\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:306]
ShooterGameServer.exe!UGameEngine::Init() (0x00007ff6e8a2cfb6) + 0 bytes [h:\yarkupdatetest\engine\source\runtime\engine\private\gameengine.cpp:735]
ShooterGameServer.exe!UShooterEngine::Init() (0x00007ff6e79fc8d1) + 0 bytes [h:\yarkupdatetest\projects\shootergame\source\shootergame\private\shooterengine.cpp:396]
ShooterGameServer.exe!FEngineLoop::Init() (0x00007ff6e74fd44c) + 0 bytes [h:\yarkupdatetest\engine\source\runtime\launch\private\launchengineloop.cpp:2120]
ShooterGameServer.exe!GuardedMain() (0x00007ff6e74fcf42) + 12 bytes [h:\yarkupdatetest\engine\source\runtime\launch\private\launch.cpp:128]
ShooterGameServer.exe!GuardedMainWrapper() (0x00007ff6e74fd04a) + 5 bytes [h:\yarkupdatetest\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGameServer.exe!WinMain() (0x00007ff6e7502c2a) + 17 bytes [h:\yarkupdatetest\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGameServer.exe!__tmainCRTStartup() (0x00007ff6e994937d) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffb435f13d2) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffb43f354f4) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffb43f354f4) + 0 bytes [UnknownFile:0]

my servergrid.serveronly.json

{
  "LocalS3URL": "",
  "LocalS3AccessKeyId": "",
  "LocalS3SecretKey": "",
  "LocalS3BucketName": "",
  "LocalS3Region": "",
  "TribeLogConfig": {
    "MaxRedisEntries": 1000,
    "BackupMode": "off",
    "MaxFileHistory": 10,
    "HttpBackupURL": "",
    "HttpAPIKey": "",
    "S3URL": "",
    "S3AccessKeyId": "",
    "S3SecretKey": "",
    "S3BucketName": "",
    "S3KeyPrefix": ""
  },
  "SharedLogConfig": {
    "FetchRateSec": 60,
    "SnapshotCleanupSec": 900,
    "SnapshotRateSec": 1800,
    "SnapshotExpirationHours": 48,
    "BackupMode": "off",
    "MaxFileHistory": 10,
    "HttpBackupURL": "",
    "HttpAPIKey": "",
    "S3URL": "",
    "S3AccessKeyId": "",
    "S3SecretKey": "",
    "S3BucketName": "",
    "S3KeyPrefix": ""
  },
  "TravelDataConfig": {
    "BackupMode": "off",
    "MaxFileHistory": 10,
    "HttpBackupURL": "",
    "HttpAPIKey": "",
    "S3URL": "",
    "S3AccessKeyId": "",
    "S3SecretKey": "",
    "S3BucketName": "",
    "S3KeyPrefix": ""
  },
  "DatabaseConnections": [
    {
      "Name": "Default",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    },
    {
      "Name": "TribeDB",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    },
    {
      "Name": "TravelDataDB",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    },
    {
      "Name": "TerritoryDB",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    },
    {
      "Name": "LogDB",
      "URL": "127.0.0.1",
      "Port": 6379,
      "Password": "foobared"
    }
  ]
}

I have read the Wiki and other Tutorials, i dont know where is the problem!

Can anyone me help 

Thanks

  • Haha 1

Share this post


Link to post
Share on other sites

Redis Failed To Connect! Check that it's running and connectable from here or edit ServerGrid.ServerOnly.json if this is incorrect. URL=127.0.0.1 EX="connect() failure"

That's your error. It is not able to connect to Redis therefore it can not start the server. Is Redis running? Have you configured it correctly?

It also looks like you're having an error with Visual C++ try downloading and installing from here: https://www.majorgeeks.com/files/details/visual_c_redistributable_runtimes_aio_repack.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×