Jump to content

Recommended Posts

I started hosting a server last night for myself and a few friends, setup on a 2x2 grid, and we played for a few hours. They informed me treasure maps were bugged, so this morning I was following guides online for renaming the .jpg's and such to get it working again.

Anyway I was shutting down and opening the server grids and redis database multiple times to restart the server, and eventually I think I corrupted something, every time I launched a grid instance they would crash with a fatal error.

So I tried to restore an automated backup that ran last night at 4:30 AM from Cobian backup. I figured the only directories that needed to be restored are "ATLAS Dedicated Server\AtlasTools\RedisDatabase" and "ATLAS Dedicated Server\ShooterGame\Saved" however after restoring those folders, and attempting to rejoin my server, I am presented with the "create new character" screen as though our characters are deleted.

I tried this program https://redisdesktop.com/download to check the redis database, and it shows our characters there, so I know the database was not erased or anything... so how can I restore our characters?

Share this post


Link to post
Share on other sites

It sounds like your redis and saved worlds were out of sync when you restored them resulting in the forced character creation

If you're getting a message in your startup batch file along the lines of "Server LastSharedLogLineProcessed (number) is higher than the database log:ct (number), invalid state" then your saved worlds and the redis are not synced up correctly. Usually means the saved world files are farther ahead than the redis.
 

If you're not able to fix it by rolling back the world save even farther then you're pretty much just left with the option of starting over. Considering you only played for a few hours not much would be lost anyway and I'd recommend just starting fresh.

You should also not be restarting redis for any reason, it's likely this is what caused the issue if it didn't close correctly.

Did you fix your treasure map issue? Because there's a lot of reasons for why the blank maps occur

Share this post


Link to post
Share on other sites
Posted (edited)

This whole event lead to even worse corruption, eventually I couldn't get the server to launch at all, fatal errors every time. I ended up deleting everything and making a new custom map anyway because the default 2x2 grid map sucked. And yes I fixed the map issue, it was just getting the picture files named right in the right place.

So I can use ARKon to shut down the grids cleanly, but how can I cleanly shut down the redis in the future to avoid this corruption? I can't just never shut it down, servers need to reboot for windows updates, steam server updates, etc.

Edited by AYBFunkyMonkey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×