Jump to content

Sign in to follow this  
TrevorJD

Galleon construction: can't place structures due to "Requires nearby foundation supports"

Recommended Posts

It seems there's a problem with the foundation-chain tracking on ships.

I've built two galleons in the last few days. In both cases, I've not put in all the decks. The combat galleon has 3 or 4 and the cargo galleon has just two (the main deck and the uppermost stern castle deck). In both cases I've had trouble placing ceilings, walls, etc., getting the error "Requires nearby foundation supports", as illustrated with the imgur links below.

I have not tested with putting in the rest of the decks to see if it clears it up as I'm playing on official and don't care to waste the resources.

https://i.imgur.com/de6o08G.jpg

https://i.imgur.com/fez2Mki.jpg

https://i.imgur.com/72hlqDE.jpg

 

Share this post


Link to post
Share on other sites

Similar issue with me as I tried to build a structure at the front of the ship.

Share this post


Link to post
Share on other sites

Same issue running 4 decks for transport. Haven't tested front build yet but encountering this just trying to build a ramp from top rear deck to ladder... even with walls placed underneath multiple decks below for support.

Share this post


Link to post
Share on other sites

Thanks for the report folks, this issue is on our radar.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×