Jump to content

Recommended Posts

Has anyone successfully disabled the new option to set all islands in a homeserver as a spawn point?

On my private 4x4 server I have setup my one homeserver grid to contain other islands as well so that I may use the grid for more than just a spawn point. However, after the mega patch I went through the various config files, found the setting "AutoGenerateIslandSpawnRegions" set to true by default as expected and changed it to false. However, players are still able to spawn on all islands instead of being limited to just the freeport. I would like to disable this if at all possible as I have setup the map with the intention of having the freeport be the only possible spawn point without beds.

Has anyone had any luck turning this off? Please let me know it would be a big help.

Thanks!

 

P.S. It appears that all of the discovery zones on my homeserver grid have been disabled, making it impossible for my players to get the discovery XP for those islands. Any information on how to fix that would be greatly appreciated (if it's not related to the issue up above which I'm assuming it is).

Share this post


Link to post
Share on other sites

From my experience previous,
In the server grid editor, Load your map, then unlock Islands and hold Ctrl, and click on the islands in the freeport zone.
You should see a window "Edit Island Instance". in this window the Top option, "spawnPointRegionOverride:" should be set to -1 if you don't want people to spawn on the island.
and for Islands that are spawn points, they should be set 0,1,2 etc. 

Is this how yours is set up currently?
 

Share this post


Link to post
Share on other sites

I had to remove non-freeport islands and then the spawnpointregionoverride started working as intended. 

Share this post


Link to post
Share on other sites

For testing I removed the Spawn Template. After removing this I was able to choose different spawn options, however I always spawn on the same Island. I have a Grid with 9 Islands. 8 with Spawnzone -1 and 1 Freeport.

I am also not able to spawn in the Freeport. The Spawntemplate and Spawnoverwrite(=0) is set up correctly 

Share this post


Link to post
Share on other sites

I just launched my server this and I have the same issues.
Mine is setup as I mentioned above and I keep spawning on the same island not the freeport.
I will continue to tweak the settings and see if I can find a solution. 

Share this post


Link to post
Share on other sites
1 hour ago, GingerNinja said:

I just launched my server this and I have the same issues.
Mine is setup as I mentioned above and I keep spawning on the same island not the freeport.
I will continue to tweak the settings and see if I can find a solution. 

Would be great to let us know if you found anything.

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, Revy said:

Would be great to let us know if you found anything.

Well bud, 
I thought about how the spawns work, 0 = first spawn and so on.. so I decided to set 4 spawn codes 0-3 on random islands and the freeport island. Relaunched server and.. what do you know, I spawned on a totally different Island (which was set to -1) but the same island Every time I chose a spawn(north,south,east,west all spawned me on the same island).

So right now, I have changed all my islands to 0 and have set the freeport island as -1.. If this works, I will scream in glory.
*EDIT* Upon doing this reverse strategy I still spawned on the wrong island.
I am starting to think maybe I need to set the other Islands to something higher than the amount of spawns available. At this point, I am just chasing something I have no idea about, but Only time and effort will tell.

Edited by GingerNinja

Share this post


Link to post
Share on other sites
8 minutes ago, GingerNinja said:

Well bud, 
I thought about how the spawns work, 0 = first spawn and so on.. so I decided to set 4 spawn codes 0-3 on random islands and the freeport island. Relaunched server and.. what do you know, I spawned on a totally different Island (which was set to -1) but the same island Every time I chose a spawn(north,south,east,west all spawned me on the same island).

So right now, I have changed all my islands to 0 and have set the freeport island as -1.. If this works, I will scream in glory.

Would bee keen to know! That would be a good fix for now!

Share this post


Link to post
Share on other sites

Okay the above edit Worked..
So edit island and set the Free port island "spawnPointRegionOverride = 0".
Then for the other Islands, I set "spawnPointRegionOverride" as higher numbers.. starting at 6. (I made them unique just in case)
Example of my json.

"islandInstances": [
        {
          "name": "Trench_B",
          "id": 49,
          "spawnerOverrides": {},
          "minTreasureQuality": -1.0,
          "maxTreasureQuality": -1000.0,
          "useNpcVolumesForTreasures": false,
          "useLevelBoundsForTreasures": true,
          "prioritizeVolumesForTreasures": false,
          "islandPoints": -1,
          "islandTreasureBottleSupplyCrateOverrides": "",
          "spawnPointRegionOverride": 5,
          "islandWidth": 406500.0,
          "islandHeight": 406500.0,
          "worldX": 257694.313,
          "worldY": 1715214.5,
          "rotation": -360.9748
        },
        {
          "name": "Cay_J_EE_E",
          "id": 1,
          "spawnerOverrides": {},
          "minTreasureQuality": -1.0,
          "maxTreasureQuality": -1.0,
          "useNpcVolumesForTreasures": false,
          "useLevelBoundsForTreasures": true,
          "prioritizeVolumesForTreasures": false,
          "islandPoints": -1,
          "islandTreasureBottleSupplyCrateOverrides": "",
                    "spawnPointRegionOverride": 0,
          "islandWidth": 306000.0,
          "islandHeight": 306000.0,
          "worldX": 723351.1,
          "worldY": 2151563.25,
          "rotation": -315.1886
        },
        {
          "name": "Cay_F_EE_B",
          "id": 2,
          "spawnerOverrides": {},
          "minTreasureQuality": -1.0,
          "maxTreasureQuality": -1.0,
          "useNpcVolumesForTreasures": false,
          "useLevelBoundsForTreasures": true,
          "prioritizeVolumesForTreasures": false,
          "islandPoints": 1,
          "islandTreasureBottleSupplyCrateOverrides": "",
          "spawnPointRegionOverride": 6,
          "islandWidth": 204000.0,
          "islandHeight": 204000.0,
          "worldX": 727434.6,
          "worldY": 1714147.0,
          "rotation": 0.0
        },
        {
          "name": "Cay_G_EE",
          "id": 3,
          "spawnerOverrides": {},
          "minTreasureQuality": -1.0,
          "maxTreasureQuality": -1.0,
          "useNpcVolumesForTreasures": false,
          "useLevelBoundsForTreasures": true,
          "prioritizeVolumesForTreasures": false,
          "islandPoints": 1,
          "islandTreasureBottleSupplyCrateOverrides": "",
          "spawnPointRegionOverride": 7,
          "islandWidth": 204000.0,
          "islandHeight": 204000.0,
          "worldX": 203322.969,
          "worldY": 2509069.75,
          "rotation": 65.35402
        }, Etc...


If this works, just send me some grog or something In the mail somehow, I like RUM HAHA!
Hope this actually works for every one else 🙂

  • Thanks 1

Share this post


Link to post
Share on other sites

Hey guys, you have this all wrong.

You don't have to go through any of this hassle, just set your freeport spawn points to 0,1,2,3 and so on and make sure every other island outside of freeports is -1 which they should be by default and then input this into you gameusersettings.ini for each server bAutoGenerateIslandSpawnRegions=false

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Than0s said:

Hey guys, you have this all wrong.

You don't have to go through any of this hassle, just set your freeport spawn points to 0,1,2,3 and so on and make sure every other island outside of freeports is -1 which they should be by default and then input this into you gameusersettings.ini for each server bAutoGenerateIslandSpawnRegions=false

We didn't have it wrong, we were just doing it the only way we knew how.. haha 😉
Thanks mate, this is exactly the answer we all wanted. I will change my settings over later.
Again,
Thank you.

*Edit* I just realised, this is what The OP was saying doesn't work.... I will try it out my self any ways.

Edited by GingerNinja

Share this post


Link to post
Share on other sites
24 minutes ago, GingerNinja said:

We didn't have it wrong, we were just doing it the only way we knew how.. haha 😉
Thanks mate, this is exactly the answer we all wanted. I will change my settings over later.
Again,
Thank you.

*Edit* I just realised, this is what The OP was saying doesn't work.... I will try it out my self any ways.

This definately works, just make sure you put that setting line in the gameusersettings.ini under the ServerSettings...

I have it set this way on my server and it works perfectly fine I promise.

Share this post


Link to post
Share on other sites

Wow so many great answers thanks everybody! Looks like I will have some settings to play around with after work today.

 

Grogs on me!

Share this post


Link to post
Share on other sites
2 hours ago, Than0s said:

Hey guys, you have this all wrong.

You don't have to go through any of this hassle, just set your freeport spawn points to 0,1,2,3 and so on and make sure every other island outside of freeports is -1 which they should be by default and then input this into you gameusersettings.ini for each server bAutoGenerateIslandSpawnRegions=false

Sounds good, doesn’t work. That’s why we are using the workaround.

Share this post


Link to post
Share on other sites

I am having the same issue and I tried  b?AutoGenerateIslandSpawnRegions=False and it didn't work...

it keeps forcing this when I reboot server bAutoGenerateIslandSpawnRegions=false
AutoGenerateIslandSpawnRegions=True

 

Share this post


Link to post
Share on other sites

Some reason every time I reboot the server it forces it back to True and I can’t figure out where that’s coming from

Share this post


Link to post
Share on other sites

So, I can confirm that GINGERNINJA's solution does work. Changing the spawnpointregionoverrides has resolved the spawning problem. My players now consistently spawn on the freeport. However, I still have the issue that all my discover zones no longer work in my homeserver grid. Does anybody know why this changed and how to fix it?

Share this post


Link to post
Share on other sites

 the discovery points are disabled in home servers so that you cannot collect their points with suicide respawns changing home servers.

 

Share this post


Link to post
Share on other sites
On 4/12/2019 at 3:11 PM, upperking said:

Some reason every time I reboot the server it forces it back to True and I can’t figure out where that’s coming from

You have to stop the server before changing the config files.

Share this post


Link to post
Share on other sites
On 4/12/2019 at 2:08 PM, Revy said:

Sounds good, doesn’t work. That’s why we are using the workaround.

Does work, my server has no issues

Share this post


Link to post
Share on other sites

Add me to the list where  bAutoGenerateIslandSpawnRegions=false is not working for me either.  I'm wondering if server mode matters?  I'm using the old style PVE with multiple claim flags possible per island.

Share this post


Link to post
Share on other sites

Never did figure this one out. No matter if you use bAutoGenerateIslandSpawnRegions=false in game or AutoGenerateIslandSpawnRegions=false in usersettings, it adds AutoGenerateIslandSpawnRegions=true to usersettings at game launch. No window to modify.

If you only use freeport islands on home server it works fine, breaks every time you place a non-freeport island

Edited by N0ma13

Share this post


Link to post
Share on other sites

I've had this issue for a couple of weeks now I placed  Mnt_C_EE in the center of the freeports, with a north, south, east, west freeports. It would spawn me in the center island not matter which spawn I selected. Not only that but the center island was broken. Couldn't harvest and could just run through trees and rocks. Tried the AutoGenerateIslandSpawnRegions=False,   but nothing. Tried moving the island slightly, nothing. Tried wiping the server, nothing. In the end I just removed it.

Share this post


Link to post
Share on other sites

 

33 minutes ago, need4speedazx said:

I've had this issue for a couple of weeks now I placed  Mnt_C_EE in the center of the freeports, with a north, south, east, west freeports. It would spawn me in the center island not matter which spawn I selected. Not only that but the center island was broken. Couldn't harvest and could just run through trees and rocks. Tried the AutoGenerateIslandSpawnRegions=False,   but nothing. Tried moving the island slightly, nothing. Tried wiping the server, nothing. In the end I just removed it.

Moving the island is what caused the issue to start with. The only solution is to do a FULL wipe, or delete the island. start the server, save, shut down add the island and its back and working

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×