Jump to content

Recommended Posts

After adding more Grids (2x2 to 3x3) the new Server starting normaly but saying NO RCON. But every Server has a diffrent RCON Port. So what's the Problem?

Share this post


Link to post
Share on other sites

How do you get RCON to work? It says no rcon. While i can use other rcon tools to connect to the same port as set in server control.

Share this post


Link to post
Share on other sites
On 8/13/2019 at 8:36 AM, WoolyPenguin said:

How do you get RCON to work? It says no rcon. While i can use other rcon tools to connect to the same port as set in server control.

If the server ip address is not Internet facing (ie Private Address) and your using port mapping to allow the outside world to see your server, you will need to use the loopback ip (127.0.0.1)  This will happen mainly with VM based setups, barebone servers don't have this issue.

Share this post


Link to post
Share on other sites
On 8/1/2019 at 5:59 PM, Neitfall said:

Also having this issue. I had my server password protected and when I started using this Server manager it seems its not password protecting the server anymore. The WorldAtlas Password does exists in servergrid.json. Maybe its because we are running the Blackwood Map?

Yea Im having the same issue, cant find a solultion yet

Share this post


Link to post
Share on other sites

Hands down great work, I'd like to donate if you allow it, your program is very well done... Atlas should pay you for making such a great tool for their game!

 

  • Like 1

Share this post


Link to post
Share on other sites

ASC Patch 0.1.7.0b Released

  • Re-coded all Auto-Update functions, deals with a range of issues
  • Exposed save/shutdown/restart timers
  • Fixed a bug in the Schedule that stopped restarts
  • Added more server config options
  • Minor GUI Adjustments
  • Refactoring

Share this post


Link to post
Share on other sites

Not sure what I am doing wrong but the map in ASC is different than the map that is current. I reloaded the JSON but it shows completely different island configuration than is on the server. Suggestions?

Share this post


Link to post
Share on other sites
3 minutes ago, Nutcutt3r said:

Not sure what I am doing wrong but the map in ASC is different than the map that is current. I reloaded the JSON but it shows completely different island configuration than is on the server. Suggestions?

Have you tried reloading the ServerGrid.json in the "Service Menu"?  I know of some sysops who have different ServerGrid files under different names, ASC currently only supports ServerGrid.json  (for example, ServerGrid2x2.json is not valid)

Share this post


Link to post
Share on other sites

Yes, just tried again, not sure where to look but its strange. Is it because its Blackwood?

Share this post


Link to post
Share on other sites
7 minutes ago, Nutcutt3r said:

Yes, just tried again, not sure where to look but its strange. Is it because its Blackwood?

Yes, Blackwood does not use ServerGrid.json because it's a mod

Share this post


Link to post
Share on other sites
1 minute ago, SparcMX said:

Yes, Blackwood does not use ServerGrid.json because it's a mod

OK at least I am not going crazy then!  Thanks!

Share this post


Link to post
Share on other sites

i have try to work with this great program. Only i run to some issues.
1ste my servers are not popping up in Atlas can not join. i have forward al the ports.
2. the Rcon on my server is not working stay yellow.
Has somebody a video how to instal this.

 

Share this post


Link to post
Share on other sites

Thanks for that site. I have see this already a few times. But i am not able to connect the server.

 

Share this post


Link to post
Share on other sites

A single Atlas server requires 1 game port, 2 query ports and 1 seamless port.  The hidden query port is always +1 to the actual query port (eg 5760, 5761).  Seamless usually starts at 27000 and +1 for each shard.  Blackwood does not use a seamless port or redis db.
If you are trying to connect to your server, which also happens to be on the same machine your game is on, your router will need to support NAT Loopback (not all do).

Share this post


Link to post
Share on other sites

Thanks for the help my servers are working.

Next little challenge

I am not able to see the map in the game.
The map stay gray and when you open a treasure map is empty als wel.
Is there a step what i miss in the program or do i need to do someting manual ?

Share this post


Link to post
Share on other sites
13 hours ago, fireozzie said:

Thanks for the help my servers are working.

Next little challenge

I am not able to see the map in the game.
The map stay gray and when you open a treasure map is empty als wel.
Is there a step what i miss in the program or do i need to do someting manual ?

I think that is an Atlas bug that some have, maybe Antivirus or something not letting the game store the images.

See if there are any in C:\Program Files (x86)\Steam\steamapps\common\ATLAS\ShooterGame\Saved\MapImagesCache

This is a new one- C:\Program Files (x86)\Steam\steamapps\common\ATLAS\ShooterGame\Saved\NewMapImagesCache

  • Like 1

Share this post


Link to post
Share on other sites

After updating to the Version 0.1.7 our Server B1 and B2 are not starting correctly. It showing No RCON.

On both ShooterGameServer.exe [B1 and B2] this is the last state and nothing happens:

Setting breakpad minidump AppID = 834910
[2019.09.14-11.48.19:897][  0]LogMemory: Platform Memory Stats for WindowsServer
[2019.09.14-11.48.19:897][  0]LogMemory: Process Physical Memory: 61.55 MB used, 61.55 MB peak
[2019.09.14-11.48.19:897][  0]LogMemory: Process Virtual Memory: 51.39 MB used, 51.52 MB peak
[2019.09.14-11.48.19:897][  0]LogMemory: Physical Memory: 6271.46 MB used, 65373.27 MB total
[2019.09.14-11.48.19:898][  0]LogMemory: Virtual Memory: 4427.81 MB used, 134217728.00 MB total
[2019.09.14-11.48.20:357][  0]ATLAS Version: 218.31 (Rev. 117721)
[2019.09.14-11.48.20:357][  0]PID: 6644
[2019.09.14-11.52.11:374][  0]Primal Game Data Took 229.57 seconds
[2019.09.14-11.52.48:306][  0]SteamSocketsOpenSource: gethostname failed ()
[2019.09.14-11.52.48:306][  0]gethostbyname failed ()
[2019.09.14-11.53.58:652][  0]Server Initializing with BattlEye Anti-Cheat Protection. If you do not wish to use BattlEye, please launch with -NoBattlEye
[2019.09.14-11.53.58:654][  0]BattlEye successfully started.
[2019.09.14-11.53.58:656][  0]Network range scales set to: 48 start, 77 end, 0.440000 endscale


A other Server is showing this:

Setting breakpad minidump AppID = 834910
[2019.09.14-11.51.20:517][  0]LogMemory: Platform Memory Stats for WindowsServer
[2019.09.14-11.51.20:517][  0]LogMemory: Process Physical Memory: 61.57 MB used, 61.57 MB peak
[2019.09.14-11.51.20:518][  0]LogMemory: Process Virtual Memory: 51.23 MB used, 51.36 MB peak
[2019.09.14-11.51.20:518][  0]LogMemory: Physical Memory: 15286.99 MB used, 65373.27 MB total
[2019.09.14-11.51.20:518][  0]LogMemory: Virtual Memory: 4427.79 MB used, 134217728.00 MB total
[2019.09.14-11.51.20:975][  0]ATLAS Version: 218.31 (Rev. 117721)
[2019.09.14-11.51.20:975][  0]PID: 7088
[2019.09.14-11.52.11:091][  0]Primal Game Data Took 48.63 seconds
[2019.09.14-11.52.48:343][  0]SteamSocketsOpenSource: gethostname failed ()
[2019.09.14-11.52.48:344][  0]gethostbyname failed ()
[2019.09.14-11.53.40:244][  0]Server Initializing with BattlEye Anti-Cheat Protection. If you do not wish to use BattlEye, please launch with -NoBattlEye
[2019.09.14-11.53.40:245][  0]BattlEye successfully started.
[2019.09.14-11.53.40:247][  0]Network range scales set to: 48 start, 77 end, 0.440000 endscale
[2019.09.14-11.53.41:447][  0]Server: "Nekokeks9" has successfully started!
[2019.09.14-11.53.44:272][  0]Commandline: Ocean?AltSaveDirectoryName=C3?ServerX=2?ServerY=2?SeamlessIP=85.88.13.26?QueryPort=57016?Port=5716?RCONEnabled=True?RCONPort=47576?ServerAdminPassword=xxx?MaxPlayers=30?ReservedPlayerSlots=0 -server
[2019.09.14-11.53.44:272][  0]Full Startup: 152.25 seconds (BP compile: 0.00 seconds)
[2019.09.14-11.53.44:273][  0]Number of cores 12
[2019.09.14-11.53.46:591][  2]Finished start-up log processing

The Message Server: {NAME} has successfully started is not showing up anymore.

Any solutions? RCON Password is correct and Ports are open and diffrent. Redis Database is also working.

See Screenshot for more Informations: https://prnt.sc/p613rh

UPDATE: After ~2 Hours both Server crashed with this Error: [2019.09.14-13.31.39:274][  0]!!!HANG DETECTED!!!

Edited by lolman2079

Share this post


Link to post
Share on other sites

I get this crash quite often...

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentNullException: Value cannot be null.
Parameter name: key
   at System.ThrowHelper.ThrowArgumentNullException(ExceptionArgument argument)
   at System.Collections.Generic.Dictionary`2.FindEntry(TKey key)
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at System.Data.DataView.System.Collections.IList.get_Item(Int32 recordIndex)
   at DevExpress.Data.Helpers.BaseDataControllerHelper.GetRowDXErrorInfo(Int32 listSourceRow)
   at DevExpress.Data.DataController.GetErrorInfo(Int32 controllerRow)
   at DevExpress.Data.DataController.GetErrorText(Int32 controllerRow)
   at DevExpress.XtraGrid.Views.Base.ColumnView.GetColumnError(Int32 rowHandle, GridColumn column, String& error, ErrorType& errorType)
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.CalcDataRow(GridDataRowInfo ri, GridRow row, GridRow nextRow)
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.CalcRowsDrawInfo()
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.CalcGridInfo()
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.CalcCore(Graphics g, Rectangle bounds)
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.Calc(Graphics g, Rectangle bounds)
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.FullRecalcScroll(Graphics g, Rectangle bounds)
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.CalcAfterVertScrollCore(Graphics g, Rectangle bounds, Boolean useCache)
   at DevExpress.XtraGrid.Views.Grid.ViewInfo.GridViewInfo.CalcAfterVertScroll(Graphics g, Rectangle bounds, Boolean useCache)
   at DevExpress.XtraGrid.Views.Grid.GridView.RefreshRowsCore(Boolean useCache, Boolean afterScroll)
   at DevExpress.XtraGrid.Views.Grid.GridView.RefreshRows(Boolean useCache, Boolean afterScroll)
   at DevExpress.XtraGrid.Views.Grid.GridView.CalculateDataCore()
   at DevExpress.XtraGrid.Views.Grid.GridView.CalculateData()
   at DevExpress.XtraGrid.Views.Base.BaseView.Draw(GraphicsCache e)
   at DevExpress.XtraGrid.Views.Grid.GridView.Draw(GraphicsCache e)
   at DevExpress.XtraGrid.GridControl.OnPaintCore(PaintEventArgs e)
   at DevExpress.Utils.Drawing.ControlPaintHelper.PaintWithErrorHandling(PaintEventArgs paintEventArgs, Int32 layer)
   at DevExpress.Utils.Drawing.ControlPaintHelper.ProcessDirectXWMPaintCore(IntPtr hdc, Rectangle rectangle, Rectangle[] clipBounds)
   at DevExpress.Utils.Drawing.ControlPaintHelper.ProcessWMPaint(Message& m)
   at DevExpress.XtraGrid.GridControl.CheckProcessMsg(Message& m)
   at DevExpress.XtraGrid.GridControl.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3460.0 built by: NET472REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
ATLAS Server Control
    Assembly Version: 0.1.7.0
    Win32 Version: 0.1.7.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/ATLAS%20Server%20Control.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3451.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3429.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
DevExpress.Utils.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.Utils.v19.1.DLL
----------------------------------------
DevExpress.Data.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.Data.v19.1.DLL
----------------------------------------
DevExpress.XtraEditors.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraEditors.v19.1.DLL
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3260.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
ServerGridEditor
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/ServerGridEditor.DLL
----------------------------------------
AtlasGridDataLibrary
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/AtlasGridDataLibrary.DLL
----------------------------------------
Newtonsoft.Json
    Assembly Version: 12.0.0.0
    Win32 Version: 12.0.1.22727
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/Newtonsoft.Json.DLL
----------------------------------------
DevExpress.XtraLayout.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraLayout.v19.1.DLL
----------------------------------------
DevExpress.XtraBars.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraBars.v19.1.DLL
----------------------------------------
System.ComponentModel.DataAnnotations
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.ComponentModel.DataAnnotations/v4.0_4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll
----------------------------------------
PresentationFramework
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3429.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/PresentationFramework/v4.0_4.0.0.0__31bf3856ad364e35/PresentationFramework.dll
----------------------------------------
WindowsBase
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3429.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/WindowsBase/v4.0_4.0.0.0__31bf3856ad364e35/WindowsBase.dll
----------------------------------------
PresentationCore
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3429.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/PresentationCore/v4.0_4.0.0.0__31bf3856ad364e35/PresentationCore.dll
----------------------------------------
System.Xaml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3429.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xaml/v4.0_4.0.0.0__b77a5c561934e089/System.Xaml.dll
----------------------------------------
Anonymously Hosted DynamicMethods Assembly
    Assembly Version: 0.0.0.0
    Win32 Version: 4.7.3460.0 built by: NET472REL1LAST_B
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll
----------------------------------------
System.Numerics
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Runtime.Serialization
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3440.0 built by: NET472REL1LAST_B
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
DevExpress.XtraGrid.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraGrid.v19.1.DLL
----------------------------------------
DevExpress.Printing.v19.1.Core
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.Printing.v19.1.Core.DLL
----------------------------------------
DevExpress.Sparkline.v19.1.Core
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.Sparkline.v19.1.Core.DLL
----------------------------------------
DevExpress.XtraScheduler.v19.1.Core
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraScheduler.v19.1.Core.DLL
----------------------------------------
DevExpress.XtraScheduler.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraScheduler.v19.1.DLL
----------------------------------------
DevExpress.XtraScheduler.v19.1.Extensions
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.XtraScheduler.v19.1.Extensions.DLL
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
DevExpress.Images.v19.1
    Assembly Version: 19.1.4.0
    Win32 Version: 19.1.4.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/DevExpress.Images.v19.1.DLL
----------------------------------------
AutoUpdater.NET
    Assembly Version: 1.5.1.0
    Win32 Version: 1.5.1.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/AutoUpdater.NET.DLL
----------------------------------------
System.Data.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Data.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Data.Linq.dll
----------------------------------------
UIAutomationClient
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3429.0 built by: NET472REL1LAST_C
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/UIAutomationClient/v4.0_4.0.0.0__31bf3856ad364e35/UIAutomationClient.dll
----------------------------------------
RconSharp.Net45
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/RconSharp.Net45.DLL
----------------------------------------
RconSharp
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/RconSharp.DLL
----------------------------------------
System.Threading.Tasks
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Threading.Tasks/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Threading.Tasks.dll
----------------------------------------
Microsoft.Threading.Tasks
    Assembly Version: 1.0.12.0
    Win32 Version: 1.0.168.0
    CodeBase: file:///D:/ATLAS/AtlasServerControl/Framework/Microsoft.Threading.Tasks.DLL
----------------------------------------
System.Data.DataSetExtensions
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.3056.0 built by: NET472REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Data.DataSetExtensions/v4.0_4.0.0.0__b77a5c561934e089/System.Data.DataSetExtensions.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


 

Share this post


Link to post
Share on other sites

It also does not seem to be able to stay running on its own. If I leave the application open after managing the servers it eventually crashes with some error code. Turns the main section of the application white with a big red X through it with the Continue or Quit dialog that pops up. 

Share this post


Link to post
Share on other sites

The ASC has some Problems and crashed often.

I know that when you Reload the ServerGrid you have to restart the ASC ones then Reload the ServerGrid Again and Restart the ASC also again. After that the ASC starts normally.
Also a Problem is that sometimes ASC can not close every Server (When you make a Cluster Restart with the Events).
Sometime we also get a .NetFrameWork Error and when I skip sometimes the Button "Redis Database" is a red X. After restarting the ASC it works again.
@Roteck: Maybe restart the ASC and make sure that all Servers are closed and the Redis Database is also closed.

Good to Know maybe for some Custom User:

If you changes some "User Config" Settings in GameUserSettings like "PlayerDamageMultiplier", you need to make sure that this parameter stands in the GameUserSettings.ini. When you try to copy this with the Option in ASC like on A1 in GameUserSettings.ini stands PlayerDamageMultiplier=2.5 and you will copy this Settings to A2 then this PlayerDamageMultiplier is set in the Game.ini not in the GameUserSettings.ini. Maybe it is a Bug because when this or other custom Options it will automaticly written in Game.ini. 
I created a GameUserSettings.ini and copied on every folder just to make sure that every Server has the correct Settings in the correct file. 




 

Share this post


Link to post
Share on other sites
Posted (edited)

First off wonderful work but i am having an issue that only happens when I use ASC v0.1.7.0b, the ground seems to be missing. I have tried to reinstall and repair and nothing seems to fix it any ideas on what to do next?

20191006140334_1.jpg

 

Edited by ScreeeFenn

Share this post


Link to post
Share on other sites

@ScreeeFenn this is a ServerGrid Issue. You need to use a newer Version of the ServerGrid Editor (not the Editor in ASC). Just use this Editor https://github.com/GrapeshotGames/ServerGridEditor and import your ServerGrid.json and Export it again. Then replace it with the ServerGrid in your Atlas Folder. After that open ASC and then Service Menu --> Reload Server Grid. Then select the new exported File and select it. On my Server I need to restart the ASC after i reloaded the ServerGrid then reload it again and restart again and after that it worked.

Maybe it will also work on your Server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×