Jump to content

Recommended Posts

I'm aware of an issue with the auto-updater and have developed a solution, I'll be releasing a patch soon.

  • Like 1

Share this post


Link to post
Share on other sites

I just cant get this to work.  The old version worked great.  I cant load my old json. Put it in my shootergame folder.  Redist seems to just not work as the  server crashes immediately.  I try to install a completely fresh server and game and then create an entirely new json annnnnnnd I have no clue how to get all the 255 shards to be the same IP.  I cant edit half the things that show in the settings for the json.   Some user friendly instructions would be great.  Even when I try to run the program as admin it crashes out as well. Either already in use or a different error. I have tried three times to no avail.  Where am I going wrong?  How does this work for everyone else??

Share this post


Link to post
Share on other sites
Posted (edited)

This is a good program. I am currently running a 2X2 on an i5 4670 system with 16GB of RAM (Can be upgraded to 32GB of RAM, when/if I have the money). I am looking at in the future of upgrading to a 24-64 core/thread (maybe up to 128 threads) with 128-256GB RAM system for a 4X4 to 4X5 cluster. I have had an Ark server running before, until other games had become more popular, and it wasn't worth keeping it running. It has taken me a couple of days to get a 2X2 going stably, Just because Atlas is a different beast. At the moment I am having trouble with the maps in my server. I have tried to export the maps to the grid folder in the shootergame folder. and that hasn't worked (but it could be something that I am doing wrong). Also ASC is not reporting the players that are logged in. 

Edited by Austremdog

Share this post


Link to post
Share on other sites
9 hours ago, Breadventures said:

I just cant get this to work.  The old version worked great.  I cant load my old json. Put it in my shootergame folder.  Redist seems to just not work as the  server crashes immediately.  I try to install a completely fresh server and game and then create an entirely new json annnnnnnd I have no clue how to get all the 255 shards to be the same IP.  I cant edit half the things that show in the settings for the json.   Some user friendly instructions would be great.  Even when I try to run the program as admin it crashes out as well. Either already in use or a different error. I have tried three times to no avail.  Where am I going wrong?  How does this work for everyone else??

Make sure your Redis.conf password matches your ServerConfigOnly.json passwords, I'll be adding automatic Redis configuration soon.
With regards to instructions, we're working on a wiki 🙂

38 minutes ago, Austremdog said:

This is a good program. I am currently running a 2X2 on an i5 4670 system with 16GB of RAM (Can be upgraded to 32GB of RAM, when/if I have the money). I am looking at in the future of upgrading to a 24-64 core/thread (maybe up to 128 threads) with 128-256GB RAM system for a 4X4 to 4X5 cluster. I have had an Ark server running before, until other games had become more popular, and it wasn't worth keeping it running. It has taken me a couple of days to get a 2X2 going stably, Just because Atlas is a different beast. At the moment I am having trouble with the maps in my server. I have tried to export the maps to the grid folder in the shootergame folder. and that hasn't worked (but it could be something that I am doing wrong). Also ASC is not reporting the players that are logged in. 

ASC wont report the players if your RCON port is not set or blocked by firewall.  The main interface should actually say "No RCON" if this is the case.
Most of the work setting up ATLAS needs to be done with the Map Editor, ASC will only manage the cluster.

ASC Patch 0.1.3.0 has been released

  • Started work on the event scheduler
  • Sync Server is functional, still more to do
  • Changed the auto-update Versioning code
  • Started work on the Process restart service
  • Started work on Mod auto-update system
  • Updated the Shutdown Broadcast to show every second
  • Check all ASC settings before starting the cluster

Share this post


Link to post
Share on other sites
33 minutes ago, SparcMX said:

Make sure your Redis.conf password matches your ServerConfigOnly.json passwords, I'll be adding automatic Redis configuration soon.
With regards to instructions, we're working on a wiki 🙂

ASC wont report the players if your RCON port is not set or blocked by firewall.  The main interface should actually say "No RCON" if this is the case.
Most of the work setting up ATLAS needs to be done with the Map Editor, ASC will only manage the cluster.

ASC Patch 0.1.3.0 has been released

  • Started work on the event scheduler
  • Sync Server is functional, still more to do
  • Changed the auto-update Versioning code
  • Started work on the Process restart service
  • Started work on Mod auto-update system
  • Updated the Shutdown Broadcast to show every second
  • Check all ASC settings before starting the cluster

Oh. Looks like I have more learning to do. Yes the rcon say "no RCON", and I don't have the RCON port set in the ASC. I need to learn the Map editor a lot more. 

Share this post


Link to post
Share on other sites

Released a couple of patches to address bugs - 0.1.3.2b & 0.1.3.3b

Share this post


Link to post
Share on other sites
Posted (edited)

I get error when clicking to look at the GUS or other buttons.

 
I can not accept the ini files are not loaded. If you start the program with an existing server, the redis will not load properly.

 

Edited by Crusty

Share this post


Link to post
Share on other sites
2 hours ago, Crusty said:

I get error when clicking to look at the GUS or other buttons.

I can not accept the ini files are not loaded. If you start the program with an existing server, the redis will not load properly.

Make sure you have the server path set in "Server Installation" dialog.  Browse to and select the Atlas server folder, click OK.  Exit the "Server Installation" dialog.
This path will also affect Redis if its not set.

Share this post


Link to post
Share on other sites

@SparcMX  A great tool, well done and thank you 🙂  - first use today with a clean install.

I have a 3x3 grid map but it's using over 7GB of ram per cell with no-one connected. Does anyone have a better 3x3 setup with all the latest features ingame which I could kindly copy?

Share this post


Link to post
Share on other sites

getting back into server hosting, and really liking this new tool, however i'm having some issues with the GUS and Game.ini's not correctly writing or reading or something.  I select settings within the game.ini section, start the server and they are never writen to the game.ini. I close the program and reopen it, same issue, doesn't write to the ini. is there a trick to get the game.ini to write correctly with the settings?

 

Also, one bug i found was that if you do a "Copy Settings From" .. even though the IP's don't carry over, when the servers start, the IPs are using the old ones from the first server you copied it from. you have to remove and readd the IPs to correctly work.

Share this post


Link to post
Share on other sites

Great tool sparc.

Im not sure if im doing something wrong here but my timer shows {0} before restarting. Also the CPU load on Cluster totals seems to be for one shard only and not the total.

Nothing important as the tool is awesome as is.

Thanks a million

counter.png.86572f73e72f3dcc54ab85d79e802ba0.png

Share this post


Link to post
Share on other sites
On 4/30/2019 at 12:53 AM, PitMonk said:

@SparcMX  A great tool, well done and thank you 🙂  - first use today with a clean install.

I have a 3x3 grid map but it's using over 7GB of ram per cell with no-one connected. Does anyone have a better 3x3 setup with all the latest features ingame which I could kindly copy?

How many islands do you have per cluster/cell? ~4 islands per cluster can use about ~3-4GB of RAM per cluster. I have done a single cluster, with ~16 islands in that cluster, and used 8GB+ of RAM

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hello
First of all very horny manager.

Only the Atlas Manager crashes on autoupdates.

Furthermore a broadcast message command input is missing for all grids ...

In addition, it would be fine if he once creates an update without a crash that he will automatically restore the configs in the config folder. Defaulgame
Defaulgameusr etc.

 

And an automatic restart function, zbs one gives one in 30 min the server restarts, without autoupdate.

Thank you soooo

Edited by OnlyCrunch

Share this post


Link to post
Share on other sites

I like this tool its look professional. 

 

Is there a guide how to setup the sync?

And did you plan to manage it for Linux system ?

Somethink what been nice. is a tracking system like here.  

 

And a Option to change the saved folder name. 

Because right now i am use  0000 = A1  0001 = A2

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

O darn. I have done quite a few hours of researching and testing, and I still can't get the in-game maps to work. If I can't get this server to work properly, then there is no point in me looking at spending nearly AU$1000 to do a 4X4 Atlas server.

Edited by Austremdog

Share this post


Link to post
Share on other sites
On 5/13/2019 at 10:07 AM, Austremdog said:

O darn. I have done quite a few hours of researching and testing, and I still can't get the in-game maps to work. If I can't get this server to work properly, then there is no point in me looking at spending nearly AU$1000 to do a 4X4 Atlas server.

Did you read my personal message? I've sent you instructions to get the map to work. I'm running a 3x3 with quests and a working map.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello everyone and thank you to SPARCMX for this wonderful program

For my part I started using the launcher AtlasServerManager (which works well but sometimes works badly)

And I just discovered that one that I find really great

https://gyazo.com/8ac5eb2ac7ef31ec029809e1f6c10f3a

But I have a little worry maybe you might have a solution for me? I do not have a fixed IP so for my part I use a NO-IP (ip redirection)

I had no problem with the old launcher but the big problem it seems to me that your launcher does not know how to convert dns by ip ???

Edited by sheppard

Share this post


Link to post
Share on other sites
20 hours ago, DrLizzard said:

Did you read my personal message? I've sent you instructions to get the map to work. I'm running a 3x3 with quests and a working map.

Hi i have an weird problem. on my 2x2 grid server i cant zoom in or out or just say it needs very long to zoom like an input lag. i host on my own machine with plenty of performance

Share this post


Link to post
Share on other sites
Posted (edited)

@SparcMX Could you check your Server tool. My Mini Map dosent zoom in or out once i start an server over your tool. when i start it only with an bat file the minimap works

 

nvm i fugured it out

Edited by CapArrow

Share this post


Link to post
Share on other sites

I really like this tool and it is really helpful.  I have one "issue" and a suggestion (which you probably are already thinking of):

Issue: For some reason, ASC seems to not notice when an update happens.  I then need to open ASC, select Server Installation, Install/Update ATLAS dedicated and then restart the grid.  But then during the next automated check, it sees the update (even though it is already running that version) and restarts the grid again.

Suggestion (1): Can we get a checkbox or something to have ASC automatically start the Redis database when the grid starts (default=yes)?

Suggestion (2): Is there any way that I could get ASC to automatically start on server boot (a scheduled task would work fine) and then automatically start the grid (a config option to automatically start the grid [and redis] on app launch)?

Great work and thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×