Jump to content


PowerStone - Discovery Zone not working (PowerStone itself works well)

Recommended Posts

I have a problem with the powerstone discovery zones.
When collecting a powerstone, the discovery zone and the explorer note aren't unlocked/opened.
However, I receive the power stone.

The normal discovery zones that you get by discovering an island or the triggered discovery zones in front of the caves also working well.

-PowerStoneIndex and manualname are set up
-I have worked out the coordinates for the Discovery zone and the MapMarker with this document
-I've deleted the database as well as the savefiles several times.
-I have freshly and clean installed Atlas and tested everything without mods or other scripts.
-Made a complete and clean handmade copy of the map via GridEditor
-I have made my ServerGrid.json available to other people so they can host the map for testing - The discovery zones and explorer notes worked for them.
-I tried other maps on my server with the same negativ result.

What the hell is going on here?
Does anyone know this phenomenon?

If someone wants to try it or has any idea please contact me. I will gladly provide the json.

I'm grateful for any advice

Edited by Wikinger

Share this post

Link to post
Share on other sites
25 minutes ago, Wikinger said:

@duxck the questline itself works very well and i also test the grideditor from defualtCoder.

if someone wants to try... servergrid.json

Just a question, I see that you've still got breaks in your quest conf. "Power\",QuestDescription=\"J"  as in you break out \",Quest...  \"J... I have no idea if this is a problem or not, just doesn't match the rest of your json or my json. So just removed the backslashes to make it more like the original files.

Share this post

Link to post
Share on other sites

I don't think that it will change anything.
I already get the stone and the dance unlocked.
Therefore, I think that the questline basically works.

I think rather something with the discovery zones or the PowerStoneIndex is not right.
But I've compared everything tens of times with the original json and the tutorials.

strangest thing:  Phlex hostet my .json and for him it works well include ExplorerNote and DiscoZone

but .. well, i'll give it a try...


Share this post

Link to post
Share on other sites

If i delete the backslashes in the questline the map wont start correctly and result in servercrash.

That File above is an export from the map.

Share this post

Link to post
Share on other sites

any news? i do have the same problem. but i can test too much, coz im live with my server.

i had once an error because i copied the names from a website and they had utf8 chars. I couldnt see them until i changed the file from utf8 to ansi/iso ....


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...