Jump to content

Phoenix125

server manager AtlasServerUpdateUtility (ASUU). Server Manager. Blackwood. Backups, Mod Updater, Crash Detection, Discord/Twitch

Recommended Posts

I have a problem when its trying to add my altsavedirectory names, It keeps  showing a error saying it cant find folder 36 when I dont use a folder 36

00,01,02,03,04,05,10,11,12,13,14,15,20,21,22,23,24,25,30,31,32,33,34,35,40,41,42,43,44,45,50,51,52,53,54,55

https://gyazo.com/099ab41bafa15bcc16c62179f949347b

Edited by upperking

Share this post


Link to post
Share on other sites

The util pulls server info from the ServerGrid.json file.  There needs to be a folder entry in the .ini for every grid within the ServerGrid.json file... even if you aren't using them or have "disabled" them.  Therefore, just put anything in as a placeholder for any unused grid.

In other words: If you have a total of 25 grids listed in your .json file, you need to have 25 folder entries in the AtlasServerUpdatUtility.ini file.

ex) Server AltSaveDirectoryName(s) (comma separated. Leave blank for default a00,a01,a10, etc) ###=00,01,02,03,04,10,11,12,13,14,20,21,22,23,24,30,31,32,33,34,40,41,42,43,44

I plan to eventually eliminate this requirement in the future, but for now it is needed.. and is actually convenient so that you can use (nearly) the same .ini for all your server PCs.

 

(EDIT: The problem was with the utility and has been fixed.. Thank you!) 

Edited by Phoenix125

Share this post


Link to post
Share on other sites

I suppose the alternative would be to delete any unused "grid servers" from the ServerGrid.json file.. but this could cause issues when running multiple server PCs.

Sorry for not making this limitation clear.. the documentation is severely lacking at this point.. just trying to get the features included that folks are asking for.

Thanks for your patience!  It's a work-in-progress.

Share this post


Link to post
Share on other sites

ok i did that and it went past but now its asking for above number like 56,57  do I need to put in all numbers upto a 15x15 grid to stop?

Share this post


Link to post
Share on other sites

Yes... for every grid in the ServerGrid.json files, there must be a folder entry.... even the ones at the end. 😞

Edited by Phoenix125

Share this post


Link to post
Share on other sites

Yeah, you'll need all of them in there if you have 225 grids in your ServerGid.json. (SORRY!)

Another option would be to rename your existing save folders to match my util's naming scheme.. a00 a01 a02 a03 a10 a11 a12 etc... 

and then leave the

Server AltSaveDirectoryName(s) (comma separated. Leave blank for default a00,a01,a10, etc) ###=

blank.

If you use the a00 a01 naming scheme, it'll automatically put placeholders in for all servers (whether used or not).

Edited by Phoenix125

Share this post


Link to post
Share on other sites

I have a total of 36 grids I am using and its a original 4x4  I modified. are you saying there are more grids then 36 total that I am using and they are in the json?

if there 225 I I am not seeing them how do I delete or disable all of them...Insert other media

Edited by upperking

Share this post


Link to post
Share on other sites

this way doesn't work either.. I really dont want to rename my folders....  https://gyazo.com/f5ce00d43127abceaa9277286b076e36

00,01,02,03,04,05,06,07,08,09,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,69,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,210,121,122,123,124,125,126,127,128,129,130,131,132,133,134,315,136,137,138,139,140,411,142,143,144,145,146,147,148,149,150,151,152,153,154,155,156,157,158,159,160,161,162,163,164,165,166,167,169,169,170,171,172,173,174,175,176,177,178,179,180,181,182,183,184,185,186,187,188,189,190,191,192,193,194,195,196,197,198,199,200,201,202,203,204,205,206,207,208,209,210,211,212,213,214,215,216,217,218,219,220,221,222,223,224,225

 

Edited by upperking

Share this post


Link to post
Share on other sites

Here's a quick description of how the util gets its server data: 

Here's how the utility assigns folders, ports, grids, etc.:

- It opens the ServerGrid.json file and uses the "totalGridsX" and "totalGridsY" to calculate the total number of servers.
- Next, it skips to "servers": [ "
- Then reads the first "gridX" , "gridY" , "ip" , "port" , "gamePort".
- It then assigns the first folder listed under "Server AltSaveDirectoryName(s)" in AtlasServerUpdateUtility.ini to that server. The first server's information is now complete.

It then repeats this process for the remainder of the servers listed in the ServerGrid.json file.
- The utility continues to import the data for each server, even if the servers aren't used.

Share this post


Link to post
Share on other sites

Then is there a way to add a skip to next folder if folder doesn't exist or if a Gameusersettings.ini is missing?

Share this post


Link to post
Share on other sites

If your grid is 4x4 (36 grids) and that's all you have listed in your ServerGrid.json,  then you should only need 36 folders listed.

If it's asking for more, then there's a problem somewhere.  You could PM, email (kim@kim125.com), or Discord me your .ini and ServerGrid if you want and I'll figure it out.

Share this post


Link to post
Share on other sites

I think you found a "glitch" that I need to fix...

 I need to have it skip searching for the Gameusersettings.ini on unused/disabled servers... good catch.

Sorry... I'll work on that and have a patch released hopefully by late tonight (I've been working on the mod updater.. a lot more work than I previously thought).

A temporary workaround would be to create a folder and gameuser file for every server.. even the ones not being used.

Sorry for the trouble!

I decided to work on that now and put the mod updater on hold for an hour or two... I'll have the patch released within an hour hopefully and post it here.

Edited by Phoenix125
  • Thanks 1

Share this post


Link to post
Share on other sites

v1.2.4 Released! - Fixed: The utility no longer checks for GameUserSettings.ini on disabled grid servers (Thanks UPPERKING [PlayAtlas.com] for reporting)

http://www.phoenix125.com/share/atlas/AtlasServerUpdateUtility.zip

This version was only lightly tested. Sometimes a simple change can cause new problems. Please report any problems... 

(FYI: There still has to be a folder entry in the .ini file for each server listed in the .json file.. regardless of whether the server is used or not... unless you use the default folder naming scheme.. a00 a01 a02 a03 a10 a11 a12 a13 a20 a21 a22 a23 a30 a31 a32 a33 )

Thank you, Phoenix125

Edited by Phoenix125
  • Like 1

Share this post


Link to post
Share on other sites

I think there's still a mismatch between the number of servers in your ServerGrid.json and the number of folders listed... or you have something diff in your .json than I am unfamiliar with that's causing probs.

If you want, send me the ServerGrid.json and AtlasServerUpdateUtility.ini, I'll try to get to the root of it.  kim@kim125.com (Don't worry.. I'll delete the files as soon as we're done)

We can figure this out!

Share this post


Link to post
Share on other sites

v1.2.5 released. Fixed: Error when manually assigning AltSaveFolders (Thanks UPPERKING for reporting!)

Edited by Phoenix125

Share this post


Link to post
Share on other sites

I finally got it done..

v1.3.0 released. Now with MOD SUPPORT!!!   (ModIDs are pulled from the ServerGrid.json file - they must be listed in there).

http://www.phoenix125.com/share/atlas/AtlasServerUpdateUtility.zip

- Optionally automatically check for mod updates, install them, announce the update,  and restart the server.

- Also added some external script options.

Share this post


Link to post
Share on other sites

Can you please increase the max amount of time to stagger server restarts.  The reason is to help spread out the auto-saves that occur.  If all of your grids auto-save at the same time or close to it you will bring your server to it's knees and lag out the players.   And of course if this all happens at the same time the auto-save takes longer and thus the lag etc. lasts longer.

I'd like to see the option allow for at least a 5 minute stagger. 

Thanks,

 

Manalo

Share this post


Link to post
Share on other sites

@ManaloOK. I added your request!  Thanks for the suggestion.

FYI: While your servers are being started, the utility does not perform any other duties... it will not check for updates, restarts, Remote Restart, etc.  Once your servers are all started, though, it will resume.  This should not affect you, just letting you know!

Share this post


Link to post
Share on other sites

New version released..mostly just bug fixes:   http://www.phoenix125.com/share/atlas/AtlasServerUpdateUtility.zip

HOTFIX: (2019-02-26) v1.3.4   
- Fixed: Delay between grid server starts is now working after updates/restarts.
- Fixed: Redis no longer reboots during server reboots
- Fixed: "Line xxx variable not assigned" error when installing new server.
- Fixed: Now downloads AtlasModDownloader.exe before checking for mods, if necessary.
- Changed: "Delay in seconds between grid server starts (0-600)" from (1-60) to (0-600). 

Edited by Phoenix125

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×