Jump to content

mazen

After Upgrading my Server to 16.36 all instances crash immediately on startup

Recommended Posts

My Servers started crashing after the recent atlas update

 

LowLevelFatalError [File:H:\YARKUpdateLIVEReal\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp] [Line: 4073] 
Bad name index 1836216142/117


VERSION: 16.36 
KERNELBASE.dll!UnknownFunction (0x00007ffd36884078) + 0 bytes [UnknownFile:0]
ShooterGameServer.exe!FOutputDeviceWindowsError::Serialize() (0x00007ff66fa3fba3) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
ShooterGameServer.exe!FError::LowLevelFatal() (0x00007ff66fa175a6) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\core\private\misc\outputdevice.cpp:354]
ShooterGameServer.exe!ULinkerLoad::operator<<() (0x00007ff66fa56ea0) + 34 bytes [h:\yarkupdatelivereal\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:4073]
ShooterGameServer.exe!operator<<() (0x00007ff66fc50099) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\shadercore\private\vertexfactory.cpp:156]
ShooterGameServer.exe!FShader::SerializeBase() (0x00007ff66fc55388) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\shadercore\private\shader.cpp:836]
ShooterGameServer.exe!TShaderMap<FMeshMaterialShaderType>::SerializeInline() (0x00007ff6702efc09) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\shadercore\public\shader.h:1095]
ShooterGameServer.exe!FMaterialShaderMap::Serialize() (0x00007ff6702ed89f) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\materials\materialshader.cpp:1741]
ShooterGameServer.exe!FMaterial::SerializeInlineShaderMap() (0x00007ff6702f0370) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\materials\materialshared.cpp:845]
ShooterGameServer.exe!SerializeInlineShaderMaps() (0x00007ff6702bf8e6) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\materials\material.cpp:472]
ShooterGameServer.exe!UMaterialInstance::Serialize() (0x00007ff6702ee24a) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\materials\materialinstance.cpp:2097]
ShooterGameServer.exe!ULinkerLoad::Preload() (0x00007ff66fa70792) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3025]
ShooterGameServer.exe!FAsyncPackage::PreLoadObjects() (0x00007ff66fa70229) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\coreuobject\private\serialization\asyncloading.cpp:1132]
ShooterGameServer.exe!FAsyncPackage::Tick() (0x00007ff66fa7c5cb) + 8 bytes [h:\yarkupdatelivereal\engine\source\runtime\coreuobject\private\serialization\asyncloading.cpp:302]
ShooterGameServer.exe!ProcessAsyncLoading() (0x00007ff66fa71ade) + 24 bytes [h:\yarkupdatelivereal\engine\source\runtime\coreuobject\private\serialization\asyncloading.cpp:1580]
ShooterGameServer.exe!UShooterEngine::LoadGameMods() (0x00007ff66effc9e5) + 0 bytes [h:\yarkupdatelivereal\projects\shootergame\source\shootergame\private\shooterengine.cpp:968]
ShooterGameServer.exe!UEngine::LoadMap() (0x00007ff670144ff3) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\unrealengine.cpp:9854]
ShooterGameServer.exe!UEngine::Browse() (0x00007ff67012f54b) + 43 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\unrealengine.cpp:8888]
ShooterGameServer.exe!UShooterGameInstance::CheckConnectString() (0x00007ff66f002669) + 0 bytes [h:\yarkupdatelivereal\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:2959]
ShooterGameServer.exe!UShooterGameInstance::StartGameInstance() (0x00007ff66f00fc0a) + 0 bytes [h:\yarkupdatelivereal\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:335]
ShooterGameServer.exe!UGameEngine::Init() (0x00007ff66ff82406) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\engine\private\gameengine.cpp:735]
ShooterGameServer.exe!UShooterEngine::Init() (0x00007ff66effb2ef) + 0 bytes [h:\yarkupdatelivereal\projects\shootergame\source\shootergame\private\shooterengine.cpp:396]
ShooterGameServer.exe!FEngineLoop::Init() (0x00007ff66eb5851c) + 0 bytes [h:\yarkupdatelivereal\engine\source\runtime\launch\private\launchengineloop.cpp:2115]
ShooterGameServer.exe!GuardedMain() (0x00007ff66eb58012) + 12 bytes [h:\yarkupdatelivereal\engine\source\runtime\launch\private\launch.cpp:128]
ShooterGameServer.exe!GuardedMainWrapper() (0x00007ff66eb5811a) + 5 bytes [h:\yarkupdatelivereal\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGameServer.exe!WinMain() (0x00007ff66eb5dbfa) + 17 bytes [h:\yarkupdatelivereal\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGameServer.exe!__tmainCRTStartup() (0x00007ff670e4940d) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffd380284d4) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffd3a0be851) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffd3a0be851) + 0 bytes [UnknownFile:0]

 

Share this post


Link to post
Share on other sites
30 minutes ago, mazen said:

My Servers started crashing after the recent atlas update

+1 for this exact error. A few of the specific index numbers are different, but all those calls to functions or w/e are exactly the same.

Happened exactly the same way too - we tried to update the the most recent patch and update some of our mods tonight, and now everything crashes with this error.

 

Can I trouble you for a mod list comparison if you have any? Ours can be found here:

https://steamcommunity.com/sharedfiles/filedetails/?id=1639435331

Edited by Dread Pirate Ash
Fixed a word.

Share this post


Link to post
Share on other sites
1 minute ago, Dread Pirate Ash said:

+1 for this exact error. A few of the specific index numbers are the same, but all those calls to functions or w/e are exactly the same.

Happened exactly the same too - we tried to update the the most recent patch and update some of our mods tonight, and now everything crashes with this error.

 

Can I trouble you for a mod list comparison if you have any? Ours can be found here:

https://steamcommunity.com/sharedfiles/filedetails/?id=1639435331

Our Server crash with and without MODS 😞

we use: https://www.dhde.club/forum/viewtopic.php?f=12&amp;t=19

 

Share this post


Link to post
Share on other sites
3 minutes ago, Priesticus said:

Our Server crash with and without MODS 😞

we use: https://www.dhde.club/forum/viewtopic.php?f=12&amp;t=19

 

Possibly some conflict with the Peachy mods, that isn't removing data properly when the server tries to boot up without it....?

 

Edit: But yeah, we tried disabling the one we thought it was, and it didn't help. Been loathe to just disable them all just yet, since some people already converted stuff on their ships. (Like me).

Edited by Dread Pirate Ash

Share this post


Link to post
Share on other sites

Once you remove the mods, can you detele the Shootergame/Content folder then verify on steam, see if that fixes the issue? That'll remove most the changes done by mods. Backup the world first as you'll have actives ingame on the map from the mods. You can always try apply the mods back to the game after getting fresh content files. This has helped in a few cases.

Share this post


Link to post
Share on other sites

You dont need Recover the Server. 

Delete   ActiveMods=xxx   in   GUS.ini and remove entries in JSON-Mapfile. ( "ModIDs")
Server will restart.

Share this post


Link to post
Share on other sites

Update: 16.39 fixed it again, thanks to the anonymous developer 😉

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×