Jump to content

Recommended Posts

Okay, so i have tried pretty much tried everything (which good ol' google can provide) to get my in game map to work and remove this foggy and missing map when you press i and goto "Atlas" to see the overal map but nothing, so far the only thing i was able to get working was MapIMG.jpg by hosting it via Dropbox and pasteing the link in the ServerGrid.json file, I did try the same with the 4 grid images but no luck at all, the closest i came to was a white fog on my mini map which when i moved it de-coloured it slightly (Like a trail, but not as thick as the rest) I have hard re installed 3-4 servers using other peoples methods and created new maps etc.. changed jpg to PNG and vice versa with no luck still. I have downloaed the updated verson of the ServerGridEditor too to my knowledge.

I have also tried to manually move the files, deleted Local and saved folders, I have also left everything and just removed the lines Map Image URL and MetaWorldURL but still same issue persists. I think it is something to do with the Redist transfering the images over as when i log into the game after removing my saved and Local files so i can redownload the images when joining the server i get no images at all so to me something is missing but what i have no idea? I asumed it would defualt to the server directory for the ServerGrid folder but i guess not? 

Is this a issue with 2x2 servers overal? Do i need to make all 4 grids have the same SeamlessPort "27000" or do they have to be different? I'm lost been trying to look at guides for fixing this but most guides are 1x1 (1 grid is one image so its simple..) but i have 5 images, 4 for the grids and 1 for the whole server.

please someone try to help me I am lost everything else works, moving grids powerstones ghost ship custom game.ini etc.. just the issue with the Map ingame! Thanks in advance!

Edited by Tarkayne

Share this post


Link to post
Share on other sites

Was having same issue with map. What I did to get it working was to

1. Go to Atlas/Shootergame/Saved/MapImagesCache and make a new folder named your server id

2. rename MapImg to WorldMapImage and CellImg_4-4 to GridCellMapImage_4-4 and so on for each grid you have

3. Place these images in the server id folder

Hopefully your map works 

Share this post


Link to post
Share on other sites

In my hosted server files or my game files?

 

Just checked my steam>steamapps>common>ATLAS>ShooterGame?Saved>MapImagesCache and my Server ID Folder does not exist.

Normal it creates and empty folder strange this time it didnt even create a folder!

Edited by Tarkayne

Share this post


Link to post
Share on other sites
5 hours ago, ikes said:

Was having same issue with map. What I did to get it working was to

1. Go to Atlas/Shootergame/Saved/MapImagesCache and make a new folder named your server id

2. rename MapImg to WorldMapImage and CellImg_4-4 to GridCellMapImage_4-4 and so on for each grid you have

3. Place these images in the server id folder

Hopefully your map works 

I tried this and it seems to have Semi worked, but not in game. before i enter i can click "Show Atlas Map" and it shows the mini map, the fog here isnt an issue and is a quick fix but ingam eis where the issue is its blank again yet shows some sort of path? is this a command in the .ini files maybe thats keeping fogofwar on?

 

Bugg.JPG

Share this post


Link to post
Share on other sites

Nope i mean rcon. We had the same issue on 30 grids then we set rcon and made sure all ports was what they was meant be. and it solved the problem.

Share this post


Link to post
Share on other sites

Start with this... 

Game Port: 5761

Query Port: 57561

RCON Port: 32300

Redis Port: 6379

SteamlessDataPort: 27000 

Start with them ports by default. and the Port Increment:    DO 10 PORTS APART! so if you have more than 1 grid each grid has to have its own ports. this way you have the ports apart enough from each other. If your using your own dedicated server the make sure them port are all open and id do TCP and UDP to be on the safe side. Are you self hosting or getting from a GSP(Hosting Provider)?  

Edited by Sparky81

Share this post


Link to post
Share on other sites

Is the below correct? @Sparky81 or do i need to add RCONenable=True?RCONport=27020

start C:\AtlasSrv\ShooterGame\Binaries\Win64\ShooterGameServer.exe Ocean?ServerX=0?ServerY=0?AltSaveDirectoryName=00?ServerAdminPassword=RABBIT?MaxPlayers=25?ReservedPlayerSlots=2?QueryPort=57555?Port=5755?SeamlessIP=86.22.136.172 -log -server -NoBattlEye
exit

 

A;so thi sis the only mention i can find for RCON; image.png.9052706420311de91f213bfa9a9647be.png

Share this post


Link to post
Share on other sites

Sorry guys I tried everything like you and this is what made my map work.   Since then I did one more thing and that was change my seamless port to my web ip. I've done so many file moves and other things to try and get that map working that I would have to start from scratch again to pinpoint what else could be different.  I use atlas full server controller and last night I travelled into a grid I didn't rename the map for and the map worked and also  the correctly named grid file was in my server id folder.  Atlas/Server/Shootergame/DefaultGameUserSettings in this file is where I added

SeamlessDataSocketEnabled=true
SeamlessDataSocketPort=your web ip

Again no idea if this is what worked but worth a try 

 

And my map is fog of war like that first image but where i've been you can see the map

 

Edited by ikes

Share this post


Link to post
Share on other sites

Didnt work for me, whats everyone elses Server launch bat file command?

mine is this, im sure its not right?

start C:\AtlasSrv\ShooterGame\Binaries\Win64\ShooterGameServer.exe Ocean?ServerX=0?ServerY=0?AltSaveDirectoryName=00?ServerAdminPassword=XXXXXXXX?MaxPlayers=25?ReservedPlayerSlots=2?QueryPort=57555?Port=5755?SeamlessIP=86.22.136.172 -log -server -NoBattlEye
exit

Edited by Tarkayne

Share this post


Link to post
Share on other sites

I just started a new server to see what could be an issue, it seems that C:\Program Files (x86)\Steam\steamapps\common\ATLAS\ShooterGame\Saved\MapImagesCache is always empty the server doesnt have any Maps to down? Although i have images located in C:\AtlasServer\ShooterGame\ServerGrid for the server.... Some where its not letting anyone (myself included) download the maps and run them

Share this post


Link to post
Share on other sites

this is what my folder looks like and where it is, works fine, they should all be .jpg and all named like this

 

server map.png

Edited by Anorak

Share this post


Link to post
Share on other sites

Okay, been looking at this all day again... And I have the fix!!

 

What i needed to do was ensure my Atlas Server images was as the below;

image.png.84d30ac256306dce0fd24b007f1958af.png

 

Once this was done, i needed to ensure my images on my client side was as the below;

image.png.de562728d64395b71313b37fc91454a6.png

This has now fixed my issue and im sure all you guys struggling can use this to help as im sure some people are only needing to change the "ServerGrid" images fo rit to work where as some have to manualy copy the images and rename as i have above.

If any questions feel free to message me x-)

Share this post


Link to post
Share on other sites
10 hours ago, Tarkayne said:

If any questions feel free to message me x-)

Did you just... not do an export all from the map editor? Because it should create all the images you need in the 'ServerGrid' folder, a folder which needed to be copied/overwritten into the same place as ServerGrid.json. Kinda confused as to how people didn't understand that as its a big part of setting up your server in any of the guides.

Also, the MapImagesCache is, as the name would imply, simply the temporarily downloaded in-game version of the map that your client takes from the server. You can delete those at any time and the game will simply download new ones. They also (should) get deleted when you close the game, because that's how caching ought to work unless the devs are lazy.

Last of all - those images you've got there are gonna potentially show the discovery zones on your treasure maps, FYI. Anything you have labeled as 'on' when you export the images will show up. I'd recommend turning everything off for exporting cell images, and turning island names and grid lines on for the map image, and otherwise keeping things off. Or if you wanna make treasure easy you can leave the island names on, if you have them. (Actually, that assumes you even named your islands, I guess. We overwrote ours by just editing the editor files, which has consquences, but its neat that the names show up on the treasure map all zoomed-in.)

Edited by Dread Pirate Ash
a word

Share this post


Link to post
Share on other sites

This was just a dummy server to get the mini map fix but i had to rename and manually move them myself, now its done i will edit and make my server how i see it best 🙂

Share this post


Link to post
Share on other sites

Each server uses 3 ports and the seemlessDataport has to be forwarded also.

example:

      "port": 57555,
      "gamePort": 5755,
      "seamlessDataPort": 27000,

 

This can be found in the ServerGrid.json

I used CMD and executed the command "netstat -a" to see which ports opened when I started the server.

Hope this helps!

Share this post


Link to post
Share on other sites
34 minutes ago, Shadowwyrm said:

Each server uses 3 ports and the seemlessDataport has to be forwarded also.

example:

      "port": 57555,
      "gamePort": 5755,
      "seamlessDataPort": 27000,

 

This can be found in the ServerGrid.json

I used CMD and executed the command "netstat -a" to see which ports opened when I started the server.

Hope this helps!

Never had an issue with my ports?

Share this post


Link to post
Share on other sites
On ‎1‎/‎25‎/‎2019 at 6:14 PM, Tarkayne said:

Okay, been looking at this all day again... And I have the fix!!

 

What i needed to do was ensure my Atlas Server images was as the below;

image.png.84d30ac256306dce0fd24b007f1958af.png

 

Once this was done, i needed to ensure my images on my client side was as the below;

image.png.de562728d64395b71313b37fc91454a6.png

This has now fixed my issue and im sure all you guys struggling can use this to help as im sure some people are only needing to change the "ServerGrid" images fo rit to work where as some have to manualy copy the images and rename as i have above.

If any questions feel free to message me x-)

If your export was not already naming the images correctly, your map editor is out of date.

 

 

I was able to fix mine also by deleting the version I had of the map editor, and re-exporting everything.  I also was not port-forwarding my seemless ports.  With those 2 changes, my maps work now! 🙂 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...