Jump to content

KayaBorealis

bug Tames falling through floors and boats

Recommended Posts

Wow this bug's been reported for over a month and NOTHING?!

We just lost a player over yet another pet killed by loading to a ship and it landing on the ocean floor.

Ship loading issues need to get prioritized higher up on the fix it list.

Share this post


Link to post
Share on other sites

This is still an issue. Animals fall through boats after coming out of stasis.

Share this post


Link to post
Share on other sites

A lot of people say this doesn't happen in ARK. I haven't played ARK for over a year, but when I was last playing it, it did happen. If you had a raft base, you put all your stuff in a box and logged out. Better yet, you put all your stuff in a box and then killed yourself. That way you got consistent results. Same with the tree platform. More than likely you would log in there and find yourself falling to the ground.

Now I have to figure one of two things is going on here:

1) The code base in Atlas is from an old branch of ARK and Atlas has been in development on that branch for a year or more. The current code base of ARK has finally fixed this problem that I saw for about the two years that I played ARK.

2) People who don't think this happens in ARK, just don't do things that make this occur and Atlas just has so many cases that can trigger this, that it occurs much more often.

Not sure what the truth is here.

BTW, not trying to trivialize this bug, it is very serious and needs to be fixed. It is one of the most serious issues I have with the game right now. It is limits my game play seriously, and I can't wait to see it fixed.

Share this post


Link to post
Share on other sites

@Jatheish Change the way the boat system works. When putting a tame on the boat, add it to its inventory as an icon. Treat it as a database option not a graphical move to the boat so we dont have balloon bears, and elephants. 2 in 20 minutes like this is waste of valuable programming time, when you can just add it to its inventory of the boat, until landed.

Share this post


Link to post
Share on other sites

I totally agree the other day I was patching my boat in the water and I somehow ended in the bottom part of my boat I had to destroy planksn to get out even the admin couldn't get me out.

Share this post


Link to post
Share on other sites
1 hour ago, Sneakydude said:

@Jatheish Change the way the boat system works. When putting a tame on the boat, add it to its inventory as an icon. Treat it as a database option not a graphical move to the boat so we dont have balloon bears, and elephants. 2 in 20 minutes like this is waste of valuable programming time, when you can just add it to its inventory of the boat, until landed.

There is a workaround to the moving tame to ship bug (where it kills the tame). You just get on first, then whistle follow (T) and the tame will pop up on deck same as the NPCs do. There is no reason to be losing tames when you load them on a ship, but they still need to fix the bug. I wish they would disable the menu option until they fix it.

Share this post


Link to post
Share on other sites
3 minutes ago, wildbill said:

There is a workaround to the moving tame to ship bug (where it kills the tame). You just get on first, then whistle follow (T) and the tame will pop up on deck same as the NPCs do. There is no reason to be losing tames when you load them on a ship, but they still need to fix the bug. I wish they would disable the menu option until they fix it.

There is a massive issue right now, zoning or going to repair the ship the tames go floating in the air and disappear. IS this desync? i think its in the netcoding

Share this post


Link to post
Share on other sites
35 minutes ago, Sneakydude said:

There is a massive issue right now, zoning or going to repair the ship the tames go floating in the air and disappear. IS this desync? i think its in the netcoding

Ah, was not aware of this other than that I saw one video of a taming flying off a boat and read of that happening in here, but this is the first I've heard it is related to repairing the ship.

The game does seem to have desync issues. By that I mean the client and server out of sync. I've seen this more than once, but I've not lost any tames that way, but don't doubt that it is happening. More than once, I've flown up into the air and then suddenly fall from a great height. This has killed my character a few times. 

I've had ships teleport after crossing a grid border (I think that is what you mean by zoning).

Hopefully we will see some progress soon on fixing issues like this. I'm pretty sure we are losing players to issues like this. Probably not to just this issue, but combined with others, it can make the game to frustrating to play. I play on private servers, so the impact of these is less, so I'm still playing the game.

Share this post


Link to post
Share on other sites
9 hours ago, Jizzah said:

Fucking fix it...

This is the worst, people put so much time into Tames its not funny to level them up or breed them.

Like i said guys = Devs put it as a database entry not as a graphical entry on the boat. People will be less likely to bug out. You will be fixing this bug every patch, and break it every other patch.

  • Like 1

Share this post


Link to post
Share on other sites

Ask what's left of the community whether they'd rather have a game where players/npc/tames don't glitch through supposed solid surfaces, or have a submarine and grass skirt...

Share this post


Link to post
Share on other sites
Posted (edited)

Also, after a tp, all my pets are gone even the furniture with the food, poofed, someone told me at my flag, cobras made a visit, seems they eat furniture now too. And they plan to make so big and bright changes to the core of this game, before fixing the bugs..., keep the good work to make this free to play.

No render problem, the pets are killed from a closed recint by cobras, they spammed misteriosly inside, when in 4 months, they cannot do it.

Edited by Darla

Share this post


Link to post
Share on other sites

Just punch where the animal is  its there but not rendered on  your system  kristoff rivers

Share this post


Link to post
Share on other sites

Last v20 Update made it worse and broke collisation detection for manned bot position.

IMG-20190302-203759.jpg

This happened when we tried to turn our ship...

Also there are two cannons without bot and still shows " manned " position.

Share this post


Link to post
Share on other sites

On Linux dedicated servers, there's a bug where following tames and crew will disappear because their X and Z coordinates get swapped on the Detach event when leaving the ship.

They get killed because they go out of bounds, but it doesn't seem to happen on Windows servers.

KZomN4F.jpg

 

More info here:

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I am not a mind reader but i do pay attention.

I THINK<<<keyword think they attempted the fix and why you often see your npcs and pets bouncing up n down to keep them from falling through.I think this caused as many problems as it fixes because what happens when you cross a zone line is in between those up n down bounces we get lag,EVERYOne gets that zone cross lag and it appears that is why your pet might just keep bouncing upwards as i have seen several times until it bounces right into the clouds and out of game.

The auto warping of pets directly onto boat is another that works....sometimes.Other times your pet will be stuck in the side and nOTHING works to get him out.So we are forced to try and cross a zone to reset it and hope your pet will become unstuck.The very odd time after sailing and even while pulling away sailing,your pet will just fall out into the ocean,at that point you can stop and go get him again and lol,HOPE he enters boat properly.

On the same topic,i had a lION aggro right through the bottom of my boat's hull,warp right  through two decks and started to attack everything on deck.

IMO all of these problems point to other areas of design that tried to fix problems,like pet's or npc's not getting stuck in walls was likely addressed but now it allows stuff to warp through walls when sometimes you don't want it to.

So my memory serves me,they addressed the players going on others boats as well i remember a mention of fixing npc's from being stuck and made to be TOO easy of a tame.It really feels like fixes are causing more bugs long term because i can see a correlation between supposed fixes and the bugs that are happening.

Edited by zubov56

Share this post


Link to post
Share on other sites

This seems to be easily replicated by fast traveling between servers that were placed in stasis because there were no players present.

Consistently when spawning into an empty server I am on the world mesh and not whatever structure mesh was in place.

Sounds like a data race, spawn is made before objects are loaded into the world.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×