Jump to content

KayaBorealis

bug Tames falling through floors and boats

Recommended Posts

This an issue we're working on and trying to resolve and it extends beyond tames with players also falling through the structures. Sadly it's more of a complex and difficult one to get the bottom of, but it is certainly one of our higher priority issues.

  • Like 7

Share this post


Link to post
Share on other sites
23 minutes ago, Jatheish said:

This an issue we're working on and trying to resolve and it extends beyond tames with players also falling through the structures. Sadly it's more of a complex and difficult one to get the bottom of, but it is certainly one of our higher priority issues.

Thank you! 🙂

Share this post


Link to post
Share on other sites

Today when i logged in into our base 80% of our animal disappeared - 5 elephants / 2 shielhorns / 5-6 bears / 1 giraffe / 1 rhino  and some other that i can not remember   ......no logs / no trace of them

Share this post


Link to post
Share on other sites

One of my bears disappeared this morning. Nothing in the log. I went out of render distance and then came back. The bear was back, I think right where I left him.

2 hours ago, P4TM4N said:

second bear killed boarding ship with no saddle or bag left behind.

To you an anyone that reads this. Do not load a tame onto a ship using the radial "move to ship" menu. Apparently especially if it is on follow. This will fail, somewhere around 10% of the time with your tame being dead.

Much safer to get on the ship, then whistle follow (T) and it will follow you on just like an NPC. Unlike an NPC, tames are big enough to get stuck in decking, so whistle follow from a location free of stuff built on the deck to avoid it getting stuck.

Edited by wildbill

Share this post


Link to post
Share on other sites
On 2/9/2019 at 2:51 PM, AliciaB said:

I have a bear stuck in a brigantine, can I break the bottom deck of a boat or not without sinking the boat? I will break one side of the boat after, I want to recover my favorite bear 😞



(J'ai un ours coincĂ© dans une brigantine, je peux casser le pont infĂ©rieur d'un bateau? Je vais casser un cotĂ© du bateau aprĂšs, je veux rĂ©cupĂ©rer mon ours favori 😞  )

1886663442_ours2.thumb.jpg.56c440eaadc1d4e2a591befebbf8095a.jpg

 

I hope that you managed to fix this without breaking the side of your ship Alicia - as previous posters suggested, two fixes that often seem to work include 1) raising/dropping anchor often "pops" mounts to top deck and 2) putting follow distance on Lowest, whistling the bear onto follow and then running to different vantage points on your boat (higher points in different directions). 

These approaches have definitely worked for us in the past - hopefully it can save folks a few tames. 

Edited by Kwiver

Share this post


Link to post
Share on other sites
3 hours ago, Kwiver said:

I hope that you managed to fix this without breaking the side of your ship Alicia - as previous posters suggested, two fixes that often seem to work include 1) raising/dropping anchor often "pops" mounts to top deck and 2) putting follow distance on Lowest, whistling the bear onto follow and then running to different vantage points on your boat (higher points in different directions). 

These approaches have definitely worked for us in the past - hopefully it can save folks a few tames. 

Yes I got it back, merci 🙂 

 

Share this post


Link to post
Share on other sites

Same problem... everything was fine the last few days, but this morning most of my tamed pets got stuck in my double flooring of the enclosure built above water.

Was forced to partly destroy the building to dislodge my pets.

Devs, this REALLY needs to be solved asap! How I am supposed to put my pets out of harms way - any suggestions???

Edited by Cytoxx

Share this post


Link to post
Share on other sites
On 2/10/2019 at 8:05 PM, Jatheish said:

This an issue we're working on and trying to resolve and it extends beyond tames with players also falling through the structures. Sadly it's more of a complex and difficult one to get the bottom of, but it is certainly one of our higher priority issues.

Thanks @Jatheish for the update. It's good to hear you guys are working on it and I appreciate you guys trying to do the best you can to fix things.

At the weekend my company accidentally left 3 players in the middle of the ocean due to this bug . They lost all their high level gear as they were not online when we moved a boat. When they logged in they were just sitting there floating in the middle of the ocean, many sectors away from where we ended up in the boat, with no chance to send out a rescue party in time #facepalm. Two of these affected have decided to quit the game entirely now. That's not great for a small company like mine, but a tragic indication of the fragility of the games attraction and ability to hold its audience over time if such fundamental and basic functionality cannot be addressed quickly. Gear can be replaced and grinded out, but people cant. We all play games for fun, and when the fun stops, players will leave and have.

Share this post


Link to post
Share on other sites
4 hours ago, Cytoxx said:

Same problem... everything was fine the last few days, but this morning most of my tamed pets got stuck in my double flooring of the enclosure built above water.

Was forced to partly destroy the building to dislodge my pets.

Devs, this REALLY needs to be solved asap! How I am supposed to put my pets out of harms way - any suggestions???

I've seen a few suggestions, but they mostly seem to ignore that tames can and will fall through the floor to the lowest level of a building.

So for now, I only know one sure thing, that is go ahead, put the tames on an upper floor, but have a plan to get them out of lower floors if they fall through. In a base, that is open a gate or break a few walls. On a ship, anchor/un-anchor and whistle follow from above the deck, like in a crows nest.

For a base, make sure where they fall into is safe. For me, that is putting a fence around the building they are in that keeps wild creatures away from the walls of the tame enclosure. It is extra work, but the only way to keep them safe that I know of.

Unfortunately this bug does prevent me from building a base over water, I just don't feel that would be safe, although I've not tested it.

If anyone else has ideas that take this bug into account, and still keep your tames safe, share them please.

Of course, you could also take the route a few are, and that is to stop playing the game until some of these issues are resolved. I'm not ready to do that yet, but might if this just becomes too frustrating. I think the work arounds if followed can keep us playing and having fun though.

Share this post


Link to post
Share on other sites

How can you even be thinking of adding content with these floor/ground bugs in the game? This makes the game fundamentaly unplayable when all the tamed animals you have farmed one day is gone when the servers has been down. I know this is early access but shame on you guys! Get your prioreties right ffs!

Share this post


Link to post
Share on other sites
2 hours ago, Ballaballa said:

How can you even be thinking of adding content with these floor/ground bugs in the game? This makes the game fundamentaly unplayable when all the tamed animals you have farmed one day is gone when the servers has been down. I know this is early access but shame on you guys! Get your prioreties right ffs!

I think they have different people working on bugs and content, and this one in particular is hard to fix i don't even think they can fix this, like ever, maybe for ships, but not for land structures, but then again, i still doubt it, i think this will never get fixed, like ever, i'd like the devs to change my mind or prove me wrong i really do, but yeah very unlikely

Share this post


Link to post
Share on other sites

I have been victim to this type of bug on more occasions than I care to think about .. I have lost a total of 6 bears on the EU official PVE server, and even more on the EU PVP official server when I played there before. It seems like there is always a risk, for me, that when either ordering a tamed creature to follow, or command it to board a ship, there is a likelihood that it will just get stuck between the structure of the ship and end up dying or just simply disappear before the much dreaded and almost insolent 'your creature was killed!' message pops up in red. I cannot express how frustrating this has been for me. I truly have developed a love-hate relationship with this game, as I did with ARK before. I have 178 hours on ATLAS and 917 hours on ARK but often wonder how I have persevered through such game-breaking bugs; I guess I must really be a fan of the developers and games themselves, which makes it even more painful when these things occur. Please, please, implement some means to address this and stop breaking our collective hearts - I am appropriately posting this on valentines day in the hope that my message is more poignant. Thank you in advance.

losttameagain.jpg

Share this post


Link to post
Share on other sites
4 minutes ago, tsiken said:

I have been victim to this type of bug on more occasions than I care to think about .. I have lost a total of 6 bears on the EU official PVE server, and even more on the EU PVP official server when I played there before. It seems like there is always a risk, for me, that when either ordering a tamed creature to follow, or command it to board a ship, there is a likelihood that it will just get stuck between the structure of the ship and end up dying or just simply disappear before the much dreaded and almost insolent 'your creature was killed!' message pops up in red. I cannot express how frustrating this has been for me. I truly have developed a love-hate relationship with this game, as I did with ARK before. I have 178 hours on ATLAS and 917 hours on ARK but often wonder how I have persevered through such game-breaking bugs; I guess I must really be a fan of the developers and games themselves, which makes it even more painful when these things occur. Please, please, implement some means to address this and stop breaking our collective hearts - I am appropriately posting this on valentines day in the hope that my message is more poignant. Thank you in advance.

losttameagain.jpg

This thread is about tames falling through structures, ships or bases and dying.

I think you are talking about them getting killed when loading on a ship.BTW, this is a known bug too, i've posted the work around for that in other threads. You should never have a tame dying when loading it onto a ship if you know what does and doesn't work.

Share this post


Link to post
Share on other sites

This would be sooo nice, had to destroy stone structure today to free couple of tames...at least stone is cheap again 😛  

Also with fixing the glitch snakes will stop killing tames in buildings.

Share this post


Link to post
Share on other sites

For what its worth, we rarely if ever have tames fall through our floors, but we almost never use foundations for our floors.  We use pillars and ceilings.  It puts the base up higher so snakes cant get in (they climb stacked pillars) and allows people to do maps under our base (you do not want an army set spawning in your base...)

Share this post


Link to post
Share on other sites

I've had tames fall  through ceilings with pillars today for the first time I had an elephant fall through a cliff foundation. My message to devs is give us some way to combat it if its a hard code to fix that is understandable but give us something to build or do that can actually work tames take a lot of time to go get and it is discouraging to do all kinds of crazy things and none of it work give us anything that will keep them safe boats roofs ceilings walls cliffs does not work 1 thing we can all do til the code gets worked out 

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Yomaz said:

I've had tames fall  through ceilings with pillars today for the first time I had an elephant fall through a cliff foundation. My message to devs is give us some way to combat it if its a hard code to fix that is understandable but give us something to build or do that can actually work tames take a lot of time to go get and it is discouraging to do all kinds of crazy things and none of it work give us anything that will keep them safe boats roofs ceilings walls cliffs does not work 1 thing we can all do til the code gets worked out 

 

 

Crew attached to stations don't fall.   Let us build cages for our animals that are structures,  and store animals there similar to assigned crew.   Pens and stalls and such

Share this post


Link to post
Share on other sites

We only had small pets falling through the floors after a server reset.  We still can't find one monkey, the logs say he isn't dead but after ripping up most of the foundations, he's still not there.

Today we had bears on the second level fall through to the first and of course, all the small pets fall through to the ground.

Share this post


Link to post
Share on other sites

I am extending my observations.

I have noticed there is huge desync between what is on server and what is game displaying. For example for me it was showing as my animals were not there, but when i tried passing thru that spot i got rubber-banded back. Like server was denying passage as if something was there.

There are issues a lot of times with game showing ships with planks flipped which indicates another issue with synchronization of objects. 

The fix for falling animals or dynamic objects should be simple. Not sure how they have designed the code for everything but... as far i imagine from my experience it should be this way.
 

Load world...
Load structures or static objects...
wait a cycle or two on server, because physix engine has to insert new collisions into collision tree.
Load ships.
wait a cycle or two so the collision tree is refitted. 
Load dynamic objects (animals).
Simulate physix for couple of cycles.
Start accepting  traffic.



When logging in.
I should not see myself falling thru ground into water... etc.


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×