Jump to content

Recommended Posts

EN:

On Debian 9, the server works just to upload to the directory ShooterGame/Binaries/Linux the libssl.so.1.0.0 file does not have to be uploaded to the system library
There is one problem at the time when the server starts up again there is a problem with the map write reading after restarting

 

PL:

Na Debianie 9 serwer działa wystarczy wgrać do katalogu 
ShooterGame/Binaries/Linux plik libssl.so.1.0.0 nie trzeba go wgrywać do biblioteki systemowej 
Jest jeden problem w momencie gdy gdy serwer uruchamia się ponownie jest problem z odczytem zapisu mapy po ponownym uruchomieniu 

 

Edited by muny

Share this post


Link to post
Share on other sites
2 hours ago, muny said:

EN:

On Debian 9, the server works just to upload to the directory ShooterGame/Binaries/Linux the libssl.so.1.0.0 file does not have to be uploaded to the system library
There is one problem at the time when the server starts up again there is a problem with the map write reading after restarting

 

PL:

Na Debianie 9 serwer działa wystarczy wgrać do katalogu 
ShooterGame/Binaries/Linux plik libssl.so.1.0.0 nie trzeba go wgrywać do biblioteki systemowej 
Jest jeden problem w momencie gdy gdy serwer uruchamia się ponownie jest problem z odczytem zapisu mapy po ponownym uruchomieniu 

 

Not a very safe option with a few of the glaring huge exploits in OpenSSL.1.0.1 to make this game work.

Share this post


Link to post
Share on other sites

I am making a little progress with several hours of testing and digging.

First find the system locations for libssl:

root@playground:/# find -name "libssl*"
./usr/lib/x86_64-linux-gnu/libssl.so.1.1
./usr/lib/x86_64-linux-gnu/libssl.so.1.0.2
./usr/lib/x86_64-linux-gnu/libssl3.

Now we make a Symbolic Link and name the link to match the older name.

root@playground:/# cd /usr/lib/x86_64-linux-gnu/
root@playground:/usr/lib/x86_64-linux-gnu# ln -s libssl.so.1.1 libssl.so.1.0.0

Now we check that the link is valid:

root@playground:/usr/lib/x86_64-linux-gnu# ls -al libssl*
-rw-r--r-- 1 root root 357024 Oct  7  2017 libssl3.so
lrwxrwxrwx 1 root root     15 Jan 17 14:48 libssl.so.1.0.0 -> libssl.so.1.1
-rw-r--r-- 1 root root 431232 Dec 16 12:07 libssl.so.1.0.2
-rw-r--r-- 1 root root 442984 Nov 28 14:43 libssl.so.1.1

Finally we make another link for libcrypto.1.0.0 because it will complain too.


root@playground:/usr/lib/x86_64-linux-gnu# ls libcrypt*
libcrypt.a  libcrypto.so.1.0.2	libcrypto.so.1.1  libcrypt.so
root@playground:/usr/lib/x86_64-linux-gnu# ln -s libcrypto.so.1.1 libcrypto.so.1.0.0

Now I have those in place it is time for more testing.

Share this post


Link to post
Share on other sites

Now I am seeing this error:

home/steam/Atlas/Server/ShooterGame/Binaries/Linux/ShooterGameServer: /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.1' not found (required by /home/steam/Atlas/Server/ShooterGame/Binaries/Linux/libaws-cpp-sdk-core.so)

And I do have openssl updated. More digging to do, but this is progress.

Share this post


Link to post
Share on other sites
Quote

https://www.openssl.org/source/

Note: The latest stable version is the 1.1.1 series. This is also our Long Term Support (LTS) version, supported until 11th September 2023. Our previous LTS version (1.0.2 series) will continue to be supported until 31st December 2019 (security fixes only during the last year of support). The 1.1.0 series is currently only receiving security fixes and will go out of support on 11th September 2019. All users of 1.0.2 and 1.1.0 are encouraged to upgrade to 1.1.1 as soon as possible. The 0.9.8, 1.0.0 and 1.0.1 versions are now out of support and should not be used.

So it looks like the computer @Rob is using for the build has an obsolete openssl version that is on the "Don't Use" list. That is the last thing that looks to be stopping my server from working.

Share this post


Link to post
Share on other sites
3 minutes ago, Nelson Sandalwood said:

So where are the devs on this, the posted it, and they said they wanted feedback, and then they have just ignored the fact that it doesn't work 

 

@Rob @Jatheish Is this thing on?

Share this post


Link to post
Share on other sites

I got past the openssl versioning issue on Amazon Linux 2 by just checking out openssl 1.0.0, building it and symlinking to where i built it without installing it to the system so that it doesn't fuck everything else up.  I had not tried just symlinking the existing openssl libraries on the machine because 1.0.0 is SOOOOOOOOO old, they are not binary compatible anymore unless they are being linked just for show: https://abi-laboratory.pro/index.php?view=timeline&l=openssl

At any rate, I'm now stuck trying to load the files in, will report if i figure out why it just stalls.

Share this post


Link to post
Share on other sites

Hi,
i get "no subscription" but bought atlas. What did i miss? Do i need to pay extra for the atlas dedicated server?

Here my call to install atlas:

steam@dragon:~$ steamcmd
Redirecting stderr to '/home/steam/.steam/logs/stderr.txt'
[  0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Steam>login angor9

Logging in user 'angor9' to Steam Public...
Using cached credentials. . .
Logged in OK
Waiting for user info...OK

Steam>force_install_dir /home/steam/atlas/

Steam>app_update 1006030
ERROR! Failed to install app '1006030' (No subscription)

Steam>

Share this post


Link to post
Share on other sites
5 minutes ago, angor said:

Hi,
i get "no subscription" but bought atlas. What did i miss? Do i need to pay extra for the atlas dedicated server?

Here my call to install atlas:

steam@dragon:~$ steamcmd
Redirecting stderr to '/home/steam/.steam/logs/stderr.txt'
[  0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Steam>login angor9

Logging in user 'angor9' to Steam Public...
Using cached credentials. . .
Logged in OK
Waiting for user info...OK

Steam>force_install_dir /home/steam/atlas/

Steam>app_update 1006030
ERROR! Failed to install app '1006030' (No subscription)

Steam>

login anonymous

 

instead of your user

Share this post


Link to post
Share on other sites
1 hour ago, Forrondy said:

login anonymous

 

instead of your user

Thanks, that worked. I didn't expect that to even be a possibility.

Edited by angor

Share this post


Link to post
Share on other sites
15 hours ago, RyanUk said:

My servers now launch and stay up but it seems they hang on: "Setting breakpad minidump AppID = 834910"

I've increased the max files open and the ulimit stuff to 100k for the steam user I'm using to launch the game so I don't think it's that.

Any ideas?

For me, it's actually getting past that but not writing out to the console or the log file.  If I interrupt while it's sitting there with a Ctrl-C and then check the log file I can see that it

 

[2019.01.18-03.22.44:243][  0]Log file open, 01/18/19 03:22:44
[2019.01.18-03.22.44:243][  0]ATLAS Version: 11.4 (Rev. 106774)
[2019.01.18-03.22.44:243][  0]PID: 17046
[2019.01.18-03.22.56:616][  0]Primal Game Data Took 12.17 seconds
[2019.01.18-03.22.58:577][  0]SteamSocketsOpenSource: gethostname failed ()
[2019.01.18-03.22.58:577][  0]gethostbyname failed ()
[2019.01.18-03.23.04:767][  0]Server Initializing with BattlEye Anti-Cheat Protection. If you do not wish to use BattlEye, please launch with -NoBattlEye
[2019.01.18-03.23.04:768][  0]BattlEye successfully started.
[2019.01.18-03.23.04:768][  0]Network range scales set to: 48 start, 77 end, 0.440000 endscale

But it is just hung up still... netstat is showing the receive queue growing as i try to query it for life...

[2019.01.18-03.22.44:243][  0]Log file open, 01/18/19 03:22:44
[2019.01.18-03.22.44:243][  0]ATLAS Version: 11.4 (Rev. 106774)
[2019.01.18-03.22.44:243][  0]PID: 17046
[2019.01.18-03.22.56:616][  0]Primal Game Data Took 12.17 seconds
[2019.01.18-03.22.58:577][  0]SteamSocketsOpenSource: gethostname failed ()
[2019.01.18-03.22.58:577][  0]gethostbyname failed ()
[2019.01.18-03.23.04:767][  0]Server Initializing with BattlEye Anti-Cheat Protection. If you do not wish to use BattlEye, please launch with -NoBattlEye
[2019.01.18-03.23.04:768][  0]BattlEye successfully started.
[2019.01.18-03.23.04:768][  0]Network range scales set to: 48 start, 77 end, 0.440000 endscale

Am going to try a few ubuntu machines, see if i can get it to work anywhere and see what the difference is between the machines.

Share this post


Link to post
Share on other sites

Ok, so I have a workaround to the libcurl issue, use at your own risk,
See:  https://launchpad.net/~xapienz/+archive/ubuntu/curl34

these commands in ubuntu 18.04

sudo add-apt-repository ppa:xapienz/curl34
sudo apt-get update
sudo apt install libcurl4

But now that is solved, I have a new problem (of course 🙂 )
 


4.5.1-0+UE4 7038 3077 408 10
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 834910
Signal 11 caught.
EngineCrashHandler: Signal=11
Segmentation fault (core dumped)
 

 

Share this post


Link to post
Share on other sites
1 hour ago, Nelson Sandalwood said:

Ok, so I have a workaround to the libcurl issue, use at your own risk,
See:  https://launchpad.net/~xapienz/+archive/ubuntu/curl34

these commands in ubuntu 18.04

sudo add-apt-repository ppa:xapienz/curl34
sudo apt-get update
sudo apt install libcurl4

But now that is solved, I have a new problem (of course 🙂 )
 


4.5.1-0+UE4 7038 3077 408 10
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 834910
Signal 11 caught.
EngineCrashHandler: Signal=11
Segmentation fault (core dumped)
 

 

Same problem here..

Share this post


Link to post
Share on other sites

"Signal 11 caught.
EngineCrashHandler: Signal=11
Segmentation fault (core dumped)"

 

delete save the map and it should start as you reboot and the map files will be generated, the server has a problem to load them from the file

Share this post


Link to post
Share on other sites

I want to run my grids on Linux but I see that for now I'll keep going on windows. My boxes are fairly stable and been running smoothly since 30 December.

 

Ill keep watching this thread like a hawk 🙂

Share this post


Link to post
Share on other sites

I found a solution to the problem with writing and libraries find on the system the latest

find / -name file "libssl.so. *"

then upload it to the directory "/atlas/ShooterGame/Binaries/Linux" under the name "libssl.so.1.0.0"

For me, the world record and restart have been working without a problem

 

steam://connect/94.23.211.192:57561
 

 

Edited by muny

Share this post


Link to post
Share on other sites
19 minutes ago, muny said:

I found a solution to the problem with writing and libraries find on the system the latest

find / -name file "libssl.so. *"

then upload it to the directory "/atlas/ShooterGame/Binaries/Linux" under the name "libssl.so.1.0.0"

Lucky, but if not using OpenSSL 1.0.1 or 1.0.0 it will fail on that, so not a workaround that will work for all.
I for one won't be downgrading SSL. It should be up to devs to use supported versions! 1.0.0/1.0.1 is NOT supported.

Share this post


Link to post
Share on other sites

I am currently using "libssl.so.1.1" but changed its name to "libssl.so.1.0.0"

1.1 - Is not it the latest?

Share this post


Link to post
Share on other sites
39 minutes ago, StevenB said:

Lucky, but if not using OpenSSL 1.0.1 or 1.0.0 it will fail on that, so not a workaround that will work for all.
I for one won't be downgrading SSL. It should be up to devs to use supported versions! 1.0.0/1.0.1 is NOT supported.

Definitely, 1.0.0 is something like 6 years old with known vulnerabilities, nobody should be using 1.0.0 as their system libssl and libcrypto.  You can compile them yourself like i did or (if you are lucky) use more recent ones.  The AWS libs appeared to verify the libssl and libcrypto versions when I attempted that.  Also, the binary interface has had some significant changes since 1.0.0 so even if it looked like it worked it could fail in very irritating to troubleshoot ways.

For now, building openssl 1.0.0 and putting it directly in the Binaries/Linux folder works.  Only Atlas is using this shitty old version, the rest of the system continues to use the correct version.

Devs really really really need to link against 1.1.x though, since that is the current release on most distros right now and *should* be binary compatible with up to date 1.0.2x and 1.1.1.

34 minutes ago, muny said:

I am currently using "libssl.so.1.1" but changed its name to "libssl.so.1.0.0"

1.1 - Is not it the latest?

1.1.1a is the latest, but is not the current version supported in all distros

Share this post


Link to post
Share on other sites
1 hour ago, muny said:

"Signal 11 caught.
EngineCrashHandler: Signal=11
Segmentation fault (core dumped)"

 

delete save the map and it should start as you reboot and the map files will be generated, the server has a problem to load them from the file

What files did you delete to get past this point?

Share this post


Link to post
Share on other sites

Like Forrondy said, one would have to compile/get 1.0.0 openssl and put it in Binaries/Linux, just copying and renaming won't work unless openssl 1.0.0 is already available on the system somewhere and even then could cause weird issues because they would not be binary compatible.

He deleted the savefiles I suppose, but that will only work once 😛

Share this post


Link to post
Share on other sites

Just realized i double pasted my ShooterGame.log lastnight instead of my netstat output:

[ec2-user@ip-172-31-45-98 ShooterGame]$ netstat -latun
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:6379          127.0.0.1:57562         ESTABLISHED
tcp        0      0 127.0.0.1:6379          127.0.0.1:57560         ESTABLISHED
tcp        0      0 127.0.0.1:57562         127.0.0.1:6379          ESTABLISHED
tcp        0      0 127.0.0.1:57560         127.0.0.1:6379          ESTABLISHED
tcp        0    272 172.31.45.98:22         75.177.131.36:64170     ESTABLISHED
tcp6       0      0 :::111                  :::*                    LISTEN
tcp6       0      0 :::22                   :::*                    LISTEN
udp        0      0 0.0.0.0:68              0.0.0.0:*
udp        0      0 0.0.0.0:111             0.0.0.0:*
udp        0      0 127.0.0.1:323           0.0.0.0:*
udp        0      0 0.0.0.0:647             0.0.0.0:*
udp     6272      0 0.0.0.0:27015           0.0.0.0:*
udp        0      0 0.0.0.0:5761            0.0.0.0:*
udp6       0      0 :::111                  :::*
udp6       0      0 ::1:323                 :::*
udp6       0      0 fe80::cee:81ff:fe30:546 :::*
udp6       0      0 :::647                  :::*
[ec2-user@ip-172-31-45-98 ShooterGame]$

I can see that the server has opened connections to redis, though no keys have been added, and that it managed to open the query port and game port, but it is not consuming the packets on the query port.  Just in case that info helps the devs figure out where it all goes wrong.

Share this post


Link to post
Share on other sites

Oh, also just noticed that they haven't pushed new server builds, lol... thought we would have v14 to be trying this morning.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×