Jump to content

PSA to Xbox players regarding low FPS Read more... ×
Unable to gain experience points in Freeports? Read more... ×
raysen

Kick after installing battleye

Recommended Posts

Hey Jatheish, thanks for looking into this. We know you are super busy and probably working long hours.

 

23 minutes ago, Jatheish said:

Could you guys try the following, please:

Browse to the following directory: steamapps\common\ATLAS\ShooterGame\Binaries\Win64

and right click: ATLASGame_BE and select "Run as administrator" and let me know if that works out.

From the sounds of it, seems like it doesn't have the right permissions on your PC, perhaps due to antivirus or security software blocking it, you may need to add it to an exceptions list.

 

I have tried that. I will try again now, also running steam in admin mode, and i went to the core battleye folder itself and set that exe to run in admin mode. I set steam to run in admin mode and the ATLASGame_BE to run as admin. no luck here. kicked out after about 15 seconds. (same result)

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Eyesnthedark said:

Hey Jatheish, thanks for looking into this. We know you are super busy and probably working long hours.

I have tried that. I will try again now, also running steam in admin mode, and i went to the core battleye folder itself and set that exe to run in admin mode. I set steam to run in admin mode and the ATLASGame_BE to run as admin. no luck here. kicked out after about 15 seconds. (same result)

3

Which operating system are you running? 

Share this post


Link to post
Share on other sites
3 minutes ago, Jatheish said:
11 minutes ago, Eyesnthedark said:
3

Which operating system are you running?

Win 7 64 bit

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, Jatheish said:

Which operating system are you running? 

Hello there!

I have a similar problem but with different error.

 

19:41:04: Starting BattlEye Service...
19:41:07: Launching game...
19:41:09: Note: File blocks can be ignored if they don't cause problems with the game.
19:41:09: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\uxtheme.dll".
19:41:09: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\edputil.dll".
19:41:09: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\urlmon.dll".
19:41:09: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\cldapi.dll".
19:41:09: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\slc.dll".
19:41:09: [INFO] Blocked loading of file: "C:\Windows\System32\apphelp.dll".
19:41:10: [INFO] Blocked loading of file: "C:\Windows\System32\opengl32.dll".
19:41:10: [INFO] Blocked loading of file: "C:\Windows\System32\dbghelp.dll".
19:41:10: [INFO] Blocked loading of file: "C:\Windows\System32\wininet.dll".

 

I have been battling this for 4 hours now and I can`t find a solution. 

 

My OS is Windows 10 Pro Education insider preview 64bit. I don`t have another PC to check it but I think the problem is with windows version.

Share this post


Link to post
Share on other sites
12 minutes ago, Jatheish said:

Which operating system are you running? 

Windows 10 Pro Insiders Preview 

Version 1809

OS Build 18309.1000

Tried Running ATLASGame_BE as admin with it still Disconnecting with Memory Leak error from Battleye 

Share this post


Link to post
Share on other sites
17 minutes ago, Jatheish said:

Which operating system are you running? 

I'm running Windows 10 Pro Insider Preview Build 18312.rs_prerelease 190104-1630.

I have also downloaded the battlEye documentation and will be checking that for installation errors.

Share this post


Link to post
Share on other sites
1 hour ago, Jatheish said:

Could you guys try the following, please:

Browse to the following directory: steamapps\common\ATLAS\ShooterGame\Binaries\Win64

and right click: ATLASGame_BE and select "Run as administrator" and let me know if that works out.

From the sounds of it, seems like it doesn't have the right permissions on your PC, perhaps due to antivirus or security software blocking it, you may need to add it to an exceptions list.

I've completely unistalled my antivirus (norton system suite) no luck same error after 10 seconds of play or so.

Share this post


Link to post
Share on other sites

BattlEye is not compatible with Windows 10 'Insider' builds, so this will explain why we're seeing some of the reports at the moment. It's not an operating system we support on our Official Network. I'll discuss with the team to see if there's anything that can change but I wouldn't have high hopes for an immediate resolution. We recommend for minimum specs that users are running the standard versions of Windows 7/8.1/10 (64-bit). It may be something in time that BattlEye will be able to support, but we're/they're not able to cover all spectrums, unfortunately. 

Share this post


Link to post
Share on other sites
36 minutes ago, Jatheish said:

BattlEye is not compatible with Windows 10 'Insider' builds, so this will explain why we're seeing some of the reports at the moment. It's not an operating system we support on our Official Network. I'll discuss with the team to see if there's anything that can change but I wouldn't have high hopes for an immediate resolution. We recommend for minimum specs that users are running the standard versions of Windows 7/8.1/10 (64-bit). It may be something in time that BattlEye will be able to support, but we're/they're not able to cover all spectrums, unfortunately. 

So do we complain to Steam that you don't/can't/won't support our systems or are implementing 3rd party crap that doesn't so we can get our money back?

P.S.  Windows 7 is dead (Microsoft won't support it) as of next year, unless you have a Corporate client license.

Edited by Hambo

Share this post


Link to post
Share on other sites

I love your game but this is just too much. :classic_blush: I don`t want the money back. I want to play this game but you guys are not leaving me many options.

Edited by TudumZagorac

Share this post


Link to post
Share on other sites
59 minutes ago, Jatheish said:

We recommend for minimum specs that users are running the standard versions of Windows 7/8.1/10 (64-bit). It may be something in time that BattlEye will be able to support, but we're/they're not able to cover all spectrums, unfortunately. 

My other PC that runs the game, has the same windows 7 premium edition, i'm not sure that is the issue in my case. That PC is nearly dead or else i'd just use it. For now i'm using it to log in long enough to repair my boats in freeport until this is resolved.

 

Edited by Eyesnthedark

Share this post


Link to post
Share on other sites

We finally find a way to avoid the battleeye bug but it's kinda shitty to do.

Log in using Atlasgame_BE.exe.

step 1: When you are ingame kill yourself. Fast way to do it : it's press R to combat mode - left control - block spam with left/right mouse.

Step 2: The map to respawn is gunna be flash green. Chose change home server (bottom right) chose a new one and respawn. (at this point you will probably get kick out server)

Step 3: Log back at freeport and kill yourself again.

Step 4: respawn at your base and you should be fine till you die or DC again....

Look like it's a server region problem.

I hope it help you play till they finally fix this dumb BE update.

 

Share this post


Link to post
Share on other sites

I've spoken to the BattlEye developers and they're going to be working on an update which will provide support for those beta/insider operating systems. There's no real timeline on it atm but hoping they'll have it done within the week.

  • Like 1
  • Confused 1

Share this post


Link to post
Share on other sites
21 minutes ago, Jatheish said:

I've spoken to the BattlEye developers and they're going to be working on an update which will provide support for those beta/insider operating systems. There's no real timeline on it atm but hoping they'll have it done within the week.

For myself I thank you for the effort.  I have beta tested software since the 1980s, including a majority of Microsoft's products... That's why I'm in the Insider Program after it replaced the previous "Official" beta program.

It's also one of the reasons I don't mind registering for Early Access programs :classic_cool:

  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, Jatheish said:

Could you guys try the following, please:

Browse to the following directory: steamapps\common\ATLAS\ShooterGame\Binaries\Win64

and right click: ATLASGame_BE and select "Run as administrator" and let me know if that works out.

From the sounds of it, seems like it doesn't have the right permissions on your PC, perhaps due to antivirus or security software blocking it, you may need to add it to an exceptions list.

Nice, did you catch up on the workaround that has been posted on steam forums to Ark's BattleEye problem in 2016? Nevertheless, it doesn't help me in Atlas. That was about the first thing I've tried after having read the old steam forum entry that I've posted  here aswell... 🙄

6 hours ago, Jatheish said:

What version of Windows do you have installed? Are you using an insider build or a prelease Win 10 build?

I run Win 10 Home x64

3 hours ago, Jatheish said:

BattlEye is not compatible with Windows 10 'Insider' builds, so this will explain why we're seeing some of the reports at the moment. It's not an operating system we support on our Official Network. I'll discuss with the team to see if there's anything that can change but I wouldn't have high hopes for an immediate resolution. We recommend for minimum specs that users are running the standard versions of Windows 7/8.1/10 (64-bit). It may be something in time that BattlEye will be able to support, but we're/they're not able to cover all spectrums, unfortunately. 

But I run Win 10 Home with 16 GB RAM on a GTX1070 OC (way above min specs!) and I'm still not supported! 0 Malware, 0 Memory errors. How come?

1 hour ago, Jatheish said:

I've spoken to the BattlEye developers and they're going to be working on an update which will provide support for those beta/insider operating systems. There's no real timeline on it atm but hoping they'll have it done within the week.

And the rest with normal OS and i.e. the omniscient "memory #0 error" can't play for good?

20bab881c37db4eb3cf3bb7896a4c9b2-full.jp

So far, you did nothing but ask us to clean or reinstall our systems while your patch broke the game for half the player base and you don't even answer why you leave it that way for days.  Is that game support?

Share this post


Link to post
Share on other sites
5 hours ago, Jatheish said:

I've spoken to the BattlEye developers and they're going to be working on an update which will provide support for those beta/insider operating systems. There's no real timeline on it atm but hoping they'll have it done within the week.

Nice, sounds like real progress. I'm backing up my data now in case it doesn't work for me, 6 hours in 21 % backed up. I'm not sure it's an answer for me because i have an identical OS win 7 64 bit premium version on 2 PCs, works with one computer and not the other. Almost identical motherboards, same CPU, one has 2 gtx 780s (sli disabled, but worked for the first 300 hours of gameplay) the other has a 960 (currently works) The only difference is the types of ram (which i've switched around, same result) Identical hard drives for the most part. engineer copies of the intel 540 SSD. 

Share this post


Link to post
Share on other sites
4 hours ago, Theo Riginal said:

Nice, did you catch up on the workaround that has been posted on steam forums to Ark's BattleEye problem in 2016? Nevertheless, it doesn't help me in Atlas. That was about the first thing I've tried after having read the old steam forum entry that I've posted  here aswell... 🙄

I run Win 10 Home x64

But I run Win 10 Home with 16 GB RAM on a GTX1070 OC (way above min specs!) and I'm still not supported! 0 Malware, 0 Memory errors. How come?

And the rest with normal OS and i.e. the omniscient "memory #0 error" can't play for good?

20bab881c37db4eb3cf3bb7896a4c9b2-full.jp

So far, you did nothing but ask us to clean or reinstall our systems while your patch broke the game for half the player base and you don't even answer why you leave it that way for days.  Is that game support?

From what I see, the Atlas people aren't the one's who messed this up. I currently can't play any games that use Battleye. Since Atlas just started using Battleye, I was unaware that Battleye had a recent update that prevents people using the Windows Insider builds from playing games. This is incredibly frustrating. A good chunk of my games use Battleye and I can't play any of them now.

Share this post


Link to post
Share on other sites
6 minutes ago, xReadyAimMissx said:

From what I see, the Atlas people aren't the one's who messed this up. I currently can't play any games that use Battleye. Since Atlas just started using Battleye, I was unaware that Battleye had a recent update that prevents people using the Windows Insider builds from playing games. This is incredibly frustrating. A good chunk of my games use Battleye and I can't play any of them now.

I can't play PuBG but I can still log on and play on Ark official servers. strange

 

Share this post


Link to post
Share on other sites
6 hours ago, xReadyAimMissx said:

From what I see, the Atlas people aren't the one's who messed this up. I currently can't play any games that use Battleye. Since Atlas just started using Battleye, I was unaware that Battleye had a recent update that prevents people using the Windows Insider builds from playing games. This is incredibly frustrating. A good chunk of my games use Battleye and I can't play any of them now.

Since WildCard aka GrapeShot implemented BattleEye, it's of course their responsability! Also, I don't have any special build OS, plain normal Windows 10 Home x64 and it still kicks me for no reason.

If you implement a cheat detector that kicks half the player base for no reason and you do it again 3 years later with the same problems on your next game and then you dont change back after days of unplayability on ALL official servers for so many players and you only question the player base's PC cleansiness and suggest re-installations or starting it with admin privileges even though so many players tell you they've done it and it's useless: You yourself messed up 4 times on 1 occasion. Unheard of if what you implemented was bugged to begin with. You forced that game-breaker on your players and didn't help to solve it noticeably.

Share this post


Link to post
Share on other sites

I instal 2 games wiht battleye conan exiles and heroes and general. They do not have a problem with battleye. 

Atlas kick me 10-30 sec "corrupted memory 0"

Reinstal system, ram 0 bugs, 0 trojan and spyware, forbidden ativirus

Share this post


Link to post
Share on other sites

For those that don't have beta/insider operating system, I know of someone that had issues today being kicked from servers due to battleye.

This is what they did to resolve the problem, although please note that I am not telling people to do this, i'm just saying this fixed it for that person and may or may not help others. It may infact be due to the person possible selecting no when the original prompt came up, but if people weren't expecting a battleye update in the Atlas patch then some may have done the same, along with selecting the "don't show me again" option.

They ran uninstall_battlEye.bat, (located in Steam > steamapps > common > ATLAS > ShooterGame > Binaries > Win64 > BattlEye)  then after that ran install_battlEye.bat. Then when it's finished, run Atlas from Steam, and it should ask you if you want to give battleye access. Select yes and then they could join the server without being kicked.

He may not have needed to run uninstall first as the issue my be that he decline access originally so he may have just needed to run the install_battlEye.bat again.

As I said i'm not recommending anything, just stating what i know from someone that had the an issue of being kicked from servers after the battleye update.

Share this post


Link to post
Share on other sites
On 1/14/2019 at 4:57 PM, Jatheish said:

BattlEye is not compatible with Windows 10 'Insider' builds, so this will explain why we're seeing some of the reports at the moment. It's not an operating system we support on our Official Network. I'll discuss with the team to see if there's anything that can change but I wouldn't have high hopes for an immediate resolution. We recommend for minimum specs that users are running the standard versions of Windows 7/8.1/10 (64-bit). It may be something in time that BattlEye will be able to support, but we're/they're not able to cover all spectrums, unfortunately. 

So, what about those of us stuck at loading primalgamedata that do NOT play on BE enabled private servers and still cannot play?

Edited by twiafu

Share this post


Link to post
Share on other sites
10 hours ago, [GP] Guybrush Threepwood said:

Uninstall_battlEye.bat, (located in Steam > steamapps > common > ATLAS > ShooterGame > Binaries > Win64 > BattlEye)  then after that ran install_battlEye.bat. Then when it's finished, run Atlas from Steam, and it should ask you if you want to give battleye access. Select yes and then they could join the server without being kicked.

He may not have needed to run uninstall first as the issue my be that he decline access originally so he may have just needed to run the install_battlEye.bat again.

As I said i'm not recommending anything, just stating what i know from someone that had the an issue of being kicked from servers after the battleye update.

That's a constructive tipp, thanks a lot!

Tried it, but not much happens when I execute install_battlEye.bat. I did get another prompting windows when starting up Atlas from steam though. It's just the EULA to be confirmed with "Okay", not a yes or no option. Unfortunately it didn't change anything, 30 seconds in I get the same "memory #0" kick.

I greatly appreciate the tipp anyway, was worth a try!

Share this post


Link to post
Share on other sites

I fixed mine, but you guys won't like what you hear. I mean I went through everything before doing this but with no luck. Full reformat and reinstalling of my OS fixed it. I couldn't just reinstall windows (I tried) actually upraded my OS to win 10 64. still no dice. I put in brand new ram sticks fresh out the package, same result. I reinstalled atlas, deleted atlas, deleted battlEye, reinstalled directx and Microsoft VC. I ran memtest, I scanned disk. I did a lot more also but you get the point.

I ended up purging everything, full format. All of  it. The BattlEye uninstall program won't remove the large crap it's taken in your OS registry if you get this error. If it is that, you must reinstall the OS, just like it says on the BattlEye FAQ. Turns out the "gold standard of anticheat" is really electroplated. Oh well, i'm back in, and if my neck turns green from a fake gold chain then oh well. At least im sailing the seas. I think the only way you can avoid this would be to go through and manually edit your registry to remove the large lumps of poo that BattlEye left in there. I think reinstalling windows would be faster. Even more so if you have no experience with registry repairs.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Eyesnthedark said:

I fixed mine, but you guys won't like what you hear. I mean I went through[...]

:classic_ohmy: Oh my! Thx for the report. I'm not gonna exchange hardware or completely re-install my OS for Atlas only for now, still hoping the devs from Grapeshot or BattleEye get their filters right with one of the next patches. Still getting kicked so far. So long, I play on the 9x9 Community Server without BattleEye. Also, there's much less grind over there!  👍

Edited by Theo Riginal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×