Jump to content

Felenk

Any fix for the blank Treasure maps yet?

Recommended Posts

I have a private 2x2 and everyones Maps work, just have blank treasure maps. I've tried everything to include the destroywilddinos, verified ports 0,0 57555 5755 27000, 0,1 57557 5757 27004, 1,0 57559 5759 27008, 1,1 57561 5761 27012. Also, I used the latest editor with JPG to creat this 2x2.

 

Any ideas or suggestion would be welcome.

 

Thanks!

Edited by Felenk

Share this post


Link to post
Share on other sites

change cell image to jpeg thats what we did and we have now working treasure maps for our 2x2

Edited by SpankyDruid

Share this post


Link to post
Share on other sites

Changing the cellimg from .jpg to jpeg broke the maps along with the blank treasure maps. 

Share this post


Link to post
Share on other sites

I've been hoping for a fix too.
The Server preview map in the lobby shows the world map correctly, but in game it is a blank/greyed out.

Currently have:
-MapImgURL and MetaWorldURL populated with direct download links to the map/cell files which is hosted on Google Drive.
-Cleared MapImagesCache folder on local machine.
-Also tried copying the map/cell jpg files directly to the MapImagesCache folder
-Changed cell names from CellImg_0-0  to  GridCellIMapImage_0-0.jpg (0-1, 1-0, etc.)
-Changed MapImg to WorldMapImage.jpg

Tried everything so far on the forums, still blank grey map.

Share this post


Link to post
Share on other sites
12 hours ago, Felenk said:

Changing the cellimg from .jpg to jpeg broke the maps along with the blank treasure maps. 

well its shouldn't of done this is how we fixed the treasure maps and did u rename the file to cellimage.jpeg ?or did it in the editor ?

 

cell.jpg

Edited by SpankyDruid

Share this post


Link to post
Share on other sites
8 minutes ago, SpankyDruid said:

well its shouldn't of done this is how we fixed the treasure maps and did u rename the file to cellimage.jpeg ?or did it in the editor ?  these are taken from our 2x2 set up so its defo working when change to JPEG

 

cell.jpg

 

tresure.jpg

Edited by SpankyDruid

Share this post


Link to post
Share on other sites

I saved the exports are jpeg from the editor and still have broken maps. I also changed the client side saved mapchache and servergrid to include the jpeg, still broke. Going to roll back the changes so we'll at least have working maps.

Thanks for your suggestion though, it was worth a shot. Getting these treasure maps is more painful then snorting a line of Wasabi. I've only a few more days until I lose most of the server crew, not having an important part of the game is limiting managing large ships with crew.

 

Share this post


Link to post
Share on other sites
On 1/12/2019 at 3:41 PM, Felenk said:

Unfortunately that didn't fix my issue

One thing you can do is open your map with paint and resave them in .jpg format. Must be the exact same name they are when you export them.

Share this post


Link to post
Share on other sites
40 minutes ago, Starbuck said:

One thing you can do is open your map with paint and resave them in .jpg format. Must be the exact same name they are when you export them.

Exactly this. DO NOT CHANGE NAMES. I did and my map was always greyed out.

Since adding the files as the image shows mine always work now.

Share this post


Link to post
Share on other sites

Maybe I'm a bit confused, my img were already .jpg I changed them to jpeg and that didn't work either, I changed them back to the original .jpg and maps work, just not treasure maps.

 

Share this post


Link to post
Share on other sites

Found my solution.

created a static IIS website to host the map img files.
 

"MetaWorldURL": "http://<server IP>/servergrid",
"MapImageURL": "http://<server IP>/mapimg.jpg",

This worked for a local network setup.

  • Thanks 1

Share this post


Link to post
Share on other sites
29 minutes ago, oliv3r said:

Found my solution.

created a static IIS website to host the map img files.
 

"MetaWorldURL": "http://<server IP>/servergrid",
"MapImageURL": "http://<server IP>/mapimg.jpg",

This worked for a local network setup.

What pixel size are your images for the MetaWorldURL and the MapImageURL?

Share this post


Link to post
Share on other sites
On 1/13/2019 at 7:01 PM, Felenk said:

Maybe I'm a bit confused, my img were already .jpg I changed them to jpeg and that didn't work either, I changed them back to the original .jpg and maps work, just not treasure maps.

 

Download the new map editor and export a fresh copy of all the stuff. You might have been using an outdated version of the editor

Share this post


Link to post
Share on other sites
On 1/18/2019 at 12:52 AM, oliv3r said:

Found my solution.

created a static IIS website to host the map img files.
 

"MetaWorldURL": "http://<server IP>/servergrid",
"MapImageURL": "http://<server IP>/mapimg.jpg",

This worked for a local network setup.

Yes!! So I set up an Apache Web Server and hosted the cell images and map image as-is and everything is back. The key for me was the WorldMapImage.jpg file in my steam cache was a 404 html response, not an actual image.

So the login map preview in ServerGrid.json is MapImageUrl and the server grid files (cells and mapimg) is the MetaWorldURL, which is only a directory path on the web server. 

Share this post


Link to post
Share on other sites

I just wanted to point out that my problem was in the command line of the bat file.
The seamless IP needs to be your public ip so that people are actually allowed to download the img from your hosted server. 

Share this post


Link to post
Share on other sites
On 1/12/2019 at 7:31 PM, Felenk said:

I have a private 2x2 and everyones Maps work, just have blank treasure maps. I've tried everything to include the destroywilddinos, verified ports 0,0 57555 5755 27000, 0,1 57557 5757 27004, 1,0 57559 5759 27008, 1,1 57561 5761 27012. Also, I used the latest editor with JPG to creat this 2x2.

 

Any ideas or suggestion would be welcome.

 

Thanks!

Hey,

I got this problem too when i installed my server. And the problem was an IP not being configured correctly. 
Here is the command to launch one of all server :
start A:\AtlasServer\ShooterGame\Binaries\Win64\ShooterGameServer.exe Ocean?ServerX=0?ServerY=2?AltSaveDirectoryName=A3_0-2?MaxPlayers=30?ReservedPlayerSlots=0?RCONEnabled=True?RCONPort=28330?QueryPort=28315?Port=28300?SeamlessIP=XXX.XXX.XXX.XXX?ForceAllStructureLocking=true -log -server -NoBattlEye
In this command there's something very important, it's the SeamlessIP=XXX.XXX.XXX.XXX option. You must  have it in your command and your MUST put the PUBLIC IP, not the internal IP (127.X.X.X).
Also, in your ServerGrid.json, for each grid you should have an option called "seamlessDataPort": XXXXX, the soft handle it directly you should do nothing about that, only control that the option is here for each grid and each port is UNIQUE for each grid. Basically the ports will be 27000, 27001, 27002 etc

 

About the images name, DO NOT CHANGE their name :

Screenshot_101.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×