Jump to content

Sign in to follow this  
KillJoy

Patch 8.72 FATAL ERROR after update HELP!!!

Recommended Posts

---------------------------
The UE4-ShooterGame Server has crashed and will close
---------------------------
Fatal error!



VERSION: 8.72
ShooterGameServer.exe!UDatabase_SharedLog_Redis::Init() (0x00007ff74a20461d) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\classes\database_sharedlog_redis.cpp:87]
ShooterGameServer.exe!AShooterGameMode::InitializeDatabaseRefs() (0x00007ff74a6c42b7) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergamemode.cpp:7180]
ShooterGameServer.exe!AShooterGameMode::OnDeserializedByGame() (0x00007ff74a6cedfe) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergamemode.cpp:10250]
ShooterGameServer.exe!UWorld::LoadFromFile() (0x00007ff74b7f3fb6) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\world.cpp:7360]
ShooterGameServer.exe!AShooterGameMode::LoadWorld() (0x00007ff74a6cc7ee) + 164 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergamemode.cpp:2434]
ShooterGameServer.exe!AShooterGameMode::InitGame() (0x00007ff74a6ba707) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergamemode.cpp:1064]
ShooterGameServer.exe!UWorld::InitializeActorsForPlay() (0x00007ff74b7f17d6) + 45 bytes [h:\yarkupdate\engine\source\runtime\engine\private\world.cpp:3408]
ShooterGameServer.exe!UEngine::LoadMap() (0x00007ff74b7befad) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\unrealengine.cpp:10356]
ShooterGameServer.exe!UEngine::Browse() (0x00007ff74b7a80db) + 43 bytes [h:\yarkupdate\engine\source\runtime\engine\private\unrealengine.cpp:8888]
ShooterGameServer.exe!UShooterGameInstance::CheckConnectString() (0x00007ff74a68d2f9) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:2904]
ShooterGameServer.exe!UShooterGameInstance::StartGameInstance() (0x00007ff74a699e3a) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:335]
ShooterGameServer.exe!UGameEngine::Init() (0x00007ff74b5fa0f6) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\gameengine.cpp:735]
ShooterGameServer.exe!UShooterEngine::Init() (0x00007ff74a685f8f) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shooterengine.cpp:396]
ShooterGameServer.exe!FEngineLoop::Init() (0x00007ff74a1f74ec) + 0 bytes [h:\yarkupdate\engine\source\runtime\launch\private\launchengineloop.cpp:2109]
ShooterGameServer.exe!GuardedMain() (0x00007ff74a1f6fe2) + 12 bytes [h:\yarkupdate\engine\source\runtime\launch\private\launch.cpp:128]
ShooterGameServer.exe!GuardedMainWrapper() (0x00007ff74a1f70ea) + 5 bytes [h:\yarkupdate\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGameServer.exe!WinMain() (0x00007ff74a1fcd9a) + 17 bytes [h:\yarkupdate\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGameServer.exe!__tmainCRTStartup() (0x00007ff74c4c26bd) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffad80013d2) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffad88d54f4) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffad88d54f4) + 0 bytes [UnknownFile:0]

---------------------------
OK   
---------------------------
 

Share this post


Link to post
Share on other sites

how is your server setup?

only 1 grid? or multiple grids?

and how do you have the save maps? every server need a other map to save in. if the maps are the same this happens.

the server cant load the map.

Share this post


Link to post
Share on other sites
3 minutes ago, jeppekroezen said:

how is your server setup?

only 1 grid? or multiple grids?

and how do you have the save maps? every server need a other map to save in. if the maps are the same this happens.

the server cant load the map.

Hey JEPPEKROEZEN

I have a 2x2 and everything was working fine before the 8.72 update and I've done other updates without any problems

Share this post


Link to post
Share on other sites

They all have their own save folder and like I said everything was working fine before ?

Ocean?ServerX=0?ServerY=0?AltSaveDirectoryName=Atlas001?MaxPlayers=70?ReservedPlayerSlots=30?QueryPort=57555?Port=5755?RCONPort=32357?SeamlessIP=<hidden> -log -server -NoBattlEye

Ocean?ServerX=0?ServerY=1?AltSaveDirectoryName=Atlas002?MaxPlayers=70?ReservedPlayerSlots=30?QueryPort=57557?Port=5757?RCONPort=32358?SeamlessIP=<hidden> -log -server -NoBattlEye

Ocean?ServerX=1?ServerY=0?AltSaveDirectoryName=Atlas003?MaxPlayers=70?ReservedPlayerSlots=30?QueryPort=57559?Port=5759?RCONPort=32359?SeamlessIP=<hidden> -log -server -NoBattlEye

Ocean?ServerX=1?ServerY=1?AltSaveDirectoryName=Atlas004?MaxPlayers=70?ReservedPlayerSlots=30?QueryPort=57561?Port=5761?RCONPort=32360?SeamlessIP=<hidden> -log -server -NoBattlEye

Edited by KillJoy

Share this post


Link to post
Share on other sites

there is a change that your save file is corrupted.. what you can do is backup the current files and try to boot a empty server. if it starts just fine ur savegames are corrupted.

i updated to this update but have no problems.

save dir is indeed correct.

Share this post


Link to post
Share on other sites

Started a fresh server and

---------------------------
The UE4-ShooterGame Server has crashed and will close
---------------------------
Fatal error!



VERSION: 8.72
ShooterGameServer.exe!UDatabase_SharedLog_Redis::Init() (0x00007ff7e3a8461d) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\classes\database_sharedlog_redis.cpp:87]
ShooterGameServer.exe!AShooterGameMode::InitializeDatabaseRefs() (0x00007ff7e3f442b7) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergamemode.cpp:7180]
ShooterGameServer.exe!AShooterGameMode::BeginPlay() (0x00007ff7e3f28bb7) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergamemode.cpp:7381]
ShooterGameServer.exe!ULevel::RouteActorInitialize() (0x00007ff7e4ee6766) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\level.cpp:1981]
ShooterGameServer.exe!UWorld::InitializeActorsForPlay() (0x00007ff7e5071810) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\world.cpp:3412]
ShooterGameServer.exe!UEngine::LoadMap() (0x00007ff7e503efad) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\unrealengine.cpp:10356]
ShooterGameServer.exe!UEngine::Browse() (0x00007ff7e50280db) + 43 bytes [h:\yarkupdate\engine\source\runtime\engine\private\unrealengine.cpp:8888]
ShooterGameServer.exe!UShooterGameInstance::CheckConnectString() (0x00007ff7e3f0d2f9) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:2904]
ShooterGameServer.exe!UShooterGameInstance::StartGameInstance() (0x00007ff7e3f19e3a) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shootergameinstance.cpp:335]
ShooterGameServer.exe!UGameEngine::Init() (0x00007ff7e4e7a0f6) + 0 bytes [h:\yarkupdate\engine\source\runtime\engine\private\gameengine.cpp:735]
ShooterGameServer.exe!UShooterEngine::Init() (0x00007ff7e3f05f8f) + 0 bytes [h:\yarkupdate\projects\shootergame\source\shootergame\private\shooterengine.cpp:396]
ShooterGameServer.exe!FEngineLoop::Init() (0x00007ff7e3a774ec) + 0 bytes [h:\yarkupdate\engine\source\runtime\launch\private\launchengineloop.cpp:2109]
ShooterGameServer.exe!GuardedMain() (0x00007ff7e3a76fe2) + 12 bytes [h:\yarkupdate\engine\source\runtime\launch\private\launch.cpp:128]
ShooterGameServer.exe!GuardedMainWrapper() (0x00007ff7e3a770ea) + 5 bytes [h:\yarkupdate\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGameServer.exe!WinMain() (0x00007ff7e3a7cd9a) + 17 bytes [h:\yarkupdate\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGameServer.exe!__tmainCRTStartup() (0x00007ff7e5d426bd) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffad80013d2) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffad88d54f4) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffad88d54f4) + 0 bytes [UnknownFile:0]

---------------------------
OK   
---------------------------
 

Share this post


Link to post
Share on other sites

Validated 4 times!!!

Only thing I can think of is the redis-server was still running when I did the update not sure if that screwed up anything I did try renaming the redis-atlasdb.rdb and starting the server again but same thing

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×