Jump to content

DeepSeaDuo

Don't get anything from bottles :-(

Recommended Posts

Has anyone else got the problem where nothing is given when picking up bottles from the sea?

Is there a fix?  Is it a config problem?

Thanks in anticipation.

Share this post


Link to post
Share on other sites

They said the chances of there being a map is supposed to be low. I don't know how I screwed up my game, because I get 1 100% of the time. Others are like you, and are reporting none.

Share this post


Link to post
Share on other sites
4 hours ago, Wilddogsgamer said:

They said the chances of there being a map is supposed to be low. I don't know how I screwed up my game, because I get 1 100% of the time. Others are like you, and are reporting none.

got a link to where and who said some bottles should be empty?  I want to calm down my players 🙂

Share this post


Link to post
Share on other sites

wrong they work if your on a dedicated server they need to be set up properly by the admin of the server ... they work on my server after i followed his instructions , have collected many bottles / maps and we are currently on treasure number 7 , this is how you get gold and blueprints. tons of fun.

Share this post


Link to post
Share on other sites
13 hours ago, cpspok said:

wrong they work if your on a dedicated server they need to be set up properly by the admin of the server ... they work on my server after i followed his instructions , have collected many bottles / maps and we are currently on treasure number 7 , this is how you get gold and blueprints. tons of fun.

Who's instructions did you follow CPSPOK?

Share this post


Link to post
Share on other sites

you have to download the map files on your server with the grideditor tool , then make sure there set as .jpeg files , delete all files in your servers atlasmain/shootergame/servergrid folder , and then upload the ones that you downloaded with the grideditor and upload them to that directory on your server . Then restart you server , for some reason the game has them as .png files and they need to be .jpeg . there is tons of people who have posted how they did it here in the forums not sure by who but that is what i did and many others have done and they work great in fact we have a large group of us that are having a blast with the maps , as you get to fight the damned on land with the maps

Share this post


Link to post
Share on other sites
8 minutes ago, cpspok said:

you have to download the map files on your server with the grideditor tool , then make sure there set as .jpeg files , delete all files in your servers atlasmain/shootergame/servergrid folder , and then upload the ones that you downloaded with the grideditor and upload them to that directory on your server . Then restart you server , for some reason the game has them as .png files and they need to be .jpeg . there is tons of people who have posted how they did it here in the forums not sure by who but that is what i did and many others have done and they work great in fact we have a large group of us that are having a blast with the maps , as you get to fight the damned on land with the maps

But have you been able to pick up high quality bottles? The high level maps can give you thousands of gold per chest. My servergrid images are all jpg's but I'm still unable to get maps from high level bottles.  

Interestingly there's an admin command that gives you treasure maps, if I want a map above quality 2.5 say 10 I have to enter the command maybe 50 times before it will give me one quality 10 map.

Share this post


Link to post
Share on other sites
9 minutes ago, thegoob said:

But have you been able to pick up high quality bottles? The high level maps can give you thousands of gold per chest. My servergrid images are all jpg's but I'm still unable to get maps from high level bottles.  

Interestingly there's an admin command that gives you treasure maps, if I want a map above quality 2.5 say 10 I have to enter the command maybe 50 times before it will give me one quality 10 map.

Yes we just did 3 last night got 1042 gold on one bottle

Share this post


Link to post
Share on other sites
1 minute ago, cpspok said:

Yes we just did 3 last night got 1042 gold on one bottle

Out of curiosity how big is the map on your server, I've noticed if I host a 2x2 I can get high quality maps easily, but if I'm hosting the 15x15 official map then I start to struggle. I'm thinking it might have something to do with map size although that's just a guess. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hey there!
I have same issue with bottles dont give maps. I have chance to earn them map about 30/70 %
My server map grid is 2x2 if someone would know. 

Edited by Kaynell

Share this post


Link to post
Share on other sites
1 hour ago, thegoob said:

Out of curiosity how big is the map on your server, I've noticed if I host a 2x2 I can get high quality maps easily, but if I'm hosting the 15x15 official map then I start to struggle. I'm thinking it might have something to do with map size although that's just a guess. 

2x2 ill try to find the thread on how to do it 

 

Share this post


Link to post
Share on other sites
1 hour ago, cpspok said:

you have to download the map files on your server with the grideditor tool , then make sure there set as .jpeg files , delete all files in your servers atlasmain/shootergame/servergrid folder , and then upload the ones that you downloaded with the grideditor and upload them to that directory on your server . Then restart you server , for some reason the game has them as .png files and they need to be .jpeg . there is tons of people who have posted how they did it here in the forums not sure by who but that is what i did and many others have done and they work great in fact we have a large group of us that are having a blast with the maps , as you get to fight the damned on land with the maps

Thanks for your reply.  I've already done all that.  I'm using the latest grid editor.

It's not that I'm seeing black map images - the maps don't go into my inventory at all 😞

  • Like 1

Share this post


Link to post
Share on other sites

here is a guide there is a little more to it i guess than what i told you all so try this hope this helps this is copied and pasted from another person that fixed so many others 

 

I've been having issues on my 2x2 cluster with the map working under various circumstances.  We went through a series of progressions of things working and not working, and it looks like we have an overall fix for map issues on our private server.  Maps are now working in all instances including the main map, zoomed in maps, treasure maps, and maps on clustered servers.  One caveat is we are using Nitrado hosted servers, so YMMV depending on your setup.  Thanks to a few different threads on this, including @Wardster's thread that led to the final solution for our cluster problem.  A bit of this is a rehash of the post here, and I wanted to give proper credit.

 

Exporting Your Maps

  1. Download the latest version of the Server Grid Editor from Github here. The latest version will export all map files with the appropriate names, reducing the potential for errors and typos.
  2. When your grid is all set, turn off any layers you don't want to show up since anything you see will be exported.  I personally prefer "Show lines" and "Water Tile Background" only to be checked.  I found that having the lines helps players visualize the server boundaries and understand where they are in the cluster.  You can edit this file as well in Photoshop or any other editor if you want to add your own logos, server region numbers, etc.
  3. Run Export --> Export Just Map Image and Export --> Export: Just Cell Images.  These two commands will generate your map files.

 

Uploading Files to Server - Primary Server

  1. On your primary server, delete any files that exist in atlasmain/ShooterGame/ServerGrid.
  2. Upload your new map files to that directory.
  3. REBOOT THE SERVER.  This is very important.  If you do not reboot the server the cell image files will not render properly and your regular map won't work past a certain zoom level and your treasure maps will be blank.  If you had existing files, they may show the old images instead of the new ones.
  4. Have all players delete the local map cache on their systems here: steamapps\common\ATLAS\ShooterGame\Saved\MapImagesCache.  They can safely delete all folders if they are playing on multiple servers as the maps will be re-downloaded if they don't exist.  This is necessary to ensure your updated map image is downloaded properly.

 

Uploading Files to Server - Expansion Servers

**Please note these steps have only been tested on Nitrado expansion servers.  Testing and reporting on success on clustered servers through other providers and/or privately hosted setups would be great!

  1. On all of your expansion servers, create the folder atlasexp/ShooterGame/ServerGrid.  
  2. Upload your new map files to that directory.
  3. REBOOT THE SERVER.  This is for the same reasons as the primary server.

Copying files to all of the clustered servers is definitely a manual workaround, but even if you're running a 3x3 it's only a few minutes of work.  Hopefully this directly will be set to synchronize as part of a future update and/or batch job as part of server maintenance by Nitrado or other hosting providers.

 

Hope this helps!  This was a head scratcher for a few days, and I wanted to share what we learned with everyone. 

Remember this has to be done for all servers / tiles / squares what ever you want to call them

Share this post


Link to post
Share on other sites
1 hour ago, thegoob said:

Out of curiosity how big is the map on your server, I've noticed if I host a 2x2 I can get high quality maps easily, but if I'm hosting the 15x15 official map then I start to struggle. I'm thinking it might have something to do with map size although that's just a guess. 

My map is 3x3.  When the server was just a few days old, all players were able to get maps from the bottles.  Now though, nobody gets them.

Share this post


Link to post
Share on other sites

CPSPOK - I think you're misunderstanding the problem.

When we were able to get maps from bottles, we could see the map image correctly.

Now though - we don't get anything at all from the bottles.  Maps do not appear in our inventories.

Share this post


Link to post
Share on other sites

i understand that , i didnt either but doing this made them work . we had bottles but empty , then i did this and bam they had maps

 

Share this post


Link to post
Share on other sites

Okay I found something weird.

So if I spawn in a map with the commands I can go up to maybe 2.5 and get it reliably, above that I might have to type the command over 50 times and for some values it just never seems to work, but if I then spawn in a map with quality over 100 it works again normally. 

 

4 minutes ago, cpspok said:

i understand that , i didnt either but doing this made them work . we had bottles but empty , then i did this and bam they had maps

 

Are you hosting the server through a platform like nitrado, or are you hosting it yourself? 

Share this post


Link to post
Share on other sites

As I can see on my server problem is still present. Or this is ok for every dedicated server? What can you say, guys?

Share this post


Link to post
Share on other sites
18 hours ago, cpspok said:

i understand that , i didnt either but doing this made them work . we had bottles but empty , then i did this and bam they had maps

 

Sadly doesn't work for my server.

 

Share this post


Link to post
Share on other sites

Okay so I have found a possible fix that has worked in my case.

You need to have all the nodes in your Atlas up at once, as bottles of a certain quality can generate maps for different nodes to where they are found. So if I hosted one node in a 2x2 server it would only let me keep the maps every once in a while but once I had all four nodes up at once, I was able to get a map every single time. It means my 15x15 wont get working bottles for the moment though :classic_tongue:

 

Share this post


Link to post
Share on other sites

As an update:  I've found that I get a map from a bottle when the map refers to the grid that I'm currently in.

I'll update again if I find any other patterns.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×