Jump to content

Sign in to follow this  
nobody971

bug Auto anchor with NPC crew

Recommended Posts

Posted (edited)

To be clear:

this is a very specific "test" because i dont have access to spawn and test things properly. so my test is VERY specific. normally id test various things but i dont have the ability to do so without spending hours farming stuff. which is not something im whiling to do.

 

Problem:

1. sloop auto anchors with NPC on sails.

2. Anchor raise visually via icon when leaving the sloop but seems to still be anchored functionally being that the sloop isn't effected by waves like an unanchored ship is. **Needs further testing**

3. Sloop seems anchored even when sailing (see attached pictures). i have not tested any other clues to the sloop actually being registered as anchored or not (via ship of the damned attack or something) because i don't want to loose my sloop. **Needs further testing**

 

Reproduce:

1. have a sloop anchored on small shipyard with med speed sail on 2nd from front slot and an NPC crew member (mines lvl2) on said sail.

2. Open sail manually by opening sail UI and clicking open. (see note 1)

3. get on the wheel and try to raise anchor or do anything sail related with npc on sails. none are responsive. Neither the ship or sails will move.

 

Note 1: I'm not 100% sure this is the cause i just noticed that it acted differently. instead of the anchor raising like I'm used to when i misclick, the anchor stayed down. I'm not sure if i clicked +10% or full.

 

Should be:

1. NPC on sails should not auto anchor sloop.

2. Sloop should anchor when exiting sloop (as per im used to seeing), not raise anchor.

3. sloop should not anchor in deep water (as per im used to seeing) but seems to. **Needs further testing**

 

extra info:

1. sloops acts as normal (minus anchor icon) with NPC not manning any positions.

2. Have not replaced NPC crew member to see if it's just the NPC that's bugged.

3. have not tested with 2nd NPC cew member on wheel.

4. i have tested moving to another region. The bug persists through different regions without step 2 from reproduce section.

20181231212210_1.jpg

20181231212219_1.jpg

20181231212400_1.jpg

Edited by nobody971

Share this post


Link to post
Share on other sites

update: i logged off for ~45min and logged back on and it seems fixed. i tried to reproduce the issue and i cant so far. I checked patch notes thread and asked in game but no one seems to know of a patch sense i was on last. wll update again if i run into the issue a 2nd time.

Share this post


Link to post
Share on other sites

i went to shallow water right clicked the ship to move anchor then quickly went to  the steering wheel and moved it again.. it was like the anchor mechanic was reversed

Edited by tetro_

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×