Jump to content

Recommended Posts

Is there currently a way to change this for unofficial servers? If so, how?

I've heard rumors that some servers have changed theirs..

Share this post


Link to post
Share on other sites

The can be disabled from spawning by using the following in your game.ini.

NPCReplacements=(FromClassName="ShipNPC_Brig_C",ToClassName="")

Not worked out the code yet for changing their rates, as the easier method uses an entity name instead of a class name, and the other method requires knowing the name of the spawners (which can be figured out, just not taken the time to do so yet).

Share this post


Link to post
Share on other sites
2 minutes ago, Jerryn said:

The can be disabled from spawning by using the following in your game.ini.

NPCReplacements=(FromClassName="ShipNPC_Brig_C",ToClassName="")

Not worked out the code yet for changing their rates, as the easier method uses an entity name instead of a class name, and the other method requires knowing the name of the spawners (which can be figured out, just not taken the time to do so yet).

This works cause there gone on my server , thanks

Share this post


Link to post
Share on other sites

Are you guys talking about the ships of the damned? I keep hearing people refer to "ghost ships", there's only one ghost ship and unless you made a ship path and assigned its blueprint it won't spawn at all. Those little glowy green ships are Ships of the Damned.

Share this post


Link to post
Share on other sites
40 minutes ago, Morgrhim said:

Are you guys talking about the ships of the damned? I keep hearing people refer to "ghost ships", there's only one ghost ship and unless you made a ship path and assigned its blueprint it won't spawn at all. Those little glowy green ships are Ships of the Damned.

There talking about the ships of the damned ....

 

Share this post


Link to post
Share on other sites
Posted (edited)

You can change the Damned spawnrate by using the following arguments.

ServerCustomDatas1: NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult

ServerCustomDatas2: 1.0,1.0,0.1

This will reduce the spawn rate of damned with 90%
EDIT: Play around with the last value (0.1) of ServerCustomDatas2 to change the spawn rate.

0.1 = 10% of Normal spawnrate
0.2 = 20%
0.3 = 30%
And so on
1.0 is normal official server spawnrate


After applying the arguments, you must restart server, and then you need to visit every grid (by ghost cmd or fly cmd) and use "cheat DestroyWildDinos" to remove already spawned damned from the server. This will kill animals too, but they respawn quite fast.

Edited by HelixU4
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, HelixU4 said:

You can change the Damned spawnrate by using the following arguments.

ServerCustomDatas1: NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult

ServerCustomDatas2: 1.0,1.0,0.1

This will reduce the spawn rate of damned with 90%
EDIT: Play around with the last value (0.1) of ServerCustomDatas2 to change the spawn rate.

0.1 = 10% of Normal spawnrate
0.2 = 20%
0.3 = 30%
And so on
1.0 is normal official server spawnrate


After applying the arguments, you must restart server, and then you need to visit every grid (by ghost cmd or fly cmd) and use "cheat DestroyWildDinos" to remove already spawned damned from the server. This will kill animals too, but they respawn quite fast.

I added

ServerCustomDatas1: NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult

ServerCustomDatas2: 1.0,1.0,0.1

to my server. Restarted everything. Did a destroywilddinos in logged in as admin. Watched the fleet of the Damned explode then spawn right back in. I tried 0.1, 0.01 and 0.001. No change. They are just as bad a cockroaches.

Edited by TruWrecks

Share this post


Link to post
Share on other sites
3 minutes ago, TruWrecks said:

I added

ServerCustomDatas1: NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult

ServerCustomDatas2: 1.0,1.0,0.1

to my server. Restarted everything. Did a destroywilddinos in logged in as admin. Watched the fleet of the Damned explode then spawn right back in. I tried 0.1, 0.01 and 0.001. No change. They are just as bad a cockroaches.

You added those values in the GridEditor, exported and overwrote the existing ones? Then restarted and did the admin command?

It works on my server. I have 6 grids, Sailed a lot today, only saw 1 damned during a 4 hour session

Share this post


Link to post
Share on other sites
Posted (edited)
40 minutes ago, HelixU4 said:

You added those values in the GridEditor, exported and overwrote the existing ones? Then restarted and did the admin command?

It works on my server. I have 6 grids, Sailed a lot today, only saw 1 damned during a 4 hour session

Where in the GridEditor do these need to go? Global Setup or somewhere else? Can you screenshot the way you entered it? Be careful not to show passwords.

Edited by TruWrecks

Share this post


Link to post
Share on other sites
4 minutes ago, TruWrecks said:

Where in the GridEditor do these need to go? Global Values or somewhere else? Can you screenshot the way you entered it? Be careful not to show passwords.

Here, you must do this for every grid you want the effect on.

And you must visit all grids and use the command "cheat DestroyWildDinos" so use the fly command and visit all of your grids and use that command.

nodamned.jpg

Share this post


Link to post
Share on other sites

After adding that in to the map grid and restarting everything I got this. There are 9 Damned ships in that pic after the destroywilddinos. Something else must be the issue.

20190101192803_1.jpg

Share this post


Link to post
Share on other sites

This was added to the ServerGrid.json after saving and exporting the from the editor.

 

      "oceanEpicSpawnEntriesOverrideTemplateName": "NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult",
      "NPCShipSpawnEntriesOverrideTemplateName": "",
      "ServerCustomDatas1": "NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult ",
      "ServerCustomDatas2": "1.0,1.0,0.1 ",

 

Found more than 30 in less than 20 min all spawning in fleets.

Share this post


Link to post
Share on other sites
Posted (edited)

When you run the command "cheat destroywilddinos" do you see NPC and animals die? To confirm you are using the correct command? All life except players should instantly die with that command.

So watch some animals or something to confirm its working when using it.

 

Animals will respawn shortly after.

Edited by HelixU4

Share this post


Link to post
Share on other sites

I logged in as Admin and used "cheat destroywilddinos". I have been an Ark server own for a couple years so I am very familiar with this command when setting up servers and testing settings.

I watched the ships get destroyed and they came right back in the same numbers.

Share this post


Link to post
Share on other sites

Does the syntax not supposed to be like this ? :

"ServerCustomDatas1" : ",NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult,",
"ServerCustomDatas2" : ",1.0,1.0,0.1,",

(values are surrounded by commas)

because these values could be inserted into others by the server ?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, TruWrecks said:

I logged in as Admin and used "cheat destroywilddinos". I have been an Ark server own for a couple years so I am very familiar with this command when setting up servers and testing settings.

I watched the ships get destroyed and they came right back in the same numbers.

Very strange. Then I'm out of options. It works fine on my server, and a lot of other people have it working fine too.
That is at least the config that is needed to reduce the spawn rate of the damned.

2 minutes ago, WashWash said:

Does the syntax not supposed to be like this ? :

"ServerCustomDatas1" : ",NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult,",
"ServerCustomDatas2" : ",1.0,1.0,0.1,",

(values are surrounded by commas)

because these values could be inserted into others by the server ?

 

This is a direct paste from my working json:

Quote

"ServerCustomDatas1": "NPCShipDifficultyMult,NPCShipDifficultyLerp,NPCShipNumMult,ChanceForCold,",
      "ServerCustomDatas2": "1.0,1.0,0.1,0,",
      "ClientCustomDatas1": ",OceanDepthFadeExponent,OceanWaterScatterIntensity,",
      "ClientCustomDatas2": ",-0.6,0.03,",

 

Edited by HelixU4

Share this post


Link to post
Share on other sites

Ok, strange.

Mine look like this :

Quote

"ServerCustomDatas1": ",DisableRain,ChanceForCold,NPCShipDifficultyMult,NPCShipDifficultyLerp,FloatsamQualityMultiplier,",
"ServerCustomDatas2": ",1,1,1.25,0.33,1.2,",

 

Share this post


Link to post
Share on other sites
2 minutes ago, WashWash said:

Ok, strange.

Mine look like this :

 

Hey, if it works, it works

Share this post


Link to post
Share on other sites
Posted (edited)

Hi guys.

I use this line in Game.ini of all block and it work
My path for one block: C:\Atlas\ShooterGame\Saved\00\Config\WindowsServer

[/Script/ShooterGame.ShooterGameMode]
DinoSpawnWeightMultipliers=(DinoNameTag=PathFollowingGhostShip,SpawnWeightMultiplier=0.3)


You must need to shut down the server before make this change. Reboot server and do DestroyWildDinos on all block.

Edited by TBLK
  • Like 1

Share this post


Link to post
Share on other sites

Look like the NPCShipNumMult doesn't work with old map file.
not sure why but asked lot of server admins they have the same issue also.

Share this post


Link to post
Share on other sites
2 minutes ago, chun1617 said:

Look like the NPCShipNumMult doesn't work with old map file.
not sure why but asked lot of server admins they have the same issue also.

Works fine with my map file. I've been working on the same map since day one. Maybe you are using an older GridEditor?

4 minutes ago, TBLK said:

Hi guys.

I use this line in Game.ini of all block and it work
My path for one block: C:\Atlas\ShooterGame\Saved\00\Config\WindowsServer

[/Script/ShooterGame.ShooterGameMode]
DinoSpawnWeightMultipliers=(DinoNameTag=PathFollowingGhostShip,SpawnWeightMultiplier=0.3)


You must need to shut down the server before make this change. Reboot server and make DestroyWildDinos on all block.

Remember that there is a big difference between Ghost Ship and Ship Of the Damned.

The ghost ship is a boss and has only one spawn. It looks like the black pearl from pirates of the Caribbean, only it glows green. And appears from the bottom of the sea.
The damned are the ship that has spikes in the back and just cruise around

 

Share this post


Link to post
Share on other sites
33 minutes ago, HelixU4 said:

Works fine with my map file. I've been working on the same map since day one. Maybe you are using an older GridEditor?

Remember that there is a big difference between Ghost Ship and Ship Of the Damned.

The ghost ship is a boss and has only one spawn. It looks like the black pearl from pirates of the Caribbean, only it glows green. And appears from the bottom of the sea.
The damned are the ship that has spikes in the back and just cruise around

 
1

I tried to update with latest version of GridEditor but still got the same problem.
To be honest I am not sure if I didn't something wrong from start.

Did you gen the new map from the lastest version of GridEditor?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×