Jump to content

dtmaster

[SOLVED] i can't traveling to another grid on my 2x2

Recommended Posts

When i will travel to another grid i become a timeout and can not connect to server. not to the old grid and not to the new grid.. 

settings all correct on my server.. Ports are free..

wath is this for a crap?

PS: sry english is google translate..

Edited by dtmaster

Share this post


Link to post
Share on other sites

Did you put the correct ServerX=## and ServerY=##  and AltSaveDirectoy=##  coords in your specific starting .bat files?

Each .bat file has to be set with his own coords that have to correspond with each server.

You can check it in your .Json file. Open it and look for ( example )  "gridX": 0, "gridY": 2, and "name"

So you have to look in the Json file for 4 of this X and Y and name

ShooterGameServer.exe Ocean?ServerX=0?ServerY=0?AltSaveDirectoryName=00

Share this post


Link to post
Share on other sites

yes its all correct.. 

i become Traveling message, then timeout and then no connect to server..

Edited by dtmaster

Share this post


Link to post
Share on other sites

I had this problem for like 2 days straight and I was gonna give up but you need to triple check the following:

Make sure all 4 servers ports, query ports, and seamless ports are added to your firewall.

Game and query ports are up, seamless is TCP

 

Next check if your seamless ports are in your server grids on the editor. 

Next check if ?seamlessport= is added to your command lines on each servers.

 

Finally check you have seamless ports are added with commas in your default usersettings.ini

 

Ex 27000,27005,27010,27015

 

 

Share this post


Link to post
Share on other sites

I solved the problem. It was NOT the firewall etc. I used following ports query = 57555, game = 5755, seamless = 27000 grid2 then 57556,5756,27001 and so on. that did not work. have the ports changed at grid 2,3 and 4 querry and game port each 2 higher than previous grid and seamless each 4 higher than previous. then restart and it worked.

In the GameUserSettings.ini I had and never had registered seamless ports. Also stood or stands of it nowhere. But it works now.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, dtmaster said:

I solved the problem. It was NOT the firewall etc. I used following ports query = 57555, game = 5755, seamless = 27000 grid2 then 57556,5756,27001 and so on. that did not work. have the ports changed at grid 2,3 and 4 querry and game port each 2 higher than previous grid and seamless each 4 higher than previous. then restart and it worked.

In the GameUserSettings.ini I had and never had registered seamless ports. Also stood or stands of it nowhere. But it works now.

 

Yes, the servers use more ports than those 3, so for example if you use 57555, 5755 and 27000 in your config it will also use port 5756 which will make your next server fail if it is configured to use 57556, 5756 and 27001 as an example.  Port numbers do not have to be in sequence for the servers, so you can do like 57555, then 57565 and then 57575 etc...

Share this post


Link to post
Share on other sites

Hello folks,

 

I've been having that same problem in a 2x2 private server.

 

I've also set all ports like 57561/5761/27000, 57565/5765/27005, 57561/5771/27010 and 57575/5775/27015, added in the firewall inbound rules, (later have tried to turn firewall offl), my ServerGrid.json is matching  with these settings and startup .bat's files too. Unfortunatly I've still been stuck in travelling grid.

 

I don't know what else can I do. Can anybody please lead me a tip?

 

E3B014F5DE824F1846294040D9285B58BD3A4C70

 

Thanks

 

 

Edited by Cyber
adding situation's image

Share this post


Link to post
Share on other sites
On 2/4/2019 at 2:58 AM, dtmaster said:

you have set on two grids 57561

Oh.. my bad... I've just wrote wrong. I mean 57561, 57565, 57571, 57575. 

 

There is no conflicting port. 

 

Let me enum all the steps that I'm understanding to be necessary: 

 

1. ServerGrid.json: port, gamePort and seamlessDataPort must be setted as unique ports with at least two "spaces number" 
 for gamePort and four for seamlessDataPort, to each grid server. IP I was point to ddns.net hostname that points to my public server IP. 

2. ServerGrid.json and Lauch Scripts (.bat) must match the same gridX and gridY ((0,0) (0,1) and so on), query port (e.g. 55561), gamePort (e.g. 5561) and SeamlessIP to public IP (using dns here again)

3. One process (.bat) for each grid/server;

4. Firewall inbound rules free those ports (I've been disabled the firewall and have tested adding those ports too except RCON ports)

5. In DefaultGameUserSettings.ini: was configured as SeamlessDataSocketPort=27000,27005,27010,27015

 

Please.. What am I missing?

 

Notice that there aren't any red wall at grid boundaries, so we know that instances are having the "conversation" properly. It seems that only clients can't migrate the connection to next grid. 

 

 

Share this post


Link to post
Share on other sites
On 2/6/2019 at 10:51 PM, Cyber said:

Oh.. my bad... I've just wrote wrong. I mean 57561, 57565, 57571, 57575. 

 

There is no conflicting port. 

 

Let me enum all the steps that I'm understanding to be necessary: 

 

1. ServerGrid.json: port, gamePort and seamlessDataPort must be setted as unique ports with at least two "spaces number" 
 for gamePort and four for seamlessDataPort, to each grid server. IP I was point to ddns.net hostname that points to my public server IP. 

2. ServerGrid.json and Lauch Scripts (.bat) must match the same gridX and gridY ((0,0) (0,1) and so on), query port (e.g. 55561), gamePort (e.g. 5561) and SeamlessIP to public IP (using dns here again)

3. One process (.bat) for each grid/server;

4. Firewall inbound rules free those ports (I've been disabled the firewall and have tested adding those ports too except RCON ports)

5. In DefaultGameUserSettings.ini: was configured as SeamlessDataSocketPort=27000,27005,27010,27015

 

Please.. What am I missing?

 

Notice that there aren't any red wall at grid boundaries, so we know that instances are having the "conversation" properly. It seems that only clients can't migrate the connection to next grid. 

 

 

Did you ever get a fix for this as i too am having this issue  my ports go up in 10's on all off them  E.G:  A1 = 57555 & 5755 & 27000  A2 = 57565 & 5765 & 27010 andd so on for all 9 instances. Pulling my hair out trying to work this issue out.

Share this post


Link to post
Share on other sites

I dont see why you need to add SeamlessDataSocketPort=27000,27005,27010,27015 to the defaultgameusersetttings seems to work fine without it...

Share this post


Link to post
Share on other sites

Very Confused Why so much helpful information is hidden. I have YET to find 1 Post from someone who figured this out that has shared what the Fix actually is. Seams those who do End up writing a Full program to help you set up your Grids. Which is nice. But the fact that those usually get updated weekly and for me every time that takes place I either barely get my database recovered. Or I have a total wipe. Really makes me want to host without a crutch. Will Anyone Come forward with A definitive answer? Where are the Devs at? 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Anything on this guys? Ports are set up correctly, border is not red. Cannot travel between shards.

[UPDATE] My issue was that all of my shards were using my external DNS name rather than a hard set IP. I believe it caused an issue with Redis communication on the inside - even though the host can resolve the DNS name and hair-pinning on the router is there. Hard set IP and maps and shard transfers work normally. I would rather use the name, but I don't think my IP changes that often - when it does I will have to shut down the cluster to update the shards.

Edited by yaK
Fix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×