Jump to content

jedahdemon

Issue traveling between cells on a grid.

Recommended Posts

I have a private server setup with a 3x3 grid, however for some reason whenever I travel between cells in the grid rather than popping me out on the other side of the grid line, the server is putting me in the center of the grid. Is there a setting that is causing this that I'm missing?

Each one is using a different Seamless port starting at 28000 and increasing in increments of 4 (28004, 28008, 28012, etc...). 

Share this post


Link to post
Share on other sites

I'm having the same issue as well. I have tried different ports and varying spaces from each other. It has to be something else. Maybe something I need to add in config to spell out the seemless port?

 

 

ServerGrid.json

Share this post


Link to post
Share on other sites
3 minutes ago, LVviper said:

I'm having the same issue as well. I have tried different ports and varying spaces from each other. It has to be something else. Maybe something I need to add in config to spell out the seemless port?

 

 

ServerGrid.json

The port spacing looks ok.

Where you say  "port": 57560, check that you have ?QueryPort=57560 on the appropriate command line;
and for "gamePort": 47560, check you have ?Port=47560  on the appropriate command line.

Also double check that you're port-forwarded all port numbers through your router.

So you should port-forward 57560 to 57579, 47560 to 47579, and 27000 to 27019

 

Beware that if you're running Steam on the same machine as the server, then Steam reserves some ports for its own use.
Your 27000... ports fall into that range...
https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711

Share this post


Link to post
Share on other sites

I have spaced the ports by 1, 2, 4, 5 etc.. I have used 57560, 47560, 28000, 27000 ranges. I have port forwarding enabled on router.  Your mentioned items in command line have QueryPort, gamePort, and SeemlessIP.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, LVviper said:

I have spaced the ports by 1, 2, 4, 5 etc.. I have used 57560, 47560, 28000, 27000 ranges. I have port forwarding enabled on router.  Your mentioned items in command line have QueryPort, gamePort, and SeemlessIP.

 

 

"port" in the json file is equivalent to "queryport" on the command line.
"gameport" in the json is equivalent to "port" on the command line.
"seamlessport" isn't needed on the command line.

Dog knows why GS did it this way, it's an endless source of confusion.

Note that I have RCON and Query ports the same because RCON is TCP and Query is UDP, so they're using different protocols.

ShooterGameServer.exe "Ocean?ServerX=0?ServerY=0?AltSaveDirectoryName=Grid00?ServerAdminPassword=xxxxxx?RCONPort=27230?QueryPort=27230?Port=27232"

      "gridX": 0,
      "gridY": 0,
      "MachineIdTag": "",
      "ip": "xx.xx.xx.xx",
      "port": 27230,
      "gamePort": 27232,
      "seamlessDataPort": 27234,
 

Share this post


Link to post
Share on other sites
6 hours ago, DeepSeaDuo said:

"port" in the json file is equivalent to "queryport" on the command line.
"gameport" in the json is equivalent to "port" on the command line.
"seamlessport" isn't needed on the command line.

Dog knows why GS did it this way, it's an endless source of confusion.

Note that I have RCON and Query ports the same because RCON is TCP and Query is UDP, so they're using different protocols.

ShooterGameServer.exe "Ocean?ServerX=0?ServerY=0?AltSaveDirectoryName=Grid00?ServerAdminPassword=xxxxxx?RCONPort=27230?QueryPort=27230?Port=27232"

      "gridX": 0,
      "gridY": 0,
      "MachineIdTag": "",
      "ip": "xx.xx.xx.xx",
      "port": 27230,
      "gamePort": 27232,
      "seamlessDataPort": 27234,
 

Looks like the adding RCON to match QueryPort and changing my IP from DNS name to IP, things are working. Thx Deepseaduo!!

Share this post


Link to post
Share on other sites
8 hours ago, LVviper said:

Looks like the adding RCON to match QueryPort and changing my IP from DNS name to IP, things are working. Thx Deepseaduo!!

Nice one LVVIPER.  It'll have been the DNS name causing the problem for you.  I didn't notice that in your json file.
 

Share this post


Link to post
Share on other sites

FYI: You do NOT want to have your RCON port set the same as your Query Port.  If you don't use RCON, it probably won't hurt, but still not a good idea.

Share this post


Link to post
Share on other sites
5 hours ago, Phoenix125 said:

FYI: You do NOT want to have your RCON port set the same as your Query Port.  If you don't use RCON, it probably won't hurt, but still not a good idea.

QueryPort uses UDP, and RCON uses TCP.  They're different protocols and don't interfere with each other.
I use an RCON program to allow chat across grids.  It works fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×