Jump to content

Danarchy

Unable to tame creatures as of today

Recommended Posts

Kraken - NA PVP

M4

Just starting today I am unable to tame creatures.  I have tried a bear and a horse and I am unable to feed them for some reason once they are bola'd.  I am only given the option "hold to release bola" and no "feed" option ever appears.  I have the recommended food item in my "0" slot and I have tried multiple bears and horses in different locations with no luck.  I am feeding directly at the mouth per usual.  I have specced out to taming level 3 and taming advanced taming proficiency.  I just recently re-specced earlier today so i don't know if that could be a part of the issue. 

https://imgur.com/a/ttB4lZQ

N/A

cheat TP M4 -101310 351973 5558

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×