Jump to content

Upcoming Ally Crew Count Patch Read more... ×
Sign in to follow this  
Bridgmark

treasure map not showing beacon???

Recommended Posts

I have the map in my hotbar and go to the spot but there's no beacon. Been like this for a few days. I tried different servers and different computers (Home and Work) but still my treasure maps not showing beacon???

Share this post


Link to post
Share on other sites

Post pictures of map and location and your location.
If the map is really high up, you can not see the beacon from below sometimes.

KuKumba

Share this post


Link to post
Share on other sites

There’s another possible solution that happened to me. I’ve been playing since day 1 and knew I was at the correct island. What it was there was an identical island in the grid. Sound simple but I was sure I was on the island but was not. 

Share this post


Link to post
Share on other sites
27 minutes ago, gumbyc said:

There’s another possible solution that happened to me. I’ve been playing since day 1 and knew I was at the correct island. What it was there was an identical island in the grid. Sound simple but I was sure I was on the island but was not. 

possibly.. ive seen them on freeports.. 

Share this post


Link to post
Share on other sites

We’ve had this happen. Two islands the identical shape in the same region, but if you look closely you can see differences in the details for ridges, etc.

Share this post


Link to post
Share on other sites

Almost certainly there is an island that is duplicate of the one you are standing on, found within the same zone. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×