Jump to content

Recommended Posts

Any Ideas on how to get a dedicated server up and running?  I have previously had a 4x4 atlas server going for some time, but this seams like a whole new setup.

 

Share this post


Link to post
Share on other sites

found this in the discord server

 

start ShooterGameServer.exe Blackwood? -log -server -NoSeamlessServer

Different map name, and -NoSeamlessServer is required due to these servers not needing a database

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Anybody set their Blackwood server to increase harvesting, exp, etc?

Tried settings in game.ini and doesn't seem to work.

Can't set server password either (seen others with this issue on discord too).

 

--

Edit. I was editing the wrong .ini file as I was using AltSaveDirectoryName and then removed that later so it was using the default directory.

Still can't set ServerPassword though.

Edited by Cradz

Share this post


Link to post
Share on other sites

CRADZ: Are you editing the ini files in \ShooterGame\Saved\Blackwood\Config\WindowsServer ?

Are you able to share your commandline please (remove any passwords).
I've got ShooterGameServer.exe "Blackwood?SessionName=PVE Blackwood Test?AltSaveDirectoryName=Blackwood?ServerAdminPassword=xxxx?RCONPort=27130?QueryPort=27130?Port=27135" -NoSeamlessServer -Exclusivejoin -log -server -NoCrashDialog 

The server appears to start and creates a save file, but I'm unable to connect.
Ports are all forwarded and firewall is open (I previously used these port numbers for the Ocean map).

Share this post


Link to post
Share on other sites

I have this in a .bat so I can run via a shortcut

start ShooterGameServer.exe Blackwood?ServerPassword=XXX?ServerAdminPassword=XXX?MaxPlayers=20?ReservedPlayerSlots=0?QueryPort=57561?Port=5761? -log -server -NoSeamlessServer -NoBattlEye

 

.. oh and I might have just seen why it's not picking up my game.ini .. might be using the original folder as I redid that .bat lol

 

Share this post


Link to post
Share on other sites
2 minutes ago, Cradz said:

I have this in a .bat so I can run via a shortcut

start ShooterGameServer.exe Blackwood?ServerPassword=XXX?ServerAdminPassword=XXX?MaxPlayers=20?ReservedPlayerSlots=0?QueryPort=57561?Port=5761? -log -server -NoSeamlessServer -NoBattlEye

 

.. oh and I might have just seen why it's not picking up my game.ini .. might be using the original folder as I redid that .bat lol

 

Thanks for your reply.  I forgot that BattleEye used to be a problem for Atlas.  I'll try adding that command line arg.

Share this post


Link to post
Share on other sites

Yup my issue was I had set a new folder on my bat to start in and then removed that later so I was editing on the wrong game.ini .. doh!

Now all good and my exp and harvesting rates are increased.

Share this post


Link to post
Share on other sites

Yea.. filter by your server name too as not all Blackwood severs show (which is good right now as you can't set a password)

 

Share this post


Link to post
Share on other sites
Posted (edited)

You CAN PW a server! And you change all of the server settings exactly the same way you do with a normal Atlas server or Ark server for that matter

Harvest Rates and breeding are in the game.ini
XP is all in the GUS

Edited by SteveM

Share this post


Link to post
Share on other sites
2 hours ago, SteveM said:

You CAN PW a server! And you change all of the server settings exactly the same way you do with a normal Atlas server or Ark server for that matter

Harvest Rates and breeding are in the game.ini
XP is all in the GUS

So how are you getting the PW on a Blackwood server? You didn't really elaborate and we've tried it in the command line AND in the server settings and still no PW...

Share this post


Link to post
Share on other sites

I have my Blackwood server up, just a small one formates and stuff,  still working on that password too,  tried in the bat file, or in the gus, under session name, I tried ServerPassword= and SessionPassword=

 

do caps matter?

 

Share this post


Link to post
Share on other sites
18 hours ago, SteveM said:

You CAN PW a server! And you change all of the server settings exactly the same way you do with a normal Atlas server or Ark server for that matter

Harvest Rates and breeding are in the game.ini
XP is all in the GUS

 What's the name of your server with a password? I have yet to see a Blackwood server with a password set.

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Momoniu said:

I have my Blackwood server up, just a small one formates and stuff,  still working on that password too,  tried in the bat file, or in the gus, under session name, I tried ServerPassword= and SessionPassword=

 

do caps matter?

 

It should work under ServerSettings (ServerAdminPassword does work) but yea ServerPassword doesn't for me or several others on the Atlas discord.

Really annoying having random people show up on my server. 

When I look at Server Info via the Admin Menu it does show Server Password *** so it's being set but just not being enforced when somebody joins.
 

Edited by Cradz

Share this post


Link to post
Share on other sites

IF....IF   we get our server up and running, how can we get and use the whitelist/blacklist abilities of an admin so no randoms join?

We can't connect to the server and can't see it in the list.

Share this post


Link to post
Share on other sites

so does any one have an actual guide to get this working properly step by step?

Share this post


Link to post
Share on other sites
53 minutes ago, Sylis said:

so does any one have an actual guide to get this working properly step by step?

I'm hoping for the same thing .... we're still having issues getting the server to respond and show up on the server list.

Share this post


Link to post
Share on other sites
Posted (edited)

so how i did it is as follows,  

fresh install of atlas server

create a .bat file with this command line

start C:\atlas\ShooterGame\Binaries\Win64\ShooterGameServer.exe Blackwood?ServerPassword=xxx?ServerAdminPassword=xxx?QueryPort=57560?Port=5760?MaxPlayers=12?ReservedPlayerSlots=0? -log -server -NoSeamlessServer -NoBattlEye

open ports on router

run it,  then exit, go to the newly created folder named C:\atlas\ShooterGame\Saved\Config\WindowsServer and edit GameUserSettings.ini, down the bottom under SessionSetting SessionName=call this what you like

save/exit

 

run bat file again,  then in the atlas game,

click, join new atlas, bottom left is a check box for show non atlas server,  then search the name in the search feild

Edited by Momoniu
forgot a step

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, Hattrix said:

IF....IF   we get our server up and running, how can we get and use the whitelist/blacklist abilities of an admin so no randoms join?

We can't connect to the server and can't see it in the list.

I tried Whitelist and set ReservedPlayerSlots to the same value as MaxPlayers and it gives a Server Full message even if you're on the Whitelist. I thought that would work ~shrug~ 

Is there a different flag for Whitelist only joining?

I can ban but have to see them on the server to do that (I do sleep though 😄 )

Edited by Cradz

Share this post


Link to post
Share on other sites

*Sigh* It is with great agony that I ask this but where are y'all getting the server files from? I haven't been able to find the steam ID to pull it down successfully on my dedicated. Any insight is greatly appreciated. I need my high seas back.

Thanks.

Share this post


Link to post
Share on other sites

We have our dedicated server up and running just fine - The players love it.

My question; To add other mods to this game, where do I list the Mod ID's? Normally they went into the ServerGrid.json file but Blackwood doesnt use a ServerGrid.json file, so which file do I list the mod numbers please?

Share this post


Link to post
Share on other sites

Going to give this a try:

If you are using a non-seamless map (Such as Blackwood) follow the below steps instead 

1. Find a mod that you want to use on the steam workshop for example https://steamcommunity.com/sharedfiles/filedetails/?id=1652044230 
2. In the game panel click on install/update mods and enter in the mod id (example 1652044230 if there are multiple mods seperate them with a , example 1652044230,1652044230)
3. add the mods to your GameUserSettings.ini configuration file and save it (eg.   ActiveMods=1652044230,1652044230
4. Upload the .mod files from your pc to the server

5. restart your server.

Share this post


Link to post
Share on other sites

I got the blackwood server setup, however I feel that I may have missed something, there are no fish in the oceans, and when i relaunch the game for some reason I cannot rejoin my server with the quick rejoin last server button on the games main menu.  Anyone know how to fix these issues?

Share this post


Link to post
Share on other sites

I think the devs know about the lack of fish, but I don't know what their plan is.

I think the LAST JOIN option is for dedicated servers, because I have the same thing happen to me, but you just have to click Join New and go in that way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×